Previous 1 2 Next 22 Replies Latest reply: Jul 30, 2010 8:40 AM by slimgym
asimpson4 Level 1 Level 1 (0 points)
I have an officially unlocked iPhone 3GS. The APN settings menu was available for editing with pre 3.1.3 firmware but has disappeared with 3.1.3 and 4.0. I have spoken with Apple where I was told to restore the phone to defaults and start over, this didn't work. The Apple support papers distinctly say that the APN settings should be available for edit with an unlocked phone OR when the telephone provider allows it. As this is an unlocked phone the APN should be available. I use the phone with 2 SIM cards, 1 AT&T and 1 Telstra (Australia) card because of travel hence having the APN available is a great help. The 2 other phones in our family have suffered the same fate so this is obviously a firmware problem, not hardware.
Any ideas on our to get the APN settings menu back?

iPhone 3GS, iOS 4
  • Gord Ell Level 1 Level 1 (0 points)
    I have the same problem ...
  • geekyaleks Level 1 Level 1 (0 points)
    I am very interested in finding out about this - I am in Canada, and here Apple is selling a factory unlocked iPhone 3GS. I just posted this as a question... You can keep an eye on my thread also...

    =================================

    This summer, I was in east europe with my unlocked google nexus one, and was able to happily use local SIM cards - to enable 3G internet functionality, I just needed to configure APN settings as per carrier spec, and - voila, Internet etc...

    This whole experience has left me with the idea, that for a factory-unlocked phone to be Internet 3g functional, it needs the ability/menu choices to set up custom APN settings.

    Apple Canada is offering an iPhone 3GS (8gb) that is factory unlocked, but unless one is able to set/change APN settings, it's kind of useless for internet...
    Does anyone know - does the Canadian Factory Unlocked Apple iPhone 3GS have the APN settings menu? My own Rogers-locked iPhone 3GS does NOT have the ability to set APN settings... Is the ability to view/set APN settings controlled by the carrier (whose sim card I inserted into the iPhone?)??
  • Templeton Peck Level 9 Level 9 (59,885 points)
    Use the iPhone Configuration Utility to set the APNs.
  • steve copeland Level 1 Level 1 (55 points)
    In the UK, we just call the carrier who send a sim update which sets the APN. I do this when I change between O2 and Orange when in Cornwall.
  • geekyaleks Level 1 Level 1 (0 points)
    In as much as I appreciate the fix suggestion, the idea of carrying a laptop when travelling just to change the APN settings on the phone is a kind of silly.. Why can't they just add the APN settings to the iPhone menus? This summer I covered 3 east european countries while driving, and was able to change APN settings on my back up phone (google nexus one) with no problem.. No "configuration utility" needed...
  • slimgym Level 1 Level 1 (0 points)
    My unlocked, brand new iPhone 4 allowed me to get in to change the APN settings which I did to use it with Virgin Mobile. Worked a treat. Then tonight, iTunes popped up "An update to the carrier settings is available" and I stupidly said yes to download and install. Now the menu is gone. I can't change the detail.

    How on earth am I supposed to change the settings when I go abroad and use a local SIM now?
  • geekyaleks Level 1 Level 1 (0 points)
    Wow, I am impressed that you were able to see the APN settings in the first place!! It is very reassuring to be able to know that. I think, that the carrier who sent you the "carrier update", decided to "shut down" the APN settings for THEIR sim! I think that if you were to take another carrier's SIM, the APN settings will reappear... Read this: http://support.apple.com/kb/ht2283

    "Additional Information
    You cannot change the information in the Cellular Data Network screen unless you have an authorized, unlocked iPhone or your carrier allows editing the APN settings."

    I think that it would be worthwhile to test it out with a different carrier's SIM...
  • slimgym Level 1 Level 1 (0 points)
    Yes I was pleased when I got the iPhone4 the APN settings were freely changeable. Luckily I got back to this state with a restore and am now ignoring the carrier update message.

    The 7.1 carrier update only appeared today, probably from T-Mobile as a user convenience. They are the network upon which my provider (Virgin) operate. Sadly the Virgin APN is somewhat different from the T-Mobile APN and the carrier update hides the menu so you can't change them!

    Virgin charge £5 a month for capped 1GB, they don't offer iPhone so don't care how or on what device it's used.

    You are right this is SIM based since the iTunes prompt does not appear if I'm in flight mode, however the APN menu does not re-appear if I take the SIM out (though it might change if I put another SIM in).

    This control freakism is a big shame. I've a Nokia E51 with Joikuspot which turns it into a wifi/BT hotspot and no restriction on changing the APN there. There are better ways to stop people tethering rather than crippling the device.
  • CarlFullen86 Level 1 Level 1 (0 points)
    Hi All,

    I was given my partners old iPhone (3g running iOS4) after he upgraded, we got it unlocked from Apple, as I'm on contract with Virgin Mobile (they're pants but i'm stuck with them). I eventually got the mobile data settings and the MMS settings to work. Now just a few days later I plugged my phone into iTunes and it updated to 4.0.1 also a message box popped up saying updating carrier settings, now I have no mobile internet!

    I have gone back into the settings >> General >> Network and "Cellular Data" has gone. The whole Network page has changed to "Switches"; perviously there was manual entry options for data connections, MMS, visual voicemail settings etc

    Enable 3G On/Off
    Mobile data On/Off
    data roaming On/Off

    Set up Internet Tethering

    VPN (Not Connected) - This option looked interesting, but when I click on it there are millions of options, its all gobble-de-gook to me.
    WiFi On/Off

    Sounds like we all have the same problem... execpt my previously working APN setting are now not working
  • slimgym Level 1 Level 1 (0 points)
    The one you're missing is "Cellular Data Network" which sits under "Mobile Data".

    You need to restore (before your backup gets overwritten) and then not apply the carrier settings once restored which pops up in iTunes when you connect the phone. When I restored and went back into the data settings the APN was set to general.t-mobile.uk which I had to reset to goto.virginmobile.uk.

    I thought I was going mad when it first happened. I could understand on my old 3G when I was tied to O2 and locked to O2, but this phone is supposedly SIM free, unlocked, not tied nor subsidised.
  • MaineRoadKid Level 1 Level 1 (5 points)
    I just had the exact same Virgin/T-Mobile problem, but I appear to have avoided the major faff of doing a restore by going to www.unlockit.co.nz on the phone and creating a custom profile with resurrected APN settings My general 'About..." settings still show Network as Virgin but Carrier as T-Mobile UK 7.1. However on the General page I have a profile setting, which shows the custom profile I created, and it appears to be using that. Certainly I have checked my usage with Virgin and there is no roaming...
  • slimgym Level 1 Level 1 (0 points)
    The restore wasn't that painful and everything came back as before in under an hour. I'd rather have the settings there to change as I like - occasionally I do use tethering and I don't know that the website generated carrier files can include the APN for tethering.

    Does your MMS still work with the website ipcc?

    I guess the menu might re-appear if you put a foreign SIM card in there which is fine, my concern was the menu had disappeared for good and if I try to go abroad and use a local SIM I'd have wasted my money.

    Hopefully apple will realise the error and release a proper carrier file for Virgin UK. They probably released the T-Mobile one as they will be partnering for contract sales and might charge extra for tethering as O2 do.
  • MaineRoadKid Level 1 Level 1 (5 points)
    I just MMSed a picture to myself on my second phone (Palm Pre) and it's worked. Need to check whether I'm charged (ie not going via Virgin, but via T-Mobile). Having said that, I'm not sure MMSs are part of my Virgin contract, so I might have been charged anyway!

    Fingers crossed there'll be a jailbreak for the iPhone 4 soon, and more options for this he he
  • slimgym Level 1 Level 1 (0 points)
    From what I can see the carrier update applies:

    APN: general.t-mobile.uk
    MMSC: http://mmsc.t-mobile.co.uk:8002
    MMS Proxy: 149.254.201.135:8080

    If it works with a Virgin SIM I don't see how T-Mobile can bill you if you don't have a contract with them.

    For what it's worth I put my O2 micro SIM in there and the "tethering" part of the configuration disappears, it fills in the O2 APN's (which are wrong as they're for contract) but at least you can access the menu and change them back.

    When I put the Virgin SIM back the tethering bit re-appeared, but I had to fill all the stuff back in again.
Previous 1 2 Next