Skip navigation
This discussion is archived

DVDs now mostly unreadable under OS X 10.6.4 but it's not hardware

3836 Views 8 Replies Latest reply: Sep 11, 2010 4:47 PM by rnbarrett RSS
snsok Calculating status...
Currently Being Moderated
Jul 11, 2010 8:17 AM
I have a problem with getting this message when I insert DVDs into my Mac Pro

"The disc you inserted was not readable by this computer."

This occurs when I try most DVDs, such as a DVD containing scanned images I just got back from a scanning service. It occurs when I insert any DVD I have previously burned on this machine. Right now, about the only DVD I can open on my machine is the Mac OS X Snow Leopard installation disc.

When I boot up my Mac under Boot Camp in Windows XP SP3, I can read any DVD in my Mac under Windows. So I am presuming the problem is not bad DVD hardware.

Here's what I have tried:

1. Booting up in Safe Mode: I can only read the Snow Leopard DVD. Other DVDs spin up but then the drive stops, although I do not get an error message

2. Tried doing Repair Disc Permissions twice on my Mac boot drive. A bunch of things were fixed but not the DVD problem.

3. The discs I created previously on my Mac are easily read on a different Windows Vista laptop, so I think there is nothing wrong with the discs.

4. Discs created on my other Windows laptop are readable on my Mac when it's booted up in Windows but not when it's booted up in Snow Leopard.

Here's one other oddity:

I used TrueCrypt to keep an encrypted file container on my boot drive. I DO NOT encrypt the entire drive. It's just basically an encrypted filefolder. Just a few days ago, TrueCrypt has been unable to mount these encrypted files on this machine under Mac OS X. However, when I boot up under Windows, TrueCrypt, which has both OS versions, can read the file just fine.

I think I am going to reinstall Snow Leopard, but I thought I would ask here first.

Thanks, all.
Mac Pro 2008, Mac OS X (10.6.4), Snow Leopard 10.6.4, 2 Quadcore Xeon, 6GB RAM
  • ParkerKuivila Level 2 Level 2 (230 points)
    Did you get this issue ever in the past on previous versions of Snow Leopard? And are you using the stock disc drive or an external one?
    MBP 2.66GHz i7, Mac OS X (10.6.4)
  • rnbarrett Calculating status...
    Thank you so much for posting this. I've been crawling the inTARwebs for the last few days to resolve a related problem. I could not open most dmg files. I got the "no mountable filesystems" message when opening the file, and disk utility kept reporting "invalid BS_jmpBoot in boot block:66671c" when trying to repair a dmg that I could open on another Mac just like mine (same hardware, OS level, etc.). I kept thinking I had screwed things up with TrueCrypt until I read this thread. I deleted the kext you mentioned, restarted, and my problems have gone away. Now I wonder how I am supposed to encrypt files on my memory key. Guess I'll just use TrueCrypt and see how that works.

    No, no! Bad Lexar! Bad!
    iMac 24" Early 2008, Mac OS X (10.5.8), and Vista SP2 with my iPhone OS 3.0.1
  • Alley_Cat Level 6 Level 6 (16,625 points)
    Just had the same problem.

    Bought a 4GB Lexar Secure II drive to transfer content to/from work.

    Suddenly no DVDs can be accessed.

    Removing the kext seems to have fixed.

    Very frustrating, this would have been an ideal cross-platform solution even if it is a bit fiddly.
    Mac OS X (10.5.8)
  • rnbarrett Level 1 Level 1 (0 points)
    Try an IronKey. They support the Mac as well - but it's a more expensive solution.

    https://store.ironkey.com/personal

    I went the TrueCrypt route, and it appears to be working...
    iMac 24" Early 2008, Mac OS X (10.5.6), and Windows 7, Mid-2010 MacBook Pro 15" running the same

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.