Question:

Question: Time for imported AAC files is changing to 789:57:13

Newly imported AAC files created in Audacity are having their

time changed to 789:57:13. In addition, when I tried to play one of these songs

in ITunes for widows, it jumped done to past several other songs and changed

their time to 789:57:13.



The songs will not play on my iPhone with this time. They will

play correctly on a third party app. On my widows computer the correct time is

noted.




Can someone please help?


Windows, Windows 6

Posted on

Reply

Apr 2, 2019 2:16 AM in response to Don_Miguel_Mexico In response to Don_Miguel_Mexico

I am not saying that the following is definitely the issue but it is a possible cause and I suggest you look in to it further.


I have found that often but not always Windows users are prone to accidentally use the wrong file extension for a file - particularly for video files. If hypothetically an MP3 file was given a .mp4 file extension this does not magically convert the file to MP4 format aka AAC but means the file is wrongly named.


As it happens Windows tools seem more forgiving of this type of mistake and Apple or more accurately Mac tools are more rigorous about checking things match properly. Therefore iTunes may see a file with a .mp4 file extension, then look at its contents and see it is not an MP4 file and reject it or in trying to process it get very, very confused. ;)


Similarly at least for video files, I have seen one of the main video 'containers' e.g. MPEG4, AVI, WMV, etc. which can be regarded as just 'envelopes' contain media using a CODEC not normally used with that particular type of container. If again hypothetically a .MP4 file contains instead audio compressed with say the MP3 codec then this would again confuse iTunes which is rigorously obeying the rules whilst other less careful programs might accept it.


Try using a tool like this https://mediaarea.net/en/MediaInfo to give a report on the file. It should list the 'container' format and the codec used. Do this on a working AAC file and a non-working one to compare.

Apr 2, 2019 2:16 AM

Reply Helpful (1)

Apr 2, 2019 12:16 PM in response to Masterdance In response to Masterdance

MediaInfo does not report to anyone except you i.e. the person running it. It is merely an independent tool which lists all the details of media files - specifically the container format, and the codec format.


As I thought I had adequately explained it is a sadly too common problem that media files are either incorrectly named or incorrectly built i.e. container versus codec.


Once you have the details of the bad compared to good files we would have a much better idea if the problem is such or whether it is an apparently valid file and the problem is something else needing further investigation.

Apr 2, 2019 12:16 PM

Reply Helpful

Apr 2, 2019 3:18 PM in response to Don_Miguel_Mexico In response to Don_Miguel_Mexico

Thank you for doing that as I would have no clue. The only thing I can think is that everyday we go on the Apple Feedback (which I believe goes to the engineers or the minds that be) and EVERYONE feedback the issue that the last upgrade has caused. Maybe that will open their eyes and they will do something. Like one person said above - resend out the last version 12.9.3 and fix the bug in 12.9.4 and then reissue it. SO FAR I am not finding any way to fix the issue without months of work.

Apr 2, 2019 3:18 PM

Reply Helpful (1)

Apr 2, 2019 6:34 PM in response to Don_Miguel_Mexico In response to Don_Miguel_Mexico

I am having the same problem. And I am also on the Audacity Forum and there are several others. Personally, I think it is an ITUNES problem. It didn't happen until the last iTunes update which was early last week. I have 2 computers with the exact same songs. My 2nd computer has NOT been updated and all the songs are perfect. On the computer I updated with the NEW iTunes, the songs from Audacity are showing 789 hrs. Now from all that I have tested, MP3 and WAVs that were created in Audacity and imported to ITUNES are OK. The M4a files are not being read right and are converting to 789:57:13 and therefore unreadable. I spent 5 days working with Apple and they say tuff cookies. I feel stuck and don't know what to do. Like I have mentioned I have 6K or more filed that now read 789 hrs. Now if you take that song and re-input into Audacity and convert it MP3 and then reimport back to iTunes, it will work. It is just a ton of work to do it. My songs do work on other apps including Virtual DJ that I use alot

Apr 2, 2019 6:34 PM

Reply Helpful

Apr 2, 2019 6:48 PM in response to Don_Miguel_Mexico In response to Don_Miguel_Mexico

Then I don't know. Where you importing one way before and you changed the type of file that you are importing now.? Mine is very consistant. If I imported using mp3 (which I did for awhile), the song plays fine. However, I switched awhile ago to creating files in audacity and then exporting them using m4a. Those are the ones with the 789 hrs. I don't know - what a mess. Just weird that one computer is not working right and my 2nd computer which has not been updated is just fine. If you hear anything, let me know.

Apr 2, 2019 6:48 PM

Reply Helpful

Apr 3, 2019 4:55 AM in response to Masterdance In response to Masterdance

I would send back feedback everyday to iTunes about the problem. If everyone bombards them maybe they will wake up and reinstall 9.2.3. Did it really start going bad after the last update? Did you change how you were importing from Audacity (i.e. mp3 vs m4a or AAC?)

Apr 3, 2019 4:55 AM

Reply Helpful

Apr 4, 2019 10:27 AM in response to Masterdance In response to Masterdance

In response to Masterdance and following up on his other thread.


I have also raised the issue with Apple. Just a reminder that I am running an iMac on Mojave 10.14.4, which makes me believe it's their problem. Given that, their initial response that 'Audacity is a 3rd party piece of software and so is not supported' is IMHO inadequate and I will follow that up. Other research also suggests that 789:57:13 is a fault code generated by iTunes to say that something's wrong with a file and it has occurred intermittently over the years with many earlier releases of iTunes.


Audacity is a widely-used program, that is frequently supplied with USB vinyl record decks. That's one of the uses I've put it to; to convert some of my old vinyl. I've discovered that virtually all the files created in m4a format (with several versions of Audacity) that I've tried from this source have had their running time altered and become unplayable.


I've also looked at the pragmatic solution of batch conversion programs (m4a to mp3). I came across the free / shareware one from MediaHuman, (there are others) which I have tried briefly (the Mac version) and which seems to work, in that the 'faulty' files quickly convert to mp3 and reimport to iTunes without issues.


This may be a way for others with far more files (& more pressing needs) to resolve the issue until Apple admit there's a problem. I have also updated to the latest version of Audacity (2.3.1) and plug-ins, but I haven't tried to generate m4a files - yet. I will report any progress in due course.

Apr 4, 2019 10:27 AM

Reply Helpful (1)

Apr 4, 2019 11:27 AM in response to robinm0 In response to robinm0

Thank u. I agree with u. Apple needs to wake up. I wish it was as simple as converting to MPs. Unfortunately I have 250 playlists with about 100 songs in each. Alot if songs in multiple playlists. As u know if I convert to MPs it sets up a new song this I have to find the playlists the songs r in and then delete the m4a songs. I have in total 18k songs with maybe 5k corrupted. Disgusting. Apple: Figure it out. Shouldn't be rocket science

Apr 4, 2019 11:27 AM

Reply Helpful

Apr 5, 2019 1:16 PM in response to robinm0 In response to robinm0

I have just discovered this problem, not having used iTunes for a few days, but it must have started at the last update. I too am running an iMac on Mojave 10.14.4. I have quite literally thousands of files affected having spent the last four years ripping my vinyl collection using VinylStudio which converts to m4a and has worked perfectly in that entire time. Until now. To say I am not happy is an understatement. I'm going to try another rip to see if I have the same problem with new files.

Apr 5, 2019 1:16 PM

Reply Helpful
User profile for user: Don_Miguel_Mexico

Question: Time for imported AAC files is changing to 789:57:13