14 Replies Latest reply: Jan 3, 2011 1:29 PM by Alain
Freddie-PR Level 1 Level 1 (0 points)
I have an iPhone 3G model MB702LL.

I just upgraded to IOS4 and now it doesn't detects my home Wifi network. All my other devices connect fine. I have tried the reset, re installed IOS4, Reboot, Turn off and on, etc. Nothing

Apple guys, help me pleeeeeeeaaaaaseeeee

iPhone 4, iOS 4, MacBook Black 13"
  • Sirtimo Level 1 Level 1 (0 points)
    I have exactly the same problem. It says no wifi. Sometimes after rebooting, I can access the wifi menu, but it cant find any networks (the circle keeps turning).

    Also horrible batterydrain.

    I have downgraded to 3.1.3 following the post of ihackintosh, but the problem persists. As if OS4 has demolished my phone
  • pmasknguyen Level 1 Level 1 (0 points)
    I have the same problem
    I cannot access wifi network after Upgrade OS 4.0.
    The Wifi is available but it cannot find any network, it show empty in the list and sometime it show but unable to connect.
    I have tried to reset network, all data, even downgrade to 3.1.2 OS but not help

    I hear someone tell this is the bug from baseband 5.13.04 of Apple and it destroy iphone's Wifi chip. Is it true?

    Please help.
    BR

    Message was edited by: pmasknguyen
  • Pete Badger Level 1 Level 1 (0 points)
    Same here. Upgraded to OS4 and no wifi despite showing wifi connected in settings. I've reset, backed up, restored, taken phone into apple store all with no success. Best I could get from Apple is wait for OS 4.01 with bug fixes. Great, but when!?

    Message was edited by: Pete Badger
  • pmasknguyen Level 1 Level 1 (0 points)
    So from apple store they confirm this is a bug in OS 4.0. is it right?
  • pmasknguyen Level 1 Level 1 (0 points)
    I have tried to update to 4.0.1 but there is still error. Please help.
  • sugardoll Level 1 Level 1 (0 points)
    I upgraded my 3G to 4.0.1 and had the same issue - could not connect to my secure wireless network. It DID, however, connect to my meighbor's unsecured network. I tried resetting Network Settings, resetting All Settings, rebooting my iPhone, rebooting my router, multiple times, all without luck.

    I had to do a FULL RESTORE from iTunes, install as a NEW PHONE and now I can connect to my wireless network. But even after the full restore, I don't see any improvement in phone performance. Still slow, still laggy, still crashes (requiring a reboot) with some apps. And now I have a phone set back to factory default. Grr.
  • subseanomad Level 1 Level 1 (0 points)
    Same problem here...
    Reset All Settings fixed the slow speed and crashing.
    Reset Network Settings has not fixed the Wifi problem.
    Not a happy customer.
  • Beauvais98 Level 1 Level 1 (0 points)
    I have the same problem here on my iPhone. I cannot believe that Apple would release an OS with such a flaw.

    It's about time I upgrade my phone and I am seriously looking at another smartphone than the iPhone.
  • mleprat Level 1 Level 1 (0 points)
    Hi Freddy,

    I got the exact same probleme since yesterday: after installing v4.0.2 on my iphone 3G, the WIFI stopped working. I have a *"No-Wifi" mention in Settings* now. I have a hard time believing that it is a hardware problem since it worked perfectly until then and several of us have the same issue after upgrading the OS...

    Did you (or others) found a way to reset Wifi one way or another?

    Thanks for your help.
    Marc
  • Devere Jones Level 1 Level 1 (10 points)
    I have the same problem. The device shows no WiFi or when it does it drops quickly. If i go into the settings page and into the networks settings, I can see an connect to my Wifi, however the connection only lasts a few seconds (not even enough time to pop open Safari). Before anyone asks i've reset, and restored this device quite a few time with no change.

    Come on Guys!!

    I even paid for your iPhone Developer Program. I've been reading through your material for months which talks about a lot about compatibility, then they release this!- its annoying!

    U've half put me (and countless others) off ever upgrading with this whole bumper fiasco.

    Are you trying to kill off your mobile user base?!

    Your first upgrade has made my phone unbearable to use and now this latest upgrade has killed my wifi! If your going to force people to stick with upgrades then at least make sure they work!

    Seems like you guys only care for those who have deep enough pockets to own your latest products. After almost three years of joy and singing your praise, I now feel more let down than ever!

    I wonder if Apple's staff even read these messages?!!

    Message was edited by: Devere Jones

    Message was edited by: Devere Jones

    Message was edited by: Devere Jones
  • AirinIdaho Level 1 Level 1 (0 points)
    I just upgraded my iPhone 3G 8GB from 3.1.2 to 4.0.2... no wifi for me now! I've done many restores to 4.0, 4.0.2, and even to 3.1.2 (had some errors but it did eventually get me to springboard), no wifi anymore, it seems like upgrading to 4.0.2 irrevocably damaged my wifi in my iPhone... has anybody found a solution? Is this just not a concern to Apple since warranty has expired on the 3G phone?

    Message was edited by: AirinIdaho
  • dmikh Level 1 Level 1 (0 points)
    Same wifi plague. I hoped 4.1 update could help but it didn't. Now my phone doesn't even show a list of wifi networks. It is a pity that $800 device (price in Russia) lasted for only two years. Thinking to switch to something more reliable and not so expensive than iPhone.
  • brockerc Level 1 Level 1 (0 points)
    Same problem here. Immediately after upgrading to 4.0 my 3G (MB0446LL) lost Wifi (...not to mention it runs 10X slower). Occasionally it will ask if I would like to join a network but then is unable to connect.

    I took it into an AppleStore a couple weeks ago and after completely reloading the software 3 times the only advice the guy could give me was to buy a new phone.

    Just updated to 4.1 and still nothing.

    Interesting how the update completely sabotaged the phone right after they released the 4G.
  • Alain Level 1 Level 1 (50 points)
    Hi Freddie

    Could it be a simple and plain hardware issue ?

    Back in march 2010, my former 3G got jailbroken to connect to Virgin here in Europe. Last summer, the wifi stopped working i.e. not finding any available signal. That time the phone was in 3.1.2. I thought I fouled up with cydia and didn't bother trying to fix it.

    Late in november wifi started working again without any software update.
    Because Virgin now sells iPhones, the 3G was upgraded to iOS 4.2.1 (with no jailbreak) last december.
    Upgrade went smoothly with not data loss. Wifi continued to operate.

    Since the very last days of 2010, wifi is dead again.
    This is why I suspect more a hardware failure than a software failure.
    If I get brave enough, I might try out http://www.snackyserve.com/iphone3g_wififixed/index.html

    Any one successful with Apple's (out of) warranty to fix this ?