1 Reply Latest reply: Aug 17, 2010 10:50 PM by highdef
micko75 Level 1 Level 1
Although the wifi icon appears on my iPhone, while im on the internet i am being charged as if im using 3G. Didnt have this problem pre OS4.0. Is apple issuing updates for these problems anytime soon???

iPhone 3G, iOS 4
  • highdef Level 1 Level 1
    I had the same problem, but more complicated. I live in Colorado at 9300 feet above sea level. I get no 3g at all, we only have the extended network. My wifi on my iphone 3g worked fine on the 3.0 software, just fine. I made the mistake of updating my iphone to 4.02 in mid August of 2010 and that is when my phones wifi failed to work. I decided to sync and backup my entire iphone and perform a restore, this was after I already performed the upgrade to 4.02 from os 3.0.
    So I essentially erased its contents and started over. Still no wifi, or kinda. The new os4.02 has some tricky settings in the network tab within the utilities folder. So I selected network and jumped right in to figure out what was going on.
    In order for me to utilize the wifi function/hardware on my iphone 3g I first disabled 3g and data roaming, leaving cellular data on. Any other combination of the network settings disabled my wifi.
    My take on the whole thing, Apple and ATT have had it a little rough with the whole 3g/apple iphone network data explosion/low bandwidth/software issues/hardware issues/ the list goes on and on. The only way ATT can keep up with the growth of bandwidth usage, someone had to manipulate the iphone to use either wifi or 3g, hence the paradox. Bad for users, because we have to change our usage habits by switching between a slow 3g expeience or a fast wifi experience. I see the whole software glitch as good. It frees up bandwidth on the 3g network by forcing the hand of the user to switch to wifi when they can to experience faster downloads. Wow, what appears to a lot of people on the internet as a massive mistake I see as Brilliance.

    Turn off your 3g and data roaming on your iphone 3g in network settings to get your wifi back.