10 Replies Latest reply: Jul 26, 2010 4:02 PM by Saveloy
amberd123 Level 1 (0 points)
i just posted a question about why my safari is not installing. i don't really mind not having the newest version of safari except when i try to go on to the itunes store, it says that "itunes requires safari 4.0.3 or later to be installed to use the itunes store within itunes. use software update to download and install the newest version of safari." well, safari will not install. also, i thought i could use itunes with something else, besides safari. like firefox or internet explorer? how do i make that work? also, this also brought up another question for me. the message says i must install safari 4.0.3 or later to use the itunes store WITHIN itunes. is there a way i can use it without itunes? or without having to update my safari? thanks.

Mac OS X (10.5.8)
  • Chris CA Level 9 (78,695 points)
    well, safari will not install.

    Perhaps you could give more info?
    What does/does not happen?
    Have you tried downloading Safari by itself (not thru Software Update)?
    Safari installs some frameworks (system files) that iTunes needs.
  • amberd123 Level 1 (0 points)
    when i try to download safari i ALWAYS get an error message saying, "the installer could not install some of the files in "/" contact the manufacturer for assistance."
  • Chris CA Level 9 (78,695 points)
    You get this message when you try to download or when you try to install the downloaded filke?
    Have you ran Software update? Try that.
  • amberd123 Level 1 (0 points)
    software update produces the same error message. i am unable to install any of my software updates. it will take the time to download, and then it will fail to install.
  • Chris CA Level 9 (78,695 points)
    Insert your System install DVD, restart and hold the C key.
    Run Disk Utility and run *Repair Permissions* and *Repair disk* on your internal drive.
    Then restart and run Software update again.
  • andyBall_uk Level 7 (20,490 points)
    Hi

    I see you posted at http://discussions.apple.com/thread.jspa?messageID=11904845#11904845 too.

    Did you run Disk Utility - Repair Disk +whilst booted from the Install DVD + ? (not repair disk permissions, Repair Disk, and you'd have had to restart your mac whilst holding down the C key)

    did it say there were errors it couldn't fix ?

    If so, then you'll either need better disk repair tools, which cost $$ or will need to erase the HD via your Install DVD & then see if you can successfully install again, followed by the appropriate updates.

    Back up your data before attempting this, it will remove everything.

    If that doesn't work out, then the HD is faulty, and if you're in warranty, Apple will replace it for you.
  • Carolyn Samit Level 10 (103,365 points)
    No wonder I couldn't find the thread.

    For whatever reason the original thread in the Safari category was deleted.

    I had gone through using Disk Utility. The startup disk has an error that requires either an erase and install or possibly DiskWarrior or TechToolPro.

    The error was this: *underlying task reported failure on exit*














    Confuzzled.
  • amberd123 Level 1 (0 points)
    yeah. all of this really confuses me. i think i'm going to take it to the apple store. my warranty runs out in august i think.
  • Tom Whiteway Level 1 (10 points)
    is your hard drive full?
  • Saveloy Level 1 (0 points)
    I have exactly the same problem with the same message from iTunes. It's driving me nuts.

    I have reinstalled system update 10.4.11, safari 4.0.5 and iTunes 9.2.1 all to no avail. Same error msg comes up.

    I have also gone down the disk repair route and booted up off the system DVD, run disk utility, repaired permissions and bubkis.

    Weirdly I wonder if this may have something to do with a corrupt file identified by an error msg from a cloning attempt I did using CCC - A Frameworks Core FP file that is stopping me running a successful clone with CCC.

    From the CCC log:

    "rsync: readlink_stat(\"/System/Library/PrivateFrameworks/CoreFP.framework/Versions/.BC .pvsm4w\") failed: Invalid argument (22)",
    "IO error encountered -- skipping file deletion"

    Now i think this has something to do with iTunes. I am beginning to think iTunes needs to be reinstalled through a complete system re-install. Really reluctant to do that tho =[