7 Replies Latest reply: Jul 30, 2010 8:59 AM by MDKINGSLEY
Chilliphone Level 1 Level 1 (0 points)
I've been on iOS4 for about 3 weeks and just yesterday Safari stopped loading. I would get a message saying something like "Cant connect to server." After a day of frustration I restored my iPhone and then synced everything all over again and STILL safari wont open, but now every app that requires internet won't work (Mail, App Store, You Tube, etc...)

I even went into setting and reset Network Settings. Does anyone have any suggestions?

note: I still get texts and phone calls though

PC, iOS 4
  • MichaelMT Level 1 Level 1 (15 points)
    Do the Internet applications work when using WiFi?
  • DaVBMan Level 6 Level 6 (9,265 points)
    Reboot is common fix for most issues.

    A reboot is:
    HOLD BOTH the HOME and LOCK buttons.
    DO NOT let go when it says Slide to turn off.
    KEEP holding until screen turns off then back on and you see the Apple Logo.
  • dude_at_jax Level 1 Level 1 (0 points)
    I experienced the same issue last week, I also turned 3G off to see if EDGE was affected as well. EDGE was affected. After about 2 hours my data services came back online. I called AT&T the next day and they said they had experienced an outage.

    I had 5 bars of both 3G and EDGE.

    My advice would be to call AT&T and see and tell them about the issue, tell them that your phone displays full signal, but data is not being transfered. They will possibly credit your account like $.10 and let you know whats going on.

    Message was edited by: dudeatjax
  • ThirdPrize Level 1 Level 1 (0 points)
    I am in the UK and have exactly the same issue on O2. i am guessing it is a aoftware thing. since upgrading to IOS4 my 3g has trouble accessing the internet. Not a WIFI issue i hasten to add. If i run any app that accesses the net then it fails first tie saying "it can't connect to the internet". if i run the app again immediately after then it connects with no problem. run another app and the first attempt fails.

    I might do a complete restore and see if that works.
  • BlondieMIA Level 1 Level 1 (0 points)
    I am having the same issues as well! I currently own 2 iphones, both 3gs. Over a week ago I updated my older 3gs to the new 4.0 software. After the 2nd day my internet and any other applications that require internet access have failed (mail, maps, app store ect). (This only my FIRST drama; Ill explain the others shortly.) Since then it has been a nightmare trying different things to fix the issue. Ive done soft resets, Ive backed up and wiped out then restored my phone numerous times (which is extremely time consuming); Ive tried resetting all settings, as well as reset network settings from the phone itself. Ive tried messing with the cellular data on/off, 3g on/off, wifi on/off... NOTHING WORKS. Ive also tried the resets in different locations (home, work, in the car in a parking lot ect)


    I noticed when i look in GENERAL info then ABOUT your phone (in settings), if i scroll down to "carrier" IT says NOT AVAILABLE.
    My other phone which I have NOT updated yet (thank god), says ATT.

    Back to my other issue... Since the 4.0 update, I am unable to send a MMS. The option disappeared! No longer am I able to send a picture or forward a contact via text. (I used this feature often).

    As we speak I have my phone hooked up to another computer which I normally dont sync it with... I didnt sync it on this computer, I only did a back up of my contacts and its in the process of downloading the seems like forever software update and attempting to restore it from the back up. (just incase it has something to do with the settings or who knows what in the phone's "regular" computer.)

    This is my last attempt to restore or fix this issue on my own.... If this doesn't work watch out apple; here I come!

    IMO I think its a bug with the software update

    OK MY PHONE JUST FINISHED THE RESTORE AND BACK UP... INTERNET STILL DOES NOT WORK... Yet, the only difference now is that the carrier does say "ATT" but still nothing! I already tried the "reset all settings" as well as "reset network settings and nada.

    What a nightmare this has been.. off to apple tomorrow morning guess we will see how that goes.
  • iamapc Level 1 Level 1 (0 points)
    I have the same problem since upgrading yesterday night. WiFi Works. 3G icon displays. 3G can't load anything (never)

    I called Rogers support, they don't know. they told me to go to apple store
  • MDKINGSLEY Level 1 Level 1 (0 points)
    Absolutely same problem. Just started on O2's simplicity contract to put in an old I phone 3g I bought off a friend (who it worked pretty well for). I updated software in between times and now I can't get any internet connection even though it says 3g and has full bars. I can get wi-fi but this is very annoying.