3 Replies Latest reply: Jul 18, 2010 1:50 PM by Gretchen Daniel1
Gretchen Daniel1 Level 1 Level 1 (15 points)
Hi - I am having major headaches with Mail and after reading the forum for an hour I still haven't been able to find anything that works for my problems:

I got so tired of deleting emails on multiple (iPhone, iPad) devices, that I deleted my POP accounts in Mail and set them up as IMAP. I have some experience with IMAP, which works perfectly on two accounts I've had for a year. These accounts are @mydomain.com accounts, so setting up my other email accounts under that domain was simple. I just reproduced the same settings.

Setting up my 2 Comcast email accounts was a little more involved; I had to open 2 Gmail accounts and have the Comcast mail forwarded to those Gmail accounts. I then set Gmail to always send from the Comcast address. All of that appears to be working fine; I'm receiving email and when I send replies out from my Gmail inbox, it appears to come from the Comcast address.

The problems I'm having with Apple Mail are as follows:

- "reply all" doesn't work; it only sends the reply to the first address on the list.

- when I hit reply, mail sends from the wrong email account - this seems random.

- when I select "use only this server" for outgoing mail, then I get error messages when trying to send, and am unable to send mail.

- when I DEselect "use only this server" for outgoing mail, then I can send email out, but none of the other problems are solved (I read in another thread that this might be a solution, but it didn't work for me).

Connection Doctor shows all servers are active, working and have a "green light".

Have I botched up my email accounts somehow, in setting them up as IMAP?

help appreciated!

MacBook Air, iMac, Mac OS X (10.6.4)
  • Gretchen Daniel1 Level 1 Level 1 (15 points)
    I should add that I have done some more testing with a friend, and I see that the "reply all" feature doesn't reply to email addresses that are within the same Apple Mail program. I figured that much out.

    But here's the weird part - I can no longer send out email from my @mydomain.com - either replies or brand new emails. I get the following message:

    +Verify that you have addressed this message correctly. Check your SMTP server settings in Mail preferences and verify any advanced settings with your system administrator.+
    +Select a different outgoing mail server from the list below or click Try Later to leave the message in your Outbox until it can be sent.+
    +Sending from: Xxxxxxx Xxxxxx <xxxxxx@comcast.net>+

    The weird thing about this is that it is saying I'm sending from my Comcast email account even when I have the @mydomain.com email account selected as the "from" account. I can't figure this part out at all.
  • Ernie Stamper Level 8 Level 8 (37,550 points)
    Gretchen,

    I am not totally clear with how you have set things up, and more info will be useful. However, let me note that normally the Gmail SMTP will change any From address to be the one used to Authenticate the SMTP. To send from another address, you may have to have an account set up, other than Gmail, but you say you have use web settings to allow sending from another address? I have not confirmed that Gmail means this to work with use of an email client rather than web access, but perhaps it does.

    I think you have discovered that Mail will choose the first address listed in the To of the original message from among those set up in Mail, and will not send to additional addresses setup in Mail, without manually adding them.

    Ernie
  • Gretchen Daniel1 Level 1 Level 1 (15 points)
    Thanks Ernie. Inexplicably, after quitting Apple Mail and relaunching it, everything started working perfectly. I don't know what to make of it, but fingers crossed.