Previous 1 2 Next 26 Replies Latest reply: Oct 13, 2013 5:57 PM by petergood66
Chelmo Level 1 (0 points)
On my iPhone 4 I can save PDFs into iBooks straight from a website as well as e-mail attachments. However on my iPad I can only save PDFs from e-mail attachments. Is it possible to open PDFs in iBooks from website links on iPad or will this only be available with the iOS4 update?
  • Level 6 (11,035 points)
    Agreed, I would like to do the same thing on my iPad but I have no iPhone to work off of.
  • J P K Level 1 (5 points)
    Should be corrected now that both the iPhone and iPad are on the same iOS version.
  • iMadivad Level 1 (30 points)

    I just tried and tested this, I have an iPad, running iOS 4.3.3 and it works...


    My test, go to, I searched for "file:pdf" (no quotes) and the first file it found was a tutorial on making pdf's. It itself, naturally, was a pdf.


    I touch & held the google result but only had the options to open, open in new page, or copy.


    click open, or open in new page, then as soon as it goes to the browser, look for an "open in iBooks" option in the top right corner (just under the address bar). Basically a bar across the top of the viewing area appears "momentarily" and does disappear pretty quickly. You can get it back by pressing at the top of the PDF area, the option reappears and you can open it in iBooks.

  • ocsurfer411 Level 1 (0 points)

    I used to be able to do this on my iPad 2 using IOS 4.3


    However on the new IOS 5.01 I can no longer open PDFs within iBooks. I have the option to do so, but when iBooks opens the PDF never populates iBooks.


    Note that I am able to open the PDF in Adobe Reader normally, it just won't open iBooks on my iPad in IOS 5.0.1

  • X10NG Level 1 (0 points)

    i have the same problem too. Before upgrade to iOS 5.01, i was using iOS 4.3.5 and my sync photo and music are very easy and fast.

    I can drag PDF file and copy to iBook, and also work for Movie.


    After my upgrade to iOS 5.01, the nightmare begin....Sync very long to waited and can't be done....Drag file to iPad can't complete.

    Also I found, when using iOS 4.3.5 when sync in progress the screen are lock. But in iOS 5.01, sync running at background and you still can launch application. Is that right?


    Hope can find solution for iOS 5.01

  • s1larson Level 1 (0 points)

    This has been a problem since mid November (at least).  Why hasnt apple addressed this yet?  Now that Steve has left us, has the tech people decided to stop doing their jobs?  This is a pretty big deal for those of us who use our iPads for research.  I updated mine so I would have icloud, but I would giveup icloud in a moment to be able to actually use my iPad again....  Anyone know what to do to fix this?  Is there different apps, or a way to roll back the version to one of the older ones that actually work??   I still cant believe that the apple tech people havent done anything, and I would have to BUY support to ask them if they have fixed a problem they created, and have ignored for over a month...  We should get an extra two weeks support everytime they update their entire system...,

  • s1larson Level 1 (0 points)

    Thank you!!  I was also coming back to update this, I dont know how I fixed it, but its working now.  I installed the Opera mini browser, pdf free reader, cloudreaders, pdf-notes.  I tried to open it in Opera, but it opened the pdf in safari, and then in ibooks, and it is working...

  • yee lim Level 1 (0 points)

    I experienced the same prob after upgraded my iPad 2 to iOS 5.0.1.. It's frustrated me!! iBooks is now useless for me!! I couldn't sync and also open PDF using iBooks..

    Tried using opera mini browser but still failed to solve it!!

    Pls help!!!

  • valiantcam Level 1 (0 points)

    Try this video, see if it helps.


  • Rich4205 Level 1 (0 points)

    When I open a PDF file in Safari the file displays fine. When I touch the "Open in iBooks" button the PDF flashes briefly on the iBooks bookshelf, then disappears. I have tried this over and over the with the same results.


    Previously, I was able to get the PDF's to stay on the book shelf after 3 tries. Rebooting the iPad corrects the problem for getting only one PDF on the bookshelf, then no other PDF's will come into iBooks until I reboot. Since I have dozens of file to get into iBooks rebooting is not a viable solution.


    Anyone else having this problem?  My iBooks is version 2.1.1 (908)



  • WoodMac Level 1 (0 points)

    I am having the same problem as Rich4205.  I would think this is a no-brainer for the Apple guys to fix but it has been going on for some time now.  Apple, please fix this app!  I have a great deal of info stored and use iBooks all the time.

  • Linda Van Thiel Level 1 (50 points)

    I have been having the same problem. The default app that came up when I would do "open in" was GoodNotes. I deleted that app and could then open the pdf in iBooks with iBooks as the default. Put GoodNotes back on and iBooks is still the default. So maybe there is something conflicting in that app. I also see a gazillion more apps that will read pdf files now when I do the "open in" through Mail.

  • TimeWindow Level 1 (0 points)

    Try this link for something that worked for me

  • 356simon Level 1 (0 points)

    I am also having this problem.  I use iBooks for every PDF that comes in and have financial results and stats saved here. I posted a message a month ago and it was suggested I save, back up then delete iBooks.  I re downloaded and luckily it populated to restore itself.  It then worked for a few days and now is back with issues.  Occasionally I save to iBooks about 6 times and finally a PDF was saved ( just a 1 pager). Help apple.


Previous 1 2 Next