Skip navigation
This discussion is archived

iPod Touch stuck in recovery mode

3382 Views 7 Replies Latest reply: Jul 24, 2010 12:58 PM by coldinertia RSS
jaseFX Calculating status...
Currently Being Moderated
Jul 22, 2010 12:54 PM
I was just trying to install the iOs update to my iPod touch, when my iPod suddenly went into recovery mode. Now I'm having trouble doing anything at all because my PC is telling me I don't have the drivers and to insert a disc I got with the product to install them, yet I didn't get a disc with my iPod and I don't think anybody does. I can't complete the resoration because it's not showing up in iTunes. Someone told me that it can't even be fixed taking it to an apple store, and they will only replace it. Is this true?

Is there anything at all i can do?
iPod Touch, Windows Vista
  • db2007 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 22, 2010 1:40 PM (in response to jaseFX)
    The same thing has happened to me AND a number of other people.
    Ive tried lots of different things but no success yet =[
    Some people have been saying if you connect your iPod to a different computer and restore and update it on there than that solves the problem?
    Acer Aspire 5315, Windows Vista
  • mizoakley Calculating status...
    Currently Being Moderated
    Jul 22, 2010 8:50 PM (in response to jaseFX)
    have the I pod Touch 3rd generation and it is stuck in the connecting to i tunes mode. Its been there for the last 22 hours. Can some one help me to get past this point.
    I Pod Touch, iOS 4
  • panalucian Calculating status...
    Currently Being Moderated
    Jul 24, 2010 12:11 AM (in response to jaseFX)
    Alright everyone this is going to sound pretty pathetic, but the same thing happened to me in the same situation. i tried the update and got stuck. So i made an appointment at my local apple store for the genius bar. All they had me do was plug my ipod touch into one of the laptops they have, and as soon as it was plugged in, itunes picked it up, and said it should be restored. So obviously i let it do it's thing. It was fixed, and it had the update. So i get back home, plug it in, and it instantly starts retrieving my backuped music and aps. So when that was finished my ipod was back to how it was, except with the update.
    -Hope that helped.
    Toshiba, Windows Vista
  • coldinertia Calculating status...
    Currently Being Moderated
    Jul 24, 2010 5:29 AM (in response to panalucian)
    Yes I have that problem too. I believe the problem is with the computer. Something with the USB connection. Notice that everyone who have had this problem have PCs and not Macs.
    HP Pavilion dv6 Notebook, Windows 7, 32-bit
  • db2007 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 24, 2010 7:17 AM (in response to jaseFX)
    I connected my iPod to another computer and it restored it and updated it. Then plugged it back into my computer and it restored all my music and apps, and for the moment (hopefully lasting) seems to work fine.
    Acer Aspire 5315, Windows Vista
  • Liam1847 Calculating status...
    Currently Being Moderated
    Jul 24, 2010 8:28 AM (in response to db2007)
    The Reason is that it has to be a USB 2.0 to work , for some reason they made it need a updated usb. I wish they would have said that before i tried to update it.

    Good Luck:-)
    dell p4, Windows XP, help
  • coldinertia Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 24, 2010 12:58 PM (in response to Liam1847)
    Strange, my USB port is 2.0 and the driver is up-to-date, but I had this problem.
    I tried restoring on another computer but unluckily that computer has its own problem, can't connect to itunes store...

    I'll try to use the Macs at uni tomorrow.
    HP Pavilion dv6 Notebook, Windows 7, 32-bit

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.