6 Replies Latest reply: Jul 27, 2010 12:23 AM by snowwakesurf9
snowwakesurf9 Level 1 Level 1 (0 points)
Hi-

So somehow after installing PDA Net on my mac to tether my new Droid phone, my computer crashed while rebooting and I got the circle-with-a-slash through it logo. I was able to boot up in safe mode, yet couldn't figure out the problem. I eventually reset the PRAM, which let me boot back up normally.

However, now whenever I plug in my iPod or any other USB device, i get an error saying "The system extension /System/Library/Extensions/IOStorageFamily.kext was installed improperly and cannot be used. Please try reinstalling it, or contact the product's vendor for an update"

When I go to look for this file, I've discovered that apparently I no longer have a /System/Library/Extensions folder???? I'm not sure how that happened at all. Any suggestions on how I can restore the .kext library/my /Extensions folder?

Thank you very much!

Macbook Pro 15", Mac OS X (10.6.4)
  • Kappy Level 10 Level 10 (252,825 points)
    If you no longer have a /System/Library/Extensions/ folder then your computer will not startup. So you cannot be missing the folder. Perhaps you don't know where to look for it?

    You can reinstall missing components, but the error message doesn't mean the .kext is missing. It simply means there is a problem with the file's permissions. That could be fixed by using Disk Utility to Repair Permissions. In fact you may want to do this:

    Repairing the Hard Drive and Permissions

    Boot from your OS X Installer disc. After the installer loads select your language and click on the Continue button. When the menu bar appears select Disk Utility from the Installer menu (Utilities menu for Tiger, Leopard or Snow Leopard.) After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list. In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive. If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return to the installer. Now restart normally.

    If DU reports errors it cannot fix, then you will need Disk Warrior and/or Tech Tool Pro to repair the drive. If you don't have either of them or if neither of them can fix the drive, then you will need to reformat the drive and reinstall OS X.
  • snowwakesurf9 Level 1 Level 1 (0 points)
    Hmmm...unless I'm mistaken the Extensions folder would be under Systems folder --> Library --> then simply Extensions??

    A search in Finder does not locate any .kext files...that's not normal, right?

    I have already done a repair permissions on my HD, but I will try what you have suggested using the OS X startup disk. Hopefully that will solve the issue.

    Thanks!
  • Kappy Level 10 Level 10 (252,825 points)
    You won't find it using Spotlight. Did you navigate directly to /System/Library/Extensions/? Or select Go To Folder from the Finder's Go menu and enter /System/Library/Extensions/ in the search field which should take you directly to the Extensions folder.
  • snowwakesurf9 Level 1 Level 1 (0 points)
    I attempted to navigate directly to it before with no luck; however, when I did the Navigate to Folder option, the .kext files appeared and my "lost" Extensions folder suddenly appeared!

    What do you recommend doing to attempt to fix this .kext file if I have already tried "Repair Disk Permissions"?

    Thanks so much for your help!
  • Kappy Level 10 Level 10 (252,825 points)
    It sounds like the folder may have gone invisible, but as long as you can locate the .kext file in question that's a good thing. If you've repaired permissions, did you note if that particular file's permissions were repaired? If so then you need to restart the computer. If not, then here's what you need to do to fix it:

    1. Open the Terminal application in your Utilities folder.
    2. At the prompt enter or paste the following:
    sudo chown -R root:wheel /System/Library/Extensions/IOStorageFamily.kext
    Press RETURN. You will be prompted to enter your admin password which will not be echoed.

    3. After the prompt returns enter or paste the following:
    sudo mv /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /Users/
    Press RETURN.

    4. After the prompt returns quit Terminal and restart the computer.

    A file named Extensions.mkext will be moved to the /Users/ folder. This is a temporary move to force the system to rebuild this cache file at startup. This should fix the issue. If all goes well then navigate to the /Users/ folder, select the Extensions.mkext file, CTRL- or RIGHT-click and select Move to Trash from the contextual menu. Empty the Trash.
  • snowwakesurf9 Level 1 Level 1 (0 points)
    Hey Kappy-

    Thanks for the response...that appears to have solved the problem! I'm not sure what caused my system to freak out, but all seems to be well again.

    Thank you so much for helping me out!! I greatly appreciate it.