8 Replies Latest reply: Oct 29, 2010 8:04 AM by Moof666
UpstateNYNick Level 1 Level 1 (0 points)
I just installed a new wireless router in my house. The previous router had no WEP or WPA password as there is only one house within range. On the new router, I'm using WPA with a password and when I turn on WiFi when I get home I need to select my network and enter the password each time. Is there a way to save the password so I don't need to enter it every time I tun on WiFi on the phone?

Thanks

Message was edited by: UpstateNYNick

iPhone 3GS OS 4.01, iOS 4
  • roaminggnome Level 10 Level 10 (92,355 points)
    Mine always remembers the network and password. I never have to select the network or enter the password.

    On the iphone, it even says: "Known networks will be joined automatically."
  • CK6Speed Level 1 Level 1 (40 points)
    roaminggnome wrote:
    Mine always remembers the network and password. I never have to select the network or enter the password.

    On the iphone, it even says: "Known networks will be joined automatically."

    Same here. It should join automatically. I only had to enter my credentials the very first time, after that if I turn on WiFi at home it automatically joins my network.
  • UpstateNYNick Level 1 Level 1 (0 points)
    Yes ... I saw those settings but it's not happening for me. Any suggestions? Maybe forget the network and re add it? I used the same SSID for the new router as the old one. Let's see.
  • roaminggnome Level 10 Level 10 (92,355 points)
    You can also try a reset. Or a restore.
  • Tom Alperin Level 3 Level 3 (715 points)
    There might be an issue with some routers using WPA instead of WPA2. Look to see what options you have and use WPA2 if it is available.

    Try deleting the network in preferences and then reconnecting to see if this solves the problem if the first solution does not work.

    Try resetting your network settings on the iPhone if the two above do not solve your problem. You should be able to go to settings, select reset and then select reset network settings. It's under general settings. Do not select reset all or erase all. Just network settings should be sufficient.
  • UpstateNYNick Level 1 Level 1 (0 points)
    OK. I forgot the network the re added it entering the password. Turned off WiFi then turned it back on and it joined automatically. I'm thinking that because I used the same SSID on the new router as the old one, i needed to forget then re-add. Problem solved. Lesson learned: If you change routers and use the same SSID, forget the network and then re-add it.
  • alister Rae Level 1 Level 1 (0 points)
    Is your phone finding your wi fi ok, mine continually 'looses' the router here at work! When I go home tonight and come in to morrow it will ask for the password for the router, it's driving me crazy. Any help appreciated?

    Thanks.
  • Moof666 Level 1 Level 1 (80 points)
    Got lots of help for you. Start a new question, though. This one is answered.