8 Replies Latest reply: Jul 28, 2010 9:50 PM by MrDuckbutt
MrDuckbutt Level 1 Level 1 (0 points)

I recently purchased a Mackie Onyx 1220 mixer with Firewire interface card. When I plug this into my iMac (via 6-pin/9-pin cable), the Onyx shows up in the sound settings applet and is set as the default output device. But if I try to play any audio, or change any of the Onyx settings (e.g. bitrate), I get the spinning beachball. This usually persists until I unplug the Onyx, or sometimes I get the beachball forever and have to force shutdown.

I tried the Onyx on a MS Vista system (via 6-pin/4-pin cable) and it seemed to detect and work consistently .. so I believe the device itself is functional. The obvious differences would be the OS and the FW connection (400-400 vs 400-800). I tried installing the latest FW SDK drivers, but no change in results.

Anyone have suggestions on what to try next? Mackie's phone support didn't really have suggestions, other than not using the 400-800 cable (which isn't an option since my iMac only has the one FW800 port). I could return the Onyx and get something else, but would prefer that as a last resort (got it a great bargain).


iMac, Mac OS X (10.5.8), Intel Core 2 Duo 2.66 GHz, 4GB DDR3 1066 MHz
  • Dr. 88 Keyz Level 1 Level 1 (30 points)
    I have the Onyx 1220 connected to my iMac (early 2009). I've been using the FW 400-800 cable with no issues at all for over a year. Try going to the "Audio MIDI" utility in the "Utilities" folder and make sure the Onyx is setup properly. The other possibility is that maybe you have a bad FW 400-800 cable.
  • MrDuckbutt Level 1 Level 1 (0 points)

    Out of curiousity, what version of OSX are you running?

    The cable is brand new, but I'll try to find another 6-pin device to verify just in case. Alas I can't really change settings in any of the sound applets since it usually results in the beachball.

    Are there any settings you know of in Audio MIDI that could prevent it from working? The only obvious one is that the bitrate defaults to 44.1 kHz instead of 96 kHz. Everything else displayed in there looks correct (it sees the right number of channels for input/output, etc).

  • Dr. 88 Keyz Level 1 Level 1 (30 points)
    I'm running 10.6.4 but also ran Ok with 10.5.x. My iMac is currently being repaired so I can't look at my settings... I should have it back later this week.

    Anyway, my sample rate has always been set at 44.1 kHz and I've never used any other frequency.

    Message was edited by: Dr. 88 Keyz
  • MrDuckbutt Level 1 Level 1 (0 points)
    Thanks for the confirmation. For another datapoint, I tried a Firewire HDD using the same cable and port - worked fine.

    One last question - you can use either port on the Onyx Firewire card, correct? The fact that my B port doesn't work under any OS is a little suspect. I'm not sure why the A port is only broken on OSX, but I may just assume it's faulty and swap it for a newer Onyx-i.

    Message was edited by: MrDuckbutt
  • Dr. 88 Keyz Level 1 Level 1 (30 points)
    Yes, you can use either FW port on the Onyx.

    One other note about my setup (don't think this should make a difference, but worth noting anyway). My Onyx is currently not directly connect my iMac. It's connect to a FW FDD via FW400 cable as follows:
    iMac <---FW 800/400 cable-->FW FDD<--FW 400 cable-->Onyx1220

    I believe at one point I may have gone directly from the iMac to the Onyx with the FW 800/400 cable and can confirm that once I get iMac back.
  • Dr. 88 Keyz Level 1 Level 1 (30 points)
    Got my iMac back this afternoon! Anyway, I've connected the Onyx directly to my iMac with the FW 800/400 cable to either port on the Onyx and it works just fine through either FW port on the Onyx. I have the "Clock source" set to "Device" for the Onyx in the Audio MIDI setup. Format is set to "44.1 kHz" for both input and output.

    Good luck and hope you get things going.
  • MrDuckbutt Level 1 Level 1 (0 points)
    Thanks for the confirmation. I'll mark your post as the answer to this question, since it indicates that my card is probably faulty.
  • MrDuckbutt Level 1 Level 1 (0 points)
    Ok I lied, one more question ..

    I was curious which FW controller is on my iMac, so I checked and it's Lucent/Agere (device ID 5901). Apparently lots of people have issues with the Agere controllers and various audio interfaces. I'm curious which controller is on your (working) system .. could you try the following?

    1) Reboot system whilst holding Command + S (it should bring up the text boot screen).
    2) In the middle of this output will be some text describing the FW device .. e.g. "Firewire (OHCI) Lucent ID 5901".

    What does yours say there?