Previous 1 2 Next 20 Replies Latest reply: Feb 27, 2014 2:26 PM by pancho2412 Go to original post
  • andyBall_uk Level 7 Level 7 (20,495 points)
    michaelmckeever9 wrote:
    As far as I can tell it's still on, but I have had to run the command several time ad it does not hold at all. Just now some images didn't load and I got a can't connect to the server massage.


    I see - sounds as if there's something else amiss.

    defaults read com.apple.safari WebKitDNSPrefetchingEnabled


    will confirm the setting - it is set per user & (probably) needs Safari restarted to take effect.
  • powerbook1701 Level 3 Level 3 (555 points)
    it would be nice if pre-fetching was an option to turn on and off in Safari.
  • Klaus1 Level 8 Level 8 (45,430 points)
    I, for one, agree.

    You can use this form for sending Apple feedback about Safari:

    http://www.apple.com/feedback/safari.html
  • powerbook1701 Level 3 Level 3 (555 points)
    Thanks, already did before posting. Just reading that thread reminded me that I wanted to do that as soon as it came out.
    For something that can impact Safari so much, it would be nice to control it..at least on or off
  • michaelmckeever9 Level 1 Level 1 (5 points)
    After what happened to Safari a few days ago i will leave it enabled.
  • pancho2412 Level 1 Level 1 (0 points)

    Hi,

     

    first I must appologize, I am a really new Mac user ...

     

    I would like to know how I disable DNS-prefetching for all users per default. Or do I need to run the command above once for every user I have created on my Mac?

     

    I also assume that once executed the command to disable dns-prefetching this will be kept unless I enable dns-prefetching again. And this also if I restart my mac and login again on my profile.

     

    Correct?

     

    BTW: I tried to read the value of WebKitDNSPrefetchingEnabled but this is only working several times directly after having written this attribute to false. After some more repeats I get the following message

     

    >defaults read com.apple.safari WebKitDNSPrefetchingEnabled

    2014-02-27 23:23:39.140 defaults[9167:507]

    The domain/default pair of (com.apple.safari, WebKitDNSPrefetchingEnabled) does not exist

     

    Any feedback would be most appreciated!!!

     

    THANKS

Previous 1 2 Next