Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Message app slow and lags on Big Sur

The Messages app (which you send and receive iMessages with) becomes very slow and unresponsive after upgrading to Big Sur. Other apps seem to be performing fine. Do anyone else have this problem? Will it be fixed in a future release?

MacBook Pro 16″, macOS 11.0

Posted on Nov 15, 2020 3:48 PM

Reply
Question marked as Solved
Answer:
Answer:

I found this and it worked for me.

Sonia Huelsenbeck says

APRIL 3, 2019 AT 9:53 PM


After trying all the suggested fixes, I contacted Apple. They had me do the following and it worked:

Sign out of Messages on the MacBook. We can do that by opening Messages, then going to the top left corner of the screen and click messages -> iMessages. We should be able to sign out from there .

Up next we’ll go on the iPhone to Settings -> Messages, turn off iMessage, restart the iPhone, then turn iMessage back on.

Go back on the MacBook and get signed back into the Messages app. 

Go on the iPhone to Settings -> Messages -> Text Message Forwarding. We should be able to flip a switch for the Mac to allow us to send SMS and MMS messages from the MacBook, and hopefully sort out the last of it.

Enter the code that pops up on your screen.

Posted on Nov 25, 2020 11:57 AM

Nov 18, 2020 5:45 PM in response to singularitylxc In response to singularitylxc

I had the same problem but only on one Mac. I have Big Sur installed on a MacBook Air, a MacBook Pro, a Mini, and an iMac, and it was only running slow on the Mini. It would also freeze and needed to be forced to quit. It's a 2014 i7 3 GHz 16 GB RAM Intel Iris 1536 MB. Everything else works fine, so I checked all settings and found one different. I set it the same as the other Macs, and Messages works absolutely fine now. That one setting was in Accessibility > Display > Cursor > Cursor Size. It was set on the 4th (middle) size. I reduced it to the smallest size even though the other Macs are on the second setting. As I said, works perfectly now.

Nov 18, 2020 5:45 PM

Reply Helpful (2)

Nov 23, 2020 10:24 PM in response to caferacer98 In response to caferacer98

Rebooting into safe mode and rebooting again was one of the first things I tried. There's a reason why we reboot first, but changing my Accessibility settings appears to have been a permanent fix. Messages hasn't frozen on me again. Hope that helps.

Nov 23, 2020 10:24 PM

Reply Helpful (1)
Question marked as Solved

Nov 25, 2020 11:57 AM in response to SBDowd In response to SBDowd

I found this and it worked for me.

Sonia Huelsenbeck says

APRIL 3, 2019 AT 9:53 PM


After trying all the suggested fixes, I contacted Apple. They had me do the following and it worked:

Sign out of Messages on the MacBook. We can do that by opening Messages, then going to the top left corner of the screen and click messages -> iMessages. We should be able to sign out from there .

Up next we’ll go on the iPhone to Settings -> Messages, turn off iMessage, restart the iPhone, then turn iMessage back on.

Go back on the MacBook and get signed back into the Messages app. 

Go on the iPhone to Settings -> Messages -> Text Message Forwarding. We should be able to flip a switch for the Mac to allow us to send SMS and MMS messages from the MacBook, and hopefully sort out the last of it.

Enter the code that pops up on your screen.

Nov 25, 2020 11:57 AM

Reply Helpful (1)

Dec 4, 2020 3:20 AM in response to Bob Howard In response to Bob Howard

Reboot only fixes it temporarily. I did that and after few days it came back. I even upgraded fusion drive to a super fast SSD 2T in my 2017 iMac 27 as I thought this new Mac OS Big Sur requires faster disk speeds but the problem is still there. Messages are laggy as I was working on 15 years old machine.

Dec 4, 2020 3:20 AM

Reply Helpful (1)

Dec 4, 2020 7:28 AM in response to flakarek In response to flakarek

I agree. The fix works, but the problem comes back. It appears to be a sync problem across platforms. With a Mini, an iMac, a MacBook Air, an iPad Pro, and iPhone 11Max next to each other a message doesn’t appear on all screens for several minutes at times. Sometimes it works extremely well. I go through the suggested fix, and the results are immediately obvious, but then it comes back within a day or two.


Dec 4, 2020 7:28 AM

Reply Helpful
User profile for user: singularitylxc

Question: Message app slow and lags on Big Sur