Previous 1 2 Next 22 Replies Latest reply: Sep 16, 2010 7:22 PM by TheWarpLynx
connex1 Level 1 (0 points)
I have been facing a problem that my iMac would suddenly drop the connection to my router which is not far from my Aztech Router when left idle for about 10 minutes. I have a 5 year old HP laptop which is located way farther from the router and is not showing any problems. All software updated are up to date. I have done all the diagnostics, deleting the network, setting up again. Anyone know of a concrete solution to this? Maybe a firmware update or a reset procedure of the airport extreme built-in card?
Any help would be appreciated. Thanks

iMac i7 27 inch - 16GB RAM, 1TB HDD, Mac OS X (10.6.4), MBP 17
  • Carolyn Samit Level 10 (102,820 points)

    Try a different Airport Channel.

    Open AirPort Utility (Applications/Utilities)

    Select the device you’re setting up, and then click Manual Setup. Enter the base station password if necessary

    Click AirPort in the toolbar, and then click Wireless.

    Choose a new channel from the Channel pop-up menu.

    If that doesn't help, go to /Library/Preferences. Move all the files in the System Configuration folder to the Trash, restart your Mac and see if that made a difference.

    Also, sometimes just turning off the router for a few minutes then turning it back on can help.

  • bburt Level 1 (25 points)
    Nope. No concrete solutions. There are a couple of other lengthy threads on the issue which have a bunch of suggestions. None have provided a definitive solution for me, though.

    If it persists, please contact Apple.
  • connex1 Level 1 (0 points)
    Update, If I am constantly using the iMac, all is well and good, it is only when I leave it for about 20 minutes, the Wifi Logo on the top right bar shows connected, but attempting to open a web page on safari takes. Sometimes, I have to turn the built-in airport extreme card off and on. It is very annoying. APPLE, please HELP !!!!! Please
  • connex1 Level 1 (0 points)
    Hi, since I am in Dubai, there isn't a professional service center that would be able to offer concrete and viable solutions. Hence, I recommend attempting to sort it out myself. I gues that the matter is a software issue, at least I hope it is so.
  • Dah•veed Level 7 (33,390 points)
    Apple is not here, this is a user to user forum only.

    If your Mac is near the router, Ethernet is a much faster connection.

    The iMacs with the best wi-fi connects are the white ones in plastic cases, the G5s and the first Intel iMacs. That is because the case does not interfere with the wi-fi signal. On the aluminum bodied iMacs, especially those with the unibody case, the case interferes with the signal. The antenna is located on the rear of the iMac under the Apple logo. You may want to be sure that the antenna is pointed directly at your router.


  • connex1 Level 1 (0 points)
    Hi Carolyn, I did try the steps you had mentioned, but the problem still exists. I have a windows laptop right next to imac and no problems on it whatsoever. If I constantly browsing, the connection will stay stable and all is good. While should I just leave the iMac for about 10 min; safari won't connect, however the Airpot icon on the top right still shows full bars.

    I so wish to find a solution to this.
  • nasroht Level 1 (0 points)
    Think what you are seeing is that the iMac goes to sleep. Energy Saver.
    System Preferences -> Energy Saver

    My Macbook Pro disconnects from my router once it goes to sleep. And it does take a while to reconnect, understandably.
  • connex1 Level 1 (0 points)
    Sold the Unit. Going to Back to Sony.
  • cranbers Level 1 (0 points)
    I have been doing a lot of experimenting. I can absolutely narrow it down to the imac wifi card. It is NOT a signal problem either. How can it go from full bars, to loss connection and searching randomely? All the while all the other wireless devices in the house have no issues? I can understand if it was a laptop and you hit a dead spot while carrying it around your house, but your imac should be stationary and it loses connection randomely. Especially when booting up.

    I have tried a wireless G router as well, it drops packets randomly when doing a continuous ping.

    I have tried a wrt54g and a wrt 610n There is only 1 other wifi hotspot within range of my imac. I have tried it on 2.4ghz wireless n, 5 ghz wireless n and 2.4ghz wireless g. All of them randomely lose packets, but the most issues is definately with a 5ghz wireless N. I can't duplicate this on my mac book pro which is using a apple airport broadcom and my imac is using the atheros.

    ype: Other Network Controller
    Bus: PCI
    Vendor ID: 0x168c
    Device ID: 0x002a
    Subsystem Vendor ID: 0x106b
    Subsystem ID: 0x008f
    Revision ID: 0x0001
    Link Width: x1
    BSD name: en1
    Kext name: AirPortAtheros21.kext
    Location: /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros21 .kext
    Version: 423.9.9

    I am no dummy when it comes to networking, I understand wireless technology. If there was an issue with log signal and finally a drop out or some sort of interference, it is painfully obvious every signal computer would have issues, not just the imac, especially when they are right next to each other, my wifi n 5 ghz signal drops out on the imac only, and there is my mac book pro right next to it, same hotspot same frequency humming along, no issues ever.

    Here is the symptoms doing a continuous ping on a wireless G linksys wrt54g:
    bytes from icmp_seq=119 ttl=64 time=0.877 ms
    64 bytes from icmp_seq=120 ttl=64 time=0.953 ms
    64 bytes from icmp_seq=121 ttl=64 time=0.846 ms
    64 bytes from icmp_seq=122 ttl=64 time=0.931 ms
    64 bytes from icmp_seq=123 ttl=64 time=0.797 ms
    64 bytes from icmp_seq=124 ttl=64 time=4.041 ms
    64 bytes from icmp_seq=125 ttl=64 time=1.367 ms
    64 bytes from icmp_seq=126 ttl=64 time=0.919 ms
    64 bytes from icmp_seq=127 ttl=64 time=0.957 ms
    Request timeout for icmp_seq 128
    Request timeout for icmp_seq 129
    Request timeout for icmp_seq 130
    64 bytes from icmp_seq=128 ttl=64 time=3056.812 ms
    64 bytes from icmp_seq=129 ttl=64 time=2057.405 ms
    64 bytes from icmp_seq=130 ttl=64 time=1058.114 ms
    64 bytes from icmp_seq=131 ttl=64 time=58.458 ms
    64 bytes from icmp_seq=132 ttl=64 time=2.395 ms
    64 bytes from icmp_seq=133 ttl=64 time=1.001 ms
    64 bytes from icmp_seq=134 ttl=64 time=0.869 ms
  • cranbers Level 1 (0 points)
    I would also like to mention that I tried it with no wifi security, wpa with tkip, wpa2 with aes. It doesn't seem to make a difference. Also I did notice it dosn't actually lose the association with the router under wireless G but it does randomely drop packets and have a sky high ping ms rate.

    So here are the issues:

    Randomly loses association and packets under 5 ghz wireless N with a wrt610n The association loss is especially bad when first booting up. And randomely has a high ping rate to the base station 1000ms + is not uncommon. It will go back down to 0.7 or less.

    The association loss can only be fixed by turning on and off the wifi card sometimes several times.

    Randomely loses association and packets under 2.4 ghz wireless N but less problematic then 5 ghz. HIgh ping rate is also not uncommon. Especially when scanning for new networks is active (selec the signal icon and it spings showing its looking for networks.

    2.4ghz wireless g isn't as bad, no association loss but still lost packets and high ping once in awhile.

    What have I tried to fix it?

    Clear out network saved data and reassociate from scratch re entering the data, clearing it out of the key chain etc.
    running latest version of mac os x 10.6.4
    Tried different encryption types, wpa wpa2 with aes no security.
    Tried assigning an IP address, dns server etc, no change in performance or symptoms.
    Reinstalled Mac os from scratch, no change in symptoms.
    Tried running it under windows 7 64bit, The issue isn't as common but I do recall having high ping rate. No loss of association though especially during boot up.
    I plugged in a stand alone wifi card that works through the ethernet port, this had no symptoms mentioned. Consistant low <1ms ping times, no dropped packets and no loss of association even at boot up. This is at 5ghz wireless N.

    I just really wanted an all in one computer and get rid of the cables. Going that route means why did I bother?
  • dvscrobe Level 1 (40 points)
    David.Austin, the only Mac that is non-metal casing is the MacBook. Does that have better Wi-Fi transmission?
  • Dah•veed Level 7 (33,390 points)
    So where is the iMac in relation to the wireless router? Some distance away from the router? Right next to the router? Both with the same results?
  • pming Level 1 (0 points)
    I havethe same problem. My new 27" inch IMAC is non-functional when it comes to Wi-Fi. All my Toshiba laptops are fine no matter where they are located in the house. Unfortunately for thw apple ethernet is not a option. I think it is a case of form over function. Apple IMAC wi-fi does not work. does anyone know of an external solution such as a USB wi-fi adaptor that would work with the latest IMAC
  • killhippie Level 3 (765 points)
    I have a late 2009 21.5 3.33ghz imac and it operates fine over wifi over 5Ghz. I use a Netgear DGND3300 and the router is central to my home, speeds are good and pings are low, unless Apple changed the cards and there is a bad batch it seems odd. My iMac is by a wall about 30ft from my router.
Previous 1 2 Next