10 Replies Latest reply: Jan 3, 2011 5:01 AM by VarunPramanik
Shash450 Level 1 (0 points)
Hey there,

I've been using the Gala release of Flash for a while now, and i've been really loving the improved CPU usage thanks to the GPU acceleration. From yesterday however, i've been having a strange problem with safari. Everytime I watch a flash video and go into full screen, the MAC OS X menubar and dock can still be seen, and are not faded out like they should be... This seems to be a problem on Youtube, Dailymotion and basically any other flash video site that i've tried. The video plays back fine, its just that there's the annoying dock and menubar in the way for some reason....

This doesn't seem to be a problem on both Chromium or Firefox. I've tried un-installing and then re-installing, repairing permissions, but its a no go... Any ideas guys? I'd really appreciate the help!

Macbook Pro Unibody (Late 08) 15" - 4GB RAM - 2.8Ghz, Mac OS X (10.6)
  • Carolyn Samit Level 10 (103,365 points)
    HI,

    Unfortunately, you are not alone. Yours is the third of fourth post regarding full screen mode using Flash in the past several days.

    You may find help at the Adobe site here. http://www.adobe.com/support/flashplayer/

    For time being, use Firefox or Chromium until Adobe can write a fix for this.

    This user's Safari is actually crashing in full screen mode. http://discussions.apple.com/thread.jspa?threadID=2512720&tstart=0

    The more complaints Adobe receives regarding this issue, the better.









    Carolyn
  • ~Bee Level 7 (31,425 points)
    There are lots of us who do not have problems with the new Flash
    and running full-screen videos from YouTube or anywhere else.

    In addition, you're just having problems with the Dock & MenuBar showing, right?
    The videos themselves run fine???

    Do you know of anything that changed on your Mac yesterday?
    Any new apps, or internet plugins? Did you update anything?
  • Shash450 Level 1 (0 points)
    Thanks for the quick replies!

    You see, that's the weird thing! I'm having no playback issues whatsoever when i go full screen (which is what i found when reading around other people's problems), and until the other day, everything was perfect. I didn't install/change anything, it literally happened at random when i launched safari towards the end of the day.. Strange thing is, if i click anything on the menubar during full screen, and then click onto the video, the menubar disappears, but then re-appears each time i go back to window mode, and then full screen again.... Its sooo strange! I tried posting this on the gala flash player forum, but the weird thing is, it won't let me post there for some reason lol.. Gonna have to keep trying...
  • Klaus1 Level 8 (47,755 points)
    Note that an updated version, Safari 5.0.1, was released July 28, 2010.

    You can download it direct from here:

    http://support.apple.com/kb/DL1070

    where you can also read about the various improvements etc.

    Note that installation will require a restart of your Mac.

    Try that and see if there is any improvement.
  • Shash450 Level 1 (0 points)
    Thanks for the reply Klaus!

    Unfortunately, that didn't seem to make a difference... When I saw the update this morning I had hoped that it would solve the problem, but alas it wasn't meant to be haha.. Its starting to get truly frustrating now though!!
  • ~Bee Level 7 (31,425 points)
    Shash --

    I'm assuming you've cleared your Safari cache & History list, right?
  • jlaguna Level 1 (0 points)
    I am having the same problem. I already restore Safari, clean the cache but nothing. Please help is really annoying!!
  • Shash450 Level 1 (0 points)
    You absolute legend!! I tried that once or twice, but it didn't seem to do the trick - but i did a third time, and looks like third time's the charm! Thanks a bunch man - I was almost thinking of switching browsers because of this!

    Thanks to the other repliers as well.. I have no idea what the **** i'd do without you helpful lot on these forums!

    Message was edited by: Shash450
  • ~Bee Level 7 (31,425 points)
    Really?
    Clearing the cache & history took three times?
    Wow!

    Anyway, I'm so happy you're all sorted now.
  • VarunPramanik Level 1 (0 points)
    I found a solution. Just click on the menubar and the menubar and dock should disappear.