Previous 1 2 3 4 5 6 Next 80 Replies Latest reply: Dec 5, 2010 1:15 AM by RichardLloyd Go to original post
  • m2gym Level 1 Level 1 (0 points)
    Agreed. Mine won't "unclick" so you end up highlighting or dragging stuff you don't want to. And then mysteriously it's fine again. No, it's not a "swollen" battery as someone suggested. It's after the trackpad update.
  • Zaptrax Level 1 Level 1 (0 points)
    Yeah, one more MacBook Pro owner here with same problem. Updated the firmware for the trackpad and it now clicks and drags without me doing anything. This has got to stop! I hope Apple is reading this forum.
  • Landin Ryan Level 1 Level 1 (0 points)
    And one more. Early 2008 Macbook Pro here. This is super annoying.
  • grieguin Level 1 Level 1 (0 points)
    I also want to know how to uninstall this update. Tap to click is completely out of wack. It keeps clicking stuff when all I do is move the cursor-- it never did that before. I've tried changing the speed for clicking, tracking, everything... and the problem persists.
  • David Allan Level 1 Level 1 (45 points)
    Same here: trackpad is stuck dragging things after installing the Multi-touch update.

    Model Name: MacBook Pro
    Model Identifier: MacBookPro5,2
    Processor Name: Intel Core 2 Duo
    System Version: Mac OS X 10.6.4 (10F569)
    Kernel Version: Darwin 10.4.0
  • dawson444 Level 1 Level 1 (0 points)
    Same problem here with the touchpad sticking, its driving me crazy. It started happening the day after I did the upgrade.
  • goldste4 Level 1 Level 1 (0 points)
    Hi, another me-too post. Downloaded the trackpad update, and just now had my trackpad do what everyone has a described: random clicking and moving that comes and goes in waves. Very frustrating as everyone as noted.
  • Tygrik Level 1 Level 1 (0 points)
    I have the problem too - I have tried uninstalling iStats 3.0, Adium, clearing safari cache, etc and nothing worked - I figured out that the double-tap helps from the stuck cursor in the "clicked" mode.

    I'm going to report this problem.
  • rreichar Level 1 Level 1 (0 points)
    I am having the same issue as everyone else. Since installing the trackpad update my 2009 MacBook Pro frequently loses it's mind and starts behaving like it is being clicked randomly. It usually requires and update to get out of it. This is very frustrating as I have lost projects that I was unable to save before having to force quit. Hopefully there will be a fix for this. I assume there is no way to rollback this update?
  • Tygrik Level 1 Level 1 (0 points)
    I have just reported the problem via developer bug reporting - I hope there will be a fast solution. I'm unable to work on my macbook with this ...
  • Ju5tin Level 1 Level 1 (0 points)
    Ah! Im having the same problem, it is super irritating. I have the late 2009 MacBook Pro. However, I'm thankful its the only problem I've ever had with the computer, and that its just a software issue. I sometimes leave it and it goes away, sometimes I try a combination of clicking, right clicking, 2 3 or 4 finger gestures. Nothing works except waiting for a bit or a restart.

    Forgot to add, I have no idea what this '3 finger gesture' is, only the new inertial scrolling was added to my trackpad settings menu.

    Message was edited by: Ju5tin
  • Ronerazo Level 1 Level 1 (0 points)
    I have encountered this issue too but so far I haven't found anything about uninstalling except, reinstalling OS X or using Time Machine. If anyone is having issues getting the "You cannot control your computer" or something like that when disabling the Bluetooth, simply plug a USB mouse and disable it, that will work.

    Hope Apple address these issues or release a mini update giving Macbooks a real update, not just MBPs
  • holamargarita Level 1 Level 1 (0 points)
    Ugh me too. Installed the update earlier today and for some reason whenever I'm scrolling down on something the website's text get highlighted even if I didn't mean it too - and it's quite a hassle with my tabs getting dragged out (am using Chrome). Worse, I couldn't even get to my icon dock without much struggle! I always have to restart my Mac in order to get rid of the annoying bug, only for it to resurface in 30 mins or so. Right now it's working fine so I'm taking advantage of the "window" haha.

    Calling Apple!
  • sleepneed Level 1 Level 1 (0 points)
    I've had the exact same thing with my (5,4) MacBook Pro. At first I thought it was just mine and I'd have to go out and get it replaced. I hope that an update can come out soon and get this fixed, I almost lost a paper when it was stuck in drag mode.
  • rolcom Level 1 Level 1 (0 points)
    SAME PROBLEMS on my macbook, I didn't notice it was after the update, its just been happening for the past little bit..will just randomly happen, usually atleast once a day.. then I restart then its fine.. getting so annoying.. i hope its just a software issue and not the swollen battery issue