Previous 1 2 3 Next 35 Replies Latest reply: Dec 8, 2012 3:14 PM by Mith_y Go to original post
  • freelancer™ Level 5 Level 5 (6,140 points)
    Yes, it's worth noting that just removing the USB Overdrive preference pane won't remove the kernel driver. The preference pane actually includes an "uninstall" button that will completely remove it from the system. If you don't do that then you'll have to go and find the system extension and delete it (and then reboot!).
  • onefish2 Level 1 Level 1 (0 points)
    I just got the Magic Trackpad in the mail this afternoon. Went to pair it with my MacBook Pro and ran into the same problem as reported here. Initially I thought it was due to running Snow Leopard in 64 bit mode. I rebooted into 32 bit mode by holding down the 3 and 2 keys and had the same issue.

    I was also on the phone with Apple Care. They were not able to help but set up an appt for me at my local Apple store.

    I had a hunch it was USB overdrive as this happened to me a few years ago when Apple released the Mighty Mouse. USB overdrive was interfering with its full functionality to. No new preference pane.

    I removed the USB Overdrive preference panel and still had the same problem.

    Not wanting to give up I refined my search criteria from "magic trackpad" won't pair to "magic trackpad" preference pane and that is where I found this thread.

    I read through it and downloaded UCS overdrive, reinstalled it and then removed it from /Applications/Utilities. There is an uninstall utility in that folder.

    Rebooted and all is fine now.
  • Welles Goodrich Level 4 Level 4 (1,380 points)
    Thanks to the folks who discovered that USB Overdrive was the culprit in getting the proper Trackpad pairing with the pref pane in spite of some limited functions when it was just paired in the Bluetooth Pref Pane. That solved my problems and I too, remembered (after the fact) that USB Overdrive caused some problems with new input hardware installation in the past, twice before if I remember correctly.

    For those who might still need mouse configuration options (especially cursor acceleration) I can report that SteerMouse works just fine to preserve the functionality of USB Overdrive without bricking the Magic Trackpad.
  • thewolfro Level 1 Level 1 (0 points)
    Guys i never installed USB-Override but still my trackpad does not work. I mean i can click on the corner button but the cursor is not moving at all.
    Since i have read through the forum i have seen people discussing about USBOverride but since i did not have it i installed it just to uninstall it after. Still my trackpad is in the same state (i can only click).

    I have also tried to dissociate it, remove it from bluetooth device list associate it back, remove the batteries, put them back in, reboot my Mac couple of times but still nothing.... What a **** is going on ?
    does any of you have any suggestion?
  • donvy Level 1 Level 1 (45 points)
    For some strange voodoo I managed to get mine working. I read somewhere here about erratic cursor movement due to a second monitor, so I unplugged mine, removed Magic Trackpad from Bluetooth, used the Trackpad preference pane to add it back, and it works! Then I plugged my second monitor back in and it still works! I hope this survives a restart. And I hope this helps someone else out there.
  • Wingsy Level 2 Level 2 (200 points)
    My 2 cents:

    Had the same problem until I uninstalled USBoverdrive. Then the Magic Trackpad was able to be found and all the features of the trackpad worked. After that I tried reinstalling USBoverdrive, but that broke the trackpad again so it looks like there's no way to have them both at the same time.

    But my purpose of using USBoverdrive was to enable extra buttons on my USB mouse for custom actions. I also have iKey on my system and found that I could do the same thing with that. So for me, USBoverdrive is history.
  • Welles Goodrich Level 4 Level 4 (1,380 points)
    To be fair to the developer I would add that new input hardware has run into driver conflicts with USB Overdrive before and each time there has been a new version released to solve the problem. So keep an eye out for an upgrade. We early adopters always get bitten by the bugs.
  • seahawk09 Level 1 Level 1 (0 points)
    I had to give the track pad a clear area too work I think the wireless signal is very fussy if there is too much stuff around the signal wont get out. I cleared my desk and it just came to life??
  • 4wolff Level 1 Level 1 (0 points)
    Hey Guys, I just got my Trackpad. Make sure you have the Mac OS X 10.6.4 version before installing your trackpad.
    When I open the box I noticed there was a sticker that said that I needed download the trackpad update. So I did and now works very good. Its amazing.

    Here is the update site: http://support.apple.com/kb/DL1066

    Hope this helps everyone. Cheers!
  • Brian M. Wood Level 1 Level 1 (0 points)
    I just purchased a magic trackpad, and I set out to install it on two macbookpro computers: a 2.2 and a 6.2 versions. Neither machine had USBoverdrive installed, so that was not the source of my problem. I installed OS X 10.6.4 and the necessary magic trackpad update on each machine. After doing so, the magic trackpad was discovered instantly by the newer macbookpro. No problem there. The older macbookpro had problems. After installing the software updates, and restarting my machine, the trackpad was not found when I used the "setup bluetooth trackpad" feature. I then restarted the machine again, and took the batteries out of the trackpad just for voodoo's sake (like blowing into old nintendo cartridges, it just makes you feel better . It worked! So perhaps this means that 1) older macbookpro models are more likely to have this problem, and 2) giving your machine an additional restart (and reciting any incantations that serve you) can solve the problem. Hope this helps someone.
  • BobHarris Level 6 Level 6 (15,925 points)
    SteerMouse seems to play nice with the Magic Mouse and Magic Trackpad (got the Magic Trackpad for Christmas).

    I had been using USB Overdrive with a LogiTech mouse, but when I could not get my new Magic Trackpad working, I uninstalled it using Applications -> Utilities -> USB Overdrive Uninstaller.

    I then tried SteerMouse and it allowed me to configure my LogiTech mouse, as well as keep all my Magic Trackpad and for the first time, all my Magic Mouse features (Magic Mouse came with my 27" iMac, but I never really use it).

    So if you need to customize your mouse 3rd party mouse, try SteerMouse (Shareware)
  • J Gysenbergs Level 1 Level 1 (30 points)
    After some hours trying to find a solution it sat right in front of my nose. By removing the trackpad from the list under the Bluetooth preferences and adding the trackpad again it came back to life. Hope this helps - JG
  • AJ- Level 1 Level 1 (20 points)
    Well, I had the same problem. The trackpad did not show up in either the bluetooth System Preferences pane or in the trackpad pane. I pressed the power button on the side of the trackpad several times, turned bluetooth on and off - I've never had USB overdrive installed, so it has nothing to do with that.

    The only thing that worked was taking the batteries out of the trackpad, waiting and then putting them back in. So the trackpad itself is getting itself into a state and resetting it works.

    I'm not even using Apple's built in bluetooth (my Mac Pro is 3 years old and has no bluetooth) I'm using some no brand micro USB dongle. Which is why it took me so long before trying power cycling the trackpad - I thought it was the crappy 3rd party dongle at fault.
  • richardjamesc Level 1 Level 1 (20 points)

    I found that ‘steermouse’ doesn’t seem to cause any problems with the new trackpad... Hope this helps

  • loadedsith at gmail Level 1 Level 1 (0 points)

    I am using Lion (10.7) on a i7 mbp, and was getting this error when I was trying to configure the magic trackpad.

     

    I had a trackpad that would connect but behave like a wireless mouse; no gestures and no tap to click.

     

    I had installed USB Overdrive prior to updating to Lion.

     

    I ran the unistaller which told me USBOverdrive was not installed. I re-installed it, rebooted as requested, and then used the unistaller.

     

    After the uninstall reboot I could tell, instantly, that it was fixed entirely based on feel, I confirmed the success in System Preferences.

     

    Thank you Internet!