2 Replies Latest reply: Aug 21, 2010 2:37 AM by paulnose
Jonas Zimmermann Level 1 (55 points)
Since last night, I have a weird problem on my iPad. The App Store app on my iPad won't open. I.e. it will start up (and it has enough time to actually connect to iTunes store and find that updates are available), but then it immediately takes me to iTunes app before I can interact with it. That way, I can neither update apps from my iPad nor buy new ones directly.

Oddly enough, this only happens with my UK account; my German and US accounts work fine, and it also works normally on my iPhone 4, and until now it never caused problems.

I've synced the iPad several times with my Mac, I've restarted it, I've signed out an in again into my iTunes account from within the iTunes app, still the same behaviour.

Has anyone else encountered this? Any tips?

Message was edited by: Jonas Zimmermann

MBP 15in 2.4GHz early 2008, Mac OS X (10.6.4), iPad WiFi, iPhone 4
  • paulnose Level 1 (0 points)
    I just got the same problem on my iPhone 3G after trying to update Skype. I was logged into UK account and it came up with the usual [Account not valid for store] message, instead of opening the proper store as usual and allowing me to login with US account, the app store just started redirecting to itunes. And the update was stuck. After 2 reboots I was able to use Skype again, but the App store is still broken. Tried the same thing with logining in and out, but can't get to the store with my UK or US account. Did a resync to the computer as well and same issue, contemplating a restore now....
  • paulnose Level 1 (0 points)
    Did the restore and all is well now.

    Steps to take...
    1. Perform backup, (right click / control click on device in iTunes and select from popup)
    2. Press restore button in iTunes for device
    3. After restore select the recent backup to reload device.

    Once it's all sync'd it should be fine, my guess is that something corrupted the firmware.