7 Replies Latest reply: Oct 27, 2010 10:03 AM by MajorIP4
SamGutteridge Level 1 Level 1 (0 points)
I have a full connection to my wireless router on my iPhone however I cannot connect to the internet. I can connect on my laptop so I know the internet is working. I can also connect to the internet using 3G on my phone.

I have tried updating my router firmware, checked my internet settings, reset my network settings on my phone but still nothing works.

Any ideas?

Thanks

iOS 4
  • GZukes Level 4 Level 4 (1,565 points)
    If you have a D-Link router, I may have an answer for you.
  • intrepidtoo Level 1 Level 1 (0 points)
    I have a similar problem, can connect via wifi but not via the cellular network since returning from Egypt. I can make phone calls, send receive sms's etc but safari, gmail and any internet apps all say no internet connection available. I've check all the settings (which are identical to another Iphone which works and connects perfectly well)and toggled the 3G, cellular data settings off and on.
    The recommended solution is Settings\Reset\Reset Networking Setting but I am reluctant to do this as I suspect that on restarting I'll be asked for my Sim PIN which I have no idea about since I've never had to use it in the past 3 years. Are these generally standard "OOOO" and are there any other surprise Qs likely to be needed to which I wont know the answer? - bought the phone unlocked by Optus in Aus recently.
  • Nethus Level 1 Level 1 (0 points)
    I have the same problems, and it is a D-Link router if you have any tips?? I swear i've tried everything I can think of and put it down to hardware fault :\
  • GZukes Level 4 Level 4 (1,565 points)
    Does your D-Link router have an option for SecuresSpot and it is disabled? There is a known issue with some D-Link routers with SecureSpot hijacking your Internet connection. The symptoms are being able to connect to your WiFi network, but most apps that use Internet not being able to send or receive data. One big clue is Safari being being sent to http://dir-625.bsecure.com/ or a similar URL. Note that dir-625 is the model number of the router, so the URL may be different for you.

    If this matches your situation, the temporary solution is to open your router settings, enable SecureSpot, save router settings, disable SecureSpot, then save the settings. This should temporarily fix the problem. These D-Link routers have a bad habit of enabling SecureSpot without notice, so you'll probably be doing this whole process again.

    I got so fed up with doing this process over and over, that I contacted D-Link Tech Support, then customer support and had the router replaced.
  • Nethus Level 1 Level 1 (0 points)
    I appreciate the reply, however this does not match my situation. My modem/router model very new, released ~3-6months ago so dlink mustve solved that issue. If only we knew what this issue was though!

    Cheers
  • lokesh755 Level 1 Level 1 (0 points)
    I have been facing that problem since months. Now I found solution.

    Just open wifi connection on iphone and fill manually ip address, subnet mask and remaining fields.

    Thats it
  • MajorIP4 Level 1 Level 1 (20 points)
    I already uses static IP but I still lose internet connectivity at times. Wifi icon shows but no connectivity. Only way to resolve is turn off/on wifi in settings.