Previous 1 2 3 Next 30 Replies Latest reply: Oct 28, 2015 8:51 AM by jonnybovine Go to original post
  • KingsleyS Level 1 Level 1
    I have a Canon MP610 which worked for a while on my iMac but now won't. I have followed the instructions on eHow for using this printer with a Mac but no success. The printer screen tells me the printer is off-line but it is all plugged in and ready to go. I can print from my PC if I connect printer to that so I know it is working. Any suggestions as to how I can solve this difficulty?
  • MacNewby24 Level 1 Level 1
    Thanks so much for those detailed instructions! Worked perfectly.
  • Petefromphilly Level 1 Level 1
    I have an canon pixma mp600. Out of the blue I was also getting printer these offline messages (they drove me crazy!). It was connected directly to the USB - the computers could not recognize it because it was "offline" I tried several different laptops and desktops - mac and pc- and different usb cables - all to no avail. I tried new drivers and many other things. I also contacted the canon help line - they insisted the usb was faulty on the printer and suggested i buy a new printer!!!
    After extensive searching online I found one post suggesting the problem could be solved if the printer was unplugged (not just turned off but disconnected from the power). I unplugged the power cable for 5 minutes and repowered up and voila problem was solved. It worked. Hope this helps someone - dont ask me how it started or why it works but it does.
  • lollyberry Level 1 Level 1
    Thanks for all this, it's been more help than apple AND Canon put together! Apple tried to convince me that my printer's WIFI was broken and Canon that my Airport was broken! Thanks so much!!!!! It worked when I turned my firewall off and reset the the printers on print and fax in the system prefs!!!!!


    Lol x
  • Dirty knees tog Level 1 Level 1
    This worked for me!
  • CU Bill Level 1 Level 1
    Unplugging the printer from the power source and waiting a few minutes, just like one person said, worked for me as well. Spent hours trying to fix this... Figured it had to be something simple. Thanks for the help.
  • Clavdivs Level 1 Level 1
    I would like to add my name to the list of the grateful for solving this problem. PAHU, Thanks so much!!!! I have spent probably 5 hours trying to troubleshoot this and your post about adding a wireless printer (rather than USB) did the trick.

    +In the interest of desperate web searchers like myself who took awhile to find this posting... I am having using my Canon MX340 printer wirelessly. My imac (OS X 10.6 Snow Leopard) could not print using wifi (linksys wrt54g router). See PAHU's post about adding another printer to solve this problem.+
  • dude_uber Level 1 Level 1
    PAHU, I'll happily add my name to the chorus of grateful hair-tearer-outerers who you've helped. in my case you saved my wireless printing bacon a couple of times and i am so grateful.

    thank you so much

  • Emma_B Level 1 Level 1

    Thankyou so much....

    we have been trying to fix this on our Canon MX410 for months.....nowhere before have we found the information about there being two types of print queues set up....


    It took me a little while to re-set up though (wireless printer would not show up on Add a printer as described - even though configured and showing up in Canon IJ network  tool) for the reference of others, here is what I did:

    • removed all printers from system print & fax window
    • went to setup (dropdown option) on CanonIJ network tool (note that printer no longer visible once step above performed)
    • plugged in USB and followed directions on screen for new setup (incl power off etc)
    • removed USB cable (and power back on)
    • wireless printer (and scanner) now showing up in Add a printer (selected and called 'location' wireless)
    • print & fax now showing 2 up canon printers ('wireless' online, and other offline)
    • changed location name of offline printer to USB
    • able to test print for each version perfectly (location tells me if USB or not)


  • mof01 Level 1 Level 1

    I have a Canon MP600 was trying stuff like re-installing the drivers , however with no joy.


    Then I read your comment re. plugging out the printer and it worked a treat. !!


    Thanks !

  • Mona - Dubai Level 1 Level 1

    Thanks Pahu - I was having issues with my new Canon printer/scanner/copier but this post helped fix it! 


    Very pleased!

  • Raythedestroyer Level 1 Level 1

    Pahu.  You're the man.  Thanks.  works for Canon Mg3100 series.

  • David Ousley Level 1 Level 1

    I did finally get my Canon MX922 to work. I deleted the driver that the Canon CD had me install. The software on the accompanying disk seemed to be the problem. I've added the printer to my network using the interface right on the printer. This took several attempts as there are a few choices how to do this. I ended up using the WPS method as the printer failed to recognizing my network password.  Using Airport Utility I was able get past the printer wanting me to "hold the button on my access point" instead I used the "add WPS Printer" that is function within the app. I went into setting on my Mac and opened 'print & scan' where you can add a printer with the "+" button. I did have to clear a previous printer there before added the one that finally worked.


    I hope this info is helpful to some other person (like me) that made the mistake of buying a POS Canon printer.

  • madmax1973 Level 1 Level 1

    also worked for me !


  • JAX.A.C Level 1 Level 1

    Five years and this info is still relevant!!