Previous 1 2 3 4 Next 58 Replies Latest reply: Jun 30, 2015 11:19 AM by Paul B. Duke Go to original post
  • sabbione Level 1 Level 1 (0 points)
    I have disabled Bluetooth 4 days ago and no issue since then...
    Will let you know if the problem is solved for good this way
  • mulrich1 Level 1 Level 1 (0 points)
    I'm having this same problem on my MBP. It's getting harder to convince my wife that macs really are better than PC's.

    The only way I can fix it is to click the trackpad repeatedly until it works appropriately.
  • nlmoreaux Level 1 Level 1 (5 points)
    Same problem on my MBP' trackpad and my "magic trackpad", since 2 months.

    Double tap seems to fix the problem for me.

    Disturbing... really...
  • DanielQuinlan Level 1 Level 1 (5 points)
    I have the same problem on my 15" MacBook Pro Unibody. The trick mentioned above that seemed to clear it was triple clicking with the trackpad. The shirt trick didn't work.

    I really wish Apple would fix the trackpad device driver.

    Daniel
  • sabbione Level 1 Level 1 (0 points)
    15 days after disabling Bluetooth still no issue...
    I think I got it.
  • fjkl324qfa Level 1 Level 1 (0 points)
    3 months and still no fix from apple? <3
  • Osmiridium Level 1 Level 1 (0 points)
    Triple-clicking on the lower left corner of the trackpad (as suggested by others) seems to work for my unibody MBPro 17.
  • mgudites Level 1 Level 1 (95 points)
    Having this issue as well, and it's just maddening. I have a Magic Trackpad hooked up to my new Mini. Pretty much every time I use it, it gets stuck in "drag" or "select" mode, and I usually just have to mash a bunch of stuff to get it working again. I already returned one unit because I thought it was just bad, but I guess it's just software.

    I have dragging completely turned off in preferences.
  • SeanKelly Level 1 Level 1 (70 points)
    I too suffer from the Magic Trackpad "sticking" on a button press or drag selection. It happens occasionally, say once every other day or so.

    The quickest fix I've found is to turn the trackpad off (hold down the power button on the right side until you see "Trackpad off" on your display), then turn it back on (tap the power button—you should see "Connected" on your display).

    No mouse, T-shirt, toggling Bluetooth on the Mac, or more arcane trickery required!

    This is on an older model MacBook Pro (2,1 Intel Core 2 Duo 2.33 GHz), 10.6.4.
  • Sam M. Level 3 Level 3 (590 points)
    Unfortunately this does not apply to trackpads built into Apple's portables, such as the malfunctioning one on my MacBook Pro.

    -SM
  • essd Level 1 Level 1 (10 points)
    The solution posted on one of the other threads has worked consistently for me to fix a stuck MBP trackpad:

    Position your thumb and index finger vertically near the left side of the trackpad. Tap both fingers down together, then lift your fingers, move a little bit to the right, and tap again...continue doing this until you reach the right side of the trackpad. I've been experiencing this problem occasionally for a few months, and doing this trick has always saved me.
  • rudlab Level 1 Level 1 (0 points)
    I have had the same problem as others with MagicTrackpad since I started using it last september with my MacBook Pro 17" (early 2008). At the same time the built in Trackpad on the MacBook Pro continues to work perfectly normally. So does my MagicMouse.

    Resetting the PRAM makes no difference. I can stop the misbehavior of MagicTrackpad for a short time by making a right click somewhere in a text document. After a short while the misbehavior starts again.

    The local Apple dealer has already exchanged my first MagicTrackpad for a new one after having deemed the first one as not functioning properly. However the second MagicTrackpad misbehaves just as the first one. My (unsatisfactory) solution is to turn of MagicTrackpad and use MagicMouse instead, - with no problems turning up!
  • jerry1234 Level 1 Level 1 (0 points)
    Make sure you go to system preferences and un check the dragging box. Then restart the computer and that should fix this problem.
  • Sam M. Level 3 Level 3 (590 points)
    Nice, I'll have to try that the next time it acts up. I've only heard of the uncheck the dragging box in system preferences, which hasn't worked, and sticking a shirt in between the trackpad or some crazy fabric maneuver.

    -SM
  • ekrock12345 Level 1 Level 1 (0 points)
    On my 15" MacBook Pro (aluminum case) purchased November 2008 I had all "One Finger" TrackPad options unchecked under System Preferences and the problem still occurred.

    Per discussion in other threads I have since unchecked ALL TrackPad options as well as gone under Universal Accessibility and set it to ignore built-in TrackPad when there's an external mouse attached. We'll see if that helps.