Previous 1 2 3 4 Next 57 Replies Latest reply: Jul 23, 2013 10:44 AM by HenryS Go to original post
  • Hitz86 Level 1 Level 1 (0 points)
    Just to add to the voices of discontent on here.

    I am using both the trackpad on a 2010 MacBook Pro as well as the Magic TrackPad, and they both have the exact same issue.

    Doesn't matter which app I use it in, so I figure it must be a software update issue.
  • seahawk09 Level 1 Level 1 (0 points)
    I have tried everything possible to make my track pad work with no luck I finally decided to throw it out. I hated to do it but it was becoming a book end for me. I think apple needs to do a lot more testing on bluetooth before releasing things to the public like a new car. I own an imac and love it i love macs don't get me wrong i just think more testing is really needed. I will save up my money and try a wireless mouse from apple I still have a lot of faith in apple there not going away anytime soon Microsoft needs some healthy competition. I look forward to many more years of Mac stuff to come.


    Richard
  • toyakumar Level 1 Level 1 (0 points)
    I am having the same problem with the trackpad of my macbook, purchased in 2006. this is driving me nuts. restarted several times, turned dragging off, tried everything i could think of. anybody with a fix out there? please help!
  • Tom Kenney Level 1 Level 1 (115 points)
    The track pad on a Black MacBook stopped working, stuck down permanently in the "select" position.

    An iFix thread suggested that it might be a swollen battery that should be replaced.

    I removed the battery and the track pad worked fine with the battery out.

    I then gingerly replaced the battery and gently tightened the locking screw and, voila, working fine, at least for now.
  • De Minister Level 1 Level 1 (0 points)

    I have had this issue with several machines before. I have it again on a 17" unibody from 2010. Only in the old aluminum power and macbooks, the battery could cause a problem. although the battery is placed under the trackpad in the new macbook pro it is working fine and no wires are running over the battery. It is most probably a hardware related problem. Have a look if the trackpad is registering the swipes and clicks if you use the lower half of the trackpad, it mostly works that way. Replacing the trackpad is the only option. It has probably reached the end of its life.

  • Bret Comnes Level 1 Level 1 (20 points)

    I am having the same issue.  The physical click mechanism does not bounce back reliably, especially after clicking and holding down for a drag.  How lousy!  It looks like others are getting the same issue.  Apple should replace it with a version that does not have this issue.

  • onebit Level 1 Level 1 (0 points)

    Just got a magic trackpad, I am experiencing the "stuck on select" problem. It is hard to believe that for over a year this has gone on with no resolution from Apple.

     

    Am I mistaken? Has Apple offered no solution?

  • doctordrey Level 1 Level 1 (0 points)

    I also have this issue on my brand new MBA. Can't believe it hasn't been resolved yet!

     

    Does anyone have a fix for this?

  • cornaclia Level 1 Level 1 (0 points)

    I, too, am having this problem. I am using an Intel Core 2 Duo MacBook (purchased in 2008 or 2009; I can't recall), running Snow Leopard (v. 10.6.8). The issue has become chronic within the last few weeks. I can't seem to escape it -- whether I use the trackpad, my wireless bluetooth mouse, and, less often, the keyboard! Very concerned and not impressed. Would appreciate some feedback. Clearly, buying a newer MacBook is not the answer. Am I to return to the PC? I have too admit I had an easier time using my mom's laptop -- running Windows Vista -- than my MacBook as of late.

     

    The issue is so vexing my MacBook is essentially unusable. I simply can't get anything done between rebooting before the glitch sets in again. While I enjoy the challenge of extending my keyboarding skills I will have to stop using my MacBook (and will be using an alternative OS) going forward UNLESS someone can explain and help rectify the situation!

     

    Tx.

  • PeterG61 Level 1 Level 1 (0 points)

    I have two Magic Touchpads, one on my iMac early 2008 Core 2 Duo and my wife's 2011 MBP.  Both machines running Lion.

     

    The Magic Trackpads seem to go into "select" mode by themselves, meaning that every hyperlink, email  or desktop icon I  This issue is a recurring problem on BOTH MTs and on BOTH computers.  Have been dealing with it by rebooting, which seems to clear up the problem temporarily.  I just tried two of the suggested fixes (three taps in lower left corner & slow, single taps with thumb and forefinger arranged vertically about 2" apart, depressing the pad at about midway starting on the left edge, lifting up and depressing several more times moving fingers from left edge to right edge.)  All I can say is that one of these seemed to do the trick, at least temporarily.

     

    My MT then started to "stick" in the select mode after about 10 minutes or so.  I then went into settings and de-selected the "three finger drag" option, but was unable to restart due to a program running in background that I don't want to shut down at this time.  Regardless, the "three finger drag" option was no longer responding, so I assume it took even without restart. 

     

    The problem again went away temporarily, but I noticed that it was behaving a bit differently:  I would move my cursor over a link or icon, hold it there for several seconds, but this time it would only "select" and open a link if my index finger was too close to the centerpoint of the MT.  In fact, my Magic Trackpad now seemed to be extremely sensitive - lightly brushing the pad would trigger it to "select" text or open links.  Notice I said "lightly touching," not depressing or tapping. Less than a gram of pressure on the pad would set it off without any audible "click" from the trackpad mechanism.

     

    This time I went back into settings and de-selected the "Tap to Click" / "Tap with One Finger" option.  I also shut off the MT for about 30 seconds and then turned it back on. 

     

    It has been running for the past half hour with no problems -- and both the "three finger drag" and "tap to click" functions remain inoperable, so I again assume that the settings changes were successful.

     

    As I used the shotgun method to solve the problem, I can't t say with certainty whether any one of them, or the combination, was the Magic Elixir.  All I can say is that my MT is finally operating as it should. 

     

    At least it is worth a try before pulling out hair or taking a 20# sledge to your MT.  Will keep y'all posted. 

  • PeterG61 Level 1 Level 1 (0 points)

    Just to summarize the "Magic Touchpad Elixir" in my previous post, for those who don't want to sift through the "Extended Play" version:

     

    1) In Trackpad Settings, de-select the "Tap to Click" and "Three Finger Drag" options and close setting pane.

     

     

    2) Turn your Magic Trackpad off, leave it off for about 30 seconds, and then turn it back on.


    3) Use your Magic Trackpad, and hope that the "Magic Trackpad Elixir" works as a long-term fix until Apple gets the firmware for this thing revamped to work properly.

     

    I posted the long version as much for the gurus at Apple (there might be a clue or two buried in it for those who know what to look for) as an option for MT owners who are considering pitching them.

     

    Stay Tuned.

  • FlyingMonkeyBusiness Level 1 Level 1 (0 points)

    Thanks for your post, De Minister !

     

    I need to ask for clarification.  Did you mean to say-- to cure the intermittent and erratic behaviour of the Magic Trackpad, replace the trackpad in the laptop?  (NOT the Magic Trackpad, itself?)

     

    I have two suggestions, however improbable a cure they might be.

     

    First suggestion-- Check for a swollen laptop battery.  I had the same experience as Tom Kenney, who reported that a swollen battery in the laptop caused problems.  In my situation, internal pressure from the swelling battery eventually popped the battery out of a 2008 17inch MacBook Pro. But before that happened, the internal pressure must have pushed upward, pressing the laptop's trackpad and clicker to a point of intermittent contact, confusing the laptop as to what was depressed and released.  Among other intermittent symptoms, the cursor seemed to mysteriously get "stuck" to, and later release selections, unpredictably. 

     

    My lesson learned is to periodically inspect an older MacBook (or other aging mobile iOS device) for suspicious bulging of the case. 

     

    Second suggestion-- Check to see that the Magic Trackpad is not wedged under something on your desk, like the MacBook, itself.  In my situation, the bulging battery lifted the MacBook just high enough off the desk, to start accidentally wedging a corner of the Magic Trackpad downward, in the depressed position.  At first, I though the clicker in the Magic Trackpad was broken. (I probably should have looked at the underside of that 2008 MacBook, at that time.)

  • HenryS Level 2 Level 2 (295 points)

    May I suggest a mechanical problem? Here's what I found on my MT (Magic Trackpad). First try this test (either with the MT on or off):

    1. Push in the center of the MT.
    2. Feel/hear the springiness of the pad as it responds to pushes and returns to unpushed condition.
    3. Now, push on the very lowest left (or right-hand) edge of the MT.
    4. Check for the springiness of the pad and that it has returned to being springy (clicking noise should be apparent from the above). See Picture.
    5. Clean the area to be sure small items are not interfering with the button depressing.

    HMS_2013-07-23_Mechanical Issue_Apple MagicTrackpad_1.jpg

    Repeat the test. If the test still stops the selection/push of the pad switches, you may have a left or right side defective mechanical push area (button). Inspect the button area in the photo. Posible workarounds are to use the upper areas of the pad which may place less pressure on the switch allowing it to return to it's resting spot easier.

     

    I compared my MT with a brand new one that my wife got and it had a much better feel and passed the test, while mine failed. Note that we're speaking about the MAGIC TRACKPAD not the buiult-in trackpad(s) on MB / MBP's.

Previous 1 2 3 4 Next