Previous 1 2 3 4 Next 58 Replies Latest reply: Jun 30, 2015 11:19 AM by Paul B. Duke
BGmail Level 1 (55 points)
The MT seems to have selected some text. I cannot seem to unselect the text. Whenever I move the cursor it selects whatever is under it. i have tried hitting ESC to unselect it but still not working.

Has anyone esle run into this problem with the MT? If so what did you do to fix it?

Thanks and I look forward to your reply.

iMac(20" early 2008),MBP, Mac OS X (10.5.6), Proud owner of iPhone4 3Gs 32GB
  • ianh_au Level 1 (0 points)
    Friend of mine is experiencing the same problem with the MT. His solution is a very specific pattern of mashing.

    I've also noticed it a couple of times on my MBP. Suspect its related to the MT software update that came through a few days ago.
  • dpdpdp Level 1 (40 points)
    I don't know if this helps, but see if on the Trackpad preference pane, you have "Three Fingers" set to "Dragging". When I set things this way, three fingers together will indeed drag a window, when the pointer is on the window bar -- but highlights text otherwise, in a way that's hard to get rid of. (Whether this is a bug or a feature, I can't tell.) Unchecking "Three Fingers", or setting it to "Swype to Navigate" changes this behavior.

    (It's possible, of course, that your problem is different.)
  • Lo-fi guy Level 1 (0 points)
    I'm having this problem constantly, but on my macbook trackpad. I, too, believe that it's due to the software update for the trackpad, since it started happening immediately after making this update. I've called Apple twice about it now, and they gave me BS answers that didn't help.

    Note that I've got my "One Finger" prefs set for Tap to Click and Dragging (but not Drag Lock). It's not the default setting, which explains why this hasn't shown up as a huge epidemic for them yet.

    I hope they fix this soon - it's really annoying.
  • CompuMagic Level 1 (0 points)
    I am having the same issue and it's very annoying... I thought my trackpad needed cleaning or that some moisture was getting on it but now I read others are having the same issue... I tried hitting Fn Control Alt Esc or some such combo to get rid of it - may have worked but does not solve cause of the problem which now seems to be a bug.
  • jd2020 Level 1 (15 points)
    I have this problem too: mouse click stuck causing select text or select icons on desktop. Started within past few weeks and happens occasionally. Only solution for me is to restart. My settings are similar to realbrick's. My Trackpad "Finger" settings are:

    One: Tap to click, Dragging
    Two: Scroll w/Inertia, Rotate, Screen Zoom, Secondary Tap
    Three: Swipe to Nav
    Four: Swipe Up/Down, Swipe Left/Right
  • jd2020 Level 1 (15 points)
    I should note this problem is on my 2010 MacBook Pro 15" and not on Magic Trackpad, but its the same problem.
  • frcepeda45 Level 1 (0 points)
    Same here on a MacBookPro7,1... I right click when this happens, and it solves the issue w/o a reboot. Give it a try!
  • ILOVE2OPER8 Level 1 (0 points)
    My trackpad on my late 2008 Macbook Pro also often (sometimes all the time...) selects everything on the screen where the mouse cursor is at that time.
    Really annoying, because it just keep clicking and selecting, so moves windows, change cursor position during typing and lots more annoying things.

    BUT I don't think my / the problem is software related !!!!!
    I have my Macbook now for little over 2 years, and what I suspect is that the housing of the Macbook (to the left and right of the trackpad) is bending down towards the bottom of the laptop (so towards your legs if the laptop is just sitting in your lap). Maybe it's material fatigue or it becomes softer when it becomes warm/hot because of the battery....

    It sometimes gets so worse that I just have to touch the long edge of the laptop soooooo very gentle, with one finger, and it responds as a mouse click.

    The problem comes and goes. Sometimes its not there for weeks, and other times its there for a long time.
    Really annoying because the laptop is now over 2 years old, and I don't think I have warranty anymore.... (and also because it is the "old" all silver Macbook Pro 17" and they don't make these anymore. And I like the look of it better then the new line of Macbook's.

    Ideas anyone ?????
  • jerry1234 Level 1 (0 points)
    I also have a non unibody macbook pro and the case has bowed twice and they meaning the mac store has had to replace the top case twice. I think your problem is the bluetooth antanna is not placed in the proper place. After one of my replacement covers the same thing happened to me. I also have the trackpad and it works very well for me. Also the older macbook pros the bluetooth works better than the new unibody macbook pros. I hope this helps.
  • ILOVE2OPER8 Level 1 (0 points)
    Can I ask you jerry1234 what the costs were for this replacement of the top case??
  • ILOVE2OPER8 Level 1 (0 points)
    Oh yes, and why would the problem be the placement of the bluetooth antenna??
  • jerry1234 Level 1 (0 points)
    The replacement cost of the top cover is 700.00 ,500.00 for the part and 200.00 to put it on I was covered by applecare. My cost nothing.
  • sp3ci4lk Level 1 (0 points)
    Some news...

    I also am having this "stuck" trackpad issue with my 13" 2010 MacBook Pro. It started happening almost immediately after downloading and installing the trackpad update. I called Apple a couple of times about this and they gave me a case number. They took several steps with me to try and resolve the issue but were unsuccessful.

    They finally put me in touch with a senior advisor, who emailed me an Apple data capture utility that does just what it's called and then dumps a data file onto your desktop. I run it when the trackpad starts to "stick" and then send them the file. Per my last communication with them, they've forwarded the files to engineering who is currently analyzing the files to determine what the deal is.

    As soon as I hear something back, I'll let y'all know.
  • free_refil Level 1 (0 points)
    I too am having this issue. I have the updated software installed on 10.6.4 for support of the Magic Trackpad and experience this problem regularly! I disable and then re-enable bluetooth to get it unstuck!!!
Previous 1 2 3 4 Next