11 Replies Latest reply: Dec 23, 2010 11:52 PM by keithypat
fiazco Level 1 (10 points)
When I'm at home, my iPad should recognize my own wifi, when I notice that it either does, or does not, I go into the menu settings and click on connect to wifi. It does so until I leave my iPad to idle for whatever reason, when I come back to continue browsing where I left off, it's in 3G mode...does ANYONE know how to solve this problem so that it constantly STAYS on wifi?? Thanks

  • Tamara Level 6 (13,730 points)
    Have you updated to 4.0.1? This seems to have corrected the issue for many people.
  • apple4ever Level 2 (375 points)
    Update to 4.0.1??? The actual firmware is 3.2.1…

    Did you try turning off QoS (Quality of service) setting on your SMCD3GN wireless router in some routers it is called WMM (Wireless Multi Media). Turn this setting off.

    Have you tried to switched the router to only 'g' instead of 'b/g'.

    Please don't forget to mark the topic as "Answered", that helps others when looking for an answer.

    enjoy your magic machine
  • Tamara Level 6 (13,730 points)
    You're right. I was over at the iPhone forum and still had 4.0.1 on the brain.

    The OP did not mention what router he is using.
  • jhstubbs Level 1 (5 points)
    This is exactly what is happening to me! I have been currently using the wi-fi network in my home. Once the ipad goes to sleep or it turns off, it puts it back every time onto the 3g network automatically. This didn't use to happen. I now have to go into wi-fi networks and select my home network for it to join again even though I have the "Ask to Join Networks" button selected to on. This should be happening automatically like it used to and stay in my wi-fi network.

    I tried resetting the Network Settings and that didn't help.

    Something is going wrong and it is so annoying!!
  • fiazco Level 1 (10 points)
    Sorry for the slow response, it seems jhstubbs and I are having the same problem. As far as I know, I have not updated to the newest version of iTunes yet, which I believe came out sometime after apples iPhone 4. But if doing so will fix this problem, I'm all for it. Jhstubbs, is your iPad updated w the latest firmware?
  • jhstubbs Level 1 (5 points)
    Yes everything has been updated, ipad as well as iTunes. I'm wondering if there is something in the recent update that is making this do this. I don't usually sync my iPad however I did on Monday- wonder if that did something.
    I have also tried resetting the network settings as well as turning on the HTTP to manual. (someone else suggested those things- no luck!).I now have resorted to turning off cellular data to off and that puts the wifi on and leaves it on while I'm at home.
  • jhstubbs Level 1 (5 points)
    Ok I think I fixed this! I had changed my screen brightness the other day by making it dimmer. Ever since then the wifi has been shutting off and going straight to 3G. I have since changed it back to the brightest possible setting. For some reason this has made my Wifi stay on for 3 hours so far!

    This is definitely a problem that sounds like others are having. I have tried all the other suggestions such as resetting the network and changing the HTTP to manual. Nothing has helped however this sliding the brightness bar to the brightest setting seems to have done the trick. So far.......
  • Icahnoclast Level 1 (10 points)
    I recently took my iPad on the road and connected without difficulty to 2 wifi networks in two different homes in which I stayed. Previously, the iPad worked fine with my wifi network at home. Now I cannot pick up the network. I am sitting 2 feet from the router. My iMac and MacBook pick up a strong signal. The iPad shows a strong signal when I go into wifi settings, but only the 3G icon/logo/whatever appears at top left when I exit settings. I have tried "Renew Lease" and changing the HTTP Proxy settings. Nothing helps. I did synch the iPad when I returned from my trip. I am told everything is up to date.

    If I turn off "Cellular Data" in settings, "iPad" appears in the upper left-hand corner of the screen in place of ATT and the bars. The wifi fan appears in place of 3G indicating a very strong signal. But if I try to connect to a web page I get: "Could not complete request, no Internet connection." Shouldn't I be able to turn off 3G and just use wifi? My ATT usage is mounting up. The first month I used about half of my allotted 2 GB. This month I have used almost 600 MB in 6 days. If this issue continues, I think we should be allowed unlimited 3G usage until the problem is solved.
  • Tailspin7 Level 1 (0 points)
    I'm having a similar problem. Here is the equipment I'm using.

    Ipad 3G - 3.2.1 firmware
    iPhone 3g - 3.1.3 firmware
    netgear wireless router
    roadrunner home internet
    ITunes 9.2

    I have 3g turned off on my ipad (it was a gift I haven't decided to buy a data plan yet). Whenever I am at home and I use any of the built in apps that touch the Internet (maps, AppStore, iBook store) i lose all Internet access in my house and have to reset my router and wait at least 2 hours before any device can connect to it again. I haven't had this problem at all before getting my ipad.
  • Mr.C UK Level 2 (410 points)
    I fail to see why you should get unlimited 3G because your wi-fi at home is not working. If there is an issue with wi-fi on your iPad it's not the responsibility of AT&T and has nothing to do with them. If anyone is responsible to help you resolve it it would be Apple and that is assuming it's a problem with your iPad and not your home wi-fi connection.
  • keithypat Level 1 (0 points)
    I just bought an IPad. I have the same problem. I connect to Wifi at home, but when I go on the Internet, it automatically connects to 3G and cant connect via Wifi.