7 Replies Latest reply: Aug 8, 2010 10:01 AM by BBQBob
iBobo Level 1 (0 points)
Mouse rightclick on a photo (in Safari) and add to iPhoto doesn´t work anymore. The message reads "Safari can´t communicate with iPhoto"! (SIC) This occured with the latest update of Safari. I think its kind of lousy that the latest version of Safari can´t communicate with iPhoto. I always thought that those kind of problems (lack of integration) was exclusively a Microsoft issue!

iMac, Mac OS X (10.6.4)
  • Carolyn Samit Level 10 (103,365 points)
    HI and welcome to Apple Discussions...

    I have two Macs running v10.6.4 / Safari 5.0.1 without any problems adding images to iPhoto so there's a glitch somewhere in your system.

    Go to ~/Library/Caches/com.apple.Safari and move the cache.db file to the Trash.

    Relaunch Safari and try adding an image to iPhoto.

    If that didn't help, go here for trouble shooting 3rd party plugins or input managers which might be causing the problem. Safari: Add-ons may cause Safari to unexpectedly quit or have performance issues







    Carolyn
  • AV2008 Level 1 (0 points)
    I think the latest Safari version runs the best of any released in the last year and a half. That said, I do though have this same problem w/ iphoto, any fixes would be appreciated though not urgent.
  • Carolyn Samit Level 10 (103,365 points)
    Try repairing disk permissions.



    Launch Disk Utility. (Applications/Utilities) Select MacintoshHD in the panel on the left, select the FirstAid tab. Click: Repair Disk Permissions. When it's finished from the Menu Bar, Quit Disk Utility and restart your Mac. If you see a long list of "messages" in the permissions window, it's ok. That can be ignored. As long as you see, "Permissions Repair Complete" when it's finished... you're done. Quit Disk Utility and *restart your Mac.*




  • AV2008 Level 1 (0 points)
    Tried repairing permissions but still no luck.
  • Carolyn Samit Level 10 (103,365 points)
    Try a control click on your keyboard instead.





  • AV2008 Level 1 (0 points)
    Cntrl-click did it, Thanks.
  • BBQBob Level 1 (0 points)
    I'm having the same problem lately. The first message I get in iPhoto is the file can't B found then the can't communicate message. I've found that if I go right back to the image and right click to send it 2 iPhoto it works. Also as of late I have a new problem with iPhoto. I can't print a photo. When I click on the printer icon on the photo page the icon just blinks and nothing happens. When I click on print from the file menu I get a message that no theme can B found so it won't print. WTH R themes???