8 Replies Latest reply: Aug 9, 2010 12:38 PM by Walter Branam
Walter Branam Level 1 Level 1 (60 points)
Before I installed Snow Leopard auto fill was working fine but since then when I type my email address, my name, address, etc auto fill doesn't work. I've got all three boxes checked the Safari preferences.

Your help is appreciated.
Rookie

MAC PRO and MacBook Pro, Mac OS X (10.6.4), 10GB RAM
  • 1. Re: Auto fill not working
    Carolyn Samit Level 10 Level 10 (89,745 points)
    HI,

    Open Keychain Access (Applications / Utilities) Select Passwords on the left.

    Move the "Safari Forms Autofill" keychain to the Trash. Quit Keychain Access

    Relaunch Safari. Navigate to a site that requires your user name and password. Click Yes when prompted.









    Carolyn
  • 2. Re: Auto fill not working
    Walter Branam Level 1 Level 1 (60 points)
    Thanks. I will try this today.

    Does this have anything to do with my Address Book to get the information for Auto Fill? I've noticed that there is not an icon of a person beside my name in address book unlike previous OS X versions. And I don't know how to get the icon back.

    I appreciate your all's help.
    Rookie
  • 3. Re: Auto fill not working
    Carolyn Samit Level 10 Level 10 (89,745 points)
    HI,

    If you look at Safari/Preferences - Autofill

    You can select: Using info from my Address Book card

    Not sure about the icon issue. Try posting in the Snow Leopard - Mail Forum

    You're welcome.
  • 4. Re: Auto fill not working
    Walter Branam Level 1 Level 1 (60 points)
    Carolyn, I deleted the safari/autofill from Keychain and restarted Safari but it still would not work when I tried two different sites and typed in my username - would not autofill.


    Any other thoughts?
    Rookie
  • 5. Re: Auto fill not working
    Carolyn Samit Level 10 Level 10 (89,745 points)
    Ok..

    tried two different sites


    Open Keychain Access. Delete the keychains for those sites.

    *Relaunch Safari* and try logging into one of those sites again. You should be prompted to save your user name and password again. If so, just click Yes.

    If that doesn't help, open a Finder window. Select your Home Folder in the Sidebar on the left. It has a small house icon. Then open the Library folder, then open the Preferences folder.

    Move this file to the Trash: com.apple.keychainaccess.plist

    Restart your Mac.








  • 6. Re: Auto fill not working
    Walter Branam Level 1 Level 1 (60 points)
    Carolyn, I may be saying one thing and you are thinking another - think your right and I'm wrong.

    When I'm filling out a form when buying something on line so they know where to ship, previously all I had to do is type the first letter of my first name and everything else would auto fill - my first and last name, address, phone number and email address. That's not working now - I have to type every single letter.

    Can you help with this? Thanks.
    Rookie
  • 7. Re: Auto fill not working
    Walter Branam Level 1 Level 1 (60 points)
    Finally found the solution In Apple discussion. Did not have my Address Book Card marked as "self". Check it out at:


    http://discussions.apple.com/thread.jspa?threadID=2252454

    Rookie
  • 8. Re: Auto fill not working
    Carolyn Samit Level 10 Level 10 (89,745 points)
    Wonderful. I hope other Safari users can benefit from your solution.