Skip navigation

iPhone Calendar Alerts not Working

35130 Views 19 Replies Latest reply: Aug 9, 2012 10:57 AM by mikeheck2009 RSS
1 2 Previous Next
Doug Mckenzie-Mohr1 Calculating status...
Currently Being Moderated
Aug 6, 2010 11:34 AM
I have an iPhone 3Gs which syncs with my MacBook Pro via MobileMe. I'm using the most recent OS for both the phone and the notebook. If I create an event in iCal and set an alarm for the event it goes off on my notebook, but not on my iPhone. If I set an event on my iPhone with an alarm it goes off in both locations. Alerts are set to "On" for the calendar application on the iPhone. This worked properly prior iOS 4.0. Any suggestions? Thanks in advance.
  • hallmansm Calculating status...
    Currently Being Moderated
    Aug 9, 2010 5:37 PM (in response to Doug Mckenzie-Mohr1)
    I'm having the same problem.
    I have the new iPhone 4, and I use Google Calendar, which syncs to my iPhone calendar. I made sure everything was set up when converting to the new phone.

    When I enter new events in the phone itself, and set an alarm, the alarms just never happen.
    iPhone 4, iOS 4
  • davidwegs Calculating status...
    Currently Being Moderated
    Aug 21, 2010 5:43 AM (in response to hallmansm)
    Plus one.

    I just nearly missed an appointment due to the alert not happening. What is going on with this?

    I have apple care, so I am calling in to see what can be done.
    3G, iOS 4
  • beanyip Calculating status...
    Currently Being Moderated
    Aug 21, 2010 3:01 PM (in response to Doug Mckenzie-Mohr1)
    After upgraded from OS3 to OS4, all calendar alert simply all delayed. They would only went off after the event time say 10-12hours.
    Iphone 3GS, iOS 4
  • Amcraw4d Calculating status...
    Currently Being Moderated
    Sep 1, 2010 2:08 PM (in response to Doug Mckenzie-Mohr1)
    Same issues. Google Calendars (CalDAV) will show the alert in the event details on the iPhone 3GS, but none will actually pop-up.
    iMac 27" 3.2GHz i3 4GB, Mac OS X (10.6.4), MBP 15" 2.4GHz Core2Duo 4GB, iPhone 3GS
  • momus1 Calculating status...
    Currently Being Moderated
    Sep 2, 2010 2:03 AM (in response to Doug Mckenzie-Mohr1)
    Just go to settings, mail-contacts-calendars, and set the "time zone support" in the bottom to OFF!
    Works by me...
    iphone, iOS 4, none
  • Amcraw4d Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 2, 2010 6:40 AM (in response to Doug Mckenzie-Mohr1)
    Unfortunately, disabling time zone support didn't fix the problem. I created an event locally, set an alert and, viola! nothing happened. Any other suggestions?
    iMac 27" 3.2GHz i3 4GB, Mac OS X (10.6.4), MBP 15" 2.4GHz Core2Duo 4GB, iPhone 3GS iOS4
  • rest_easy Calculating status...
    Currently Being Moderated
    Sep 3, 2010 9:37 AM (in response to Amcraw4d)
    I noticed that there are two options for calendar sync. My PC or yahoo. It's on yahoo by default (oddly).
    When I went into yahoo mail on my computer I clicked calendar and it asked me what time zone.
    it was giving me east coast time when I'm on the west coast.
    I set up a calendar event 3 hrs ahead and the alert didn't go off yet. That may do it!
    pc, Windows XP Pro
  • illuminate Calculating status...
    Currently Being Moderated
    Nov 15, 2010 10:40 AM (in response to Doug Mckenzie-Mohr1)
    Go under *Settings/Mail, Contacts, Calendars*, and underneath the Calendar settings, make sure your "time zone support" is set to your local time zone. MY iPhone by default was set to Cupertino (CA where Apple is located). So since that was 3 hours behind my time zone, all my alerts kept going off 3 hours late! As soon as I switched it to my local time zone, the alerts began working correctly!
    apple iphone 4, iOS 4
  • Partwell Calculating status...
    Currently Being Moderated
    Jan 13, 2011 8:21 AM (in response to Doug Mckenzie-Mohr1)
    In Settings, go to sounds. In there you can switch calender alerts on or off. If it is set off, it may explain why you have not had alerts.
    Mac OS X (10.6.6)
  • mahri Calculating status...
    Currently Being Moderated
    Jan 20, 2011 2:18 PM (in response to illuminate)
    Absolutely spot on, I changed to London (UK) time and the alerts have worked perfectly since. I had been onto iphone support and they suggested I reset my phone, really pleased I read your comments. Thank you.
    iphone 4, iOS 4
  • diana1953 Calculating status...
    Currently Being Moderated
    Mar 5, 2011 12:14 PM (in response to Doug Mckenzie-Mohr1)
    Solution for incorrect alerts with iPhone 4 and Google Calendar.

    I called into Apple customer support, and I believe that I have found a solution for this problem.

    I have my iPhone 4 synced with my Google calendar. The alerts were not up to date.

    To fix the problem, I went into "Settings", "Mail, Contacts, Calendars", "Gmail", and turned off the Calendar. I deleted the calendar entries off the iPhone when prompted.

    I then turned back on the Calendar in Gmail settings.

    After doing this, open up the calendar on the iPhone. Select the "Calendars" button in the upper left corner, and enable the main calendar by selecting it.

    All of my alerts showed up and refreshed correctly.
    MacBook Pro, Mac OS X (10.6.6), iPhone 4 version 4.2.6
  • nickcapetown Calculating status...
    Currently Being Moderated
    May 10, 2011 11:35 PM (in response to Doug Mckenzie-Mohr1)

    Just to add to Doug's post...

    I'm on the same system - syncing between my iPhone (4) and iCal on my Mac via MobileMe.  Never had any problems when I was phone iPhone 3, and not sure when I started getting this problem with my iPhone 4 (may have been when upgrading to new MobileMe calendar), but I am not getting pop-up alerts which I have set up in iCal on my iPhone.  They do pop up on my Mac desktop, but not on the iPhone.  The thing is, when I go into Calendar on my iPhone, all the events that I created in iCal are there to be seen in Calendar on the iPhone, and when I select one of those events, all the correct information (including the alerts) are there to be seen.

    So the information all appears to be correctly in the iPhone ... and hence I would not have thought it could be a syncing issue.

    But come the time for that alert to pop-up on my phone and it just doesn't do it. 

     

    I have checked other issues mentioned, like the time zone. 

     

    ... I've just applied the fix suggested by diana1953 (but in my case applying MobileMe where she has referred to Google Calendar / Gmail) and it seems to have worked on the test event I set.  Thanks.

  • jrcchicago Calculating status...
    Currently Being Moderated
    May 18, 2011 7:06 AM (in response to nickcapetown)

    Glad to see this thread - I've had this issue for weeks. I have the same setup as NickfromCapetown, so I'm trying Diana1953's solution (subbing MobileMe for Gmail). Hope it works.

  • jrcchicago Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 18, 2011 8:13 AM (in response to jrcchicago)

    Tried Diana1953's steps and got an odd result: when the phone is locked, the alarm goes off as it should, but not when the phone is unlocked. Will try rebooting and test it again. Any other suggestions?

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.