12 Replies Latest reply: Aug 8, 2010 10:20 AM by Allan Jones
Allen Rubin Level 1 Level 1 (20 points)
My MacBook Pro (late 2006, Snow Leopard) runs fine once it's booted... no problems... restarts quickly without problems, but if I shut it down (like at night) it will not start up without a lot of fiddling. From a cold start, when I push the power button the first time, the screen lights up, Apple logo appears, spinning gear appears, and after a minute or so gear stops spinning and nothing happens. Then I press and hold power button till MacBook shuts down. I press button again, power light comes on, but screen stays black for many minutes. I force shutdown again, press power button and do a PRAM reset, then MacBook boots normally and runs fine until the next time I shut it down. I have to repeat this procedure almost every time I shut down the MacBook, especially overnight. Any ideas?

eMac G4, Mac OS X (10.4.5), MacBook Pro - Mac OS X (10.6.4)
  • JasonFear Level 5 Level 5 (4,935 points)

    During the startup process (Apple logo with spinning gear) the system is going through a series of basic self checks and the loading of the OS. Interestingly enough the startup process is no different in a shut down to power on scenario then a restart scenario.

    Do you notice any performance issues with your machine when you're in the operating system? Any sluggishness? Any issues with peripherals that are connected to the machine?

    I'd vote you try a Safe Boot and force a full directory check, in addition to possibly running some basic diagnostics from the OS X Installation disc that came with your machine.

    Safe Mode - http://support.apple.com/kb/ht1455

    Disk Verification Troubleshooting - http://support.apple.com/kb/ts1417
  • Allen Rubin Level 1 Level 1 (20 points)
    Thanks, I'll give the safe boot a try and get back to you......
  • Allen Rubin Level 1 Level 1 (20 points)
    OK, here's what I have done (not in order)

    1. Reset the Pram
    2. Reset the SMU
    3. Safe Boot
    4. Reinstalled the system (Snow Leopard) and 10.6.4 update
    5. Ran TechTool Pro to check hardware (no problems found)

    The only thing I haven't done is run DiskWarrior (I ordered the latest version but it hasn't arrived yet.)
    The problem still persists.....
  • JasonFear Level 5 Level 5 (4,935 points)
    Hi Allen,

    I'd say that DiskWarrior might be excessive at this point, especially after you reinstalled the OS. A reinstall of the OS would theoretically resolve any sort of directory corruption. Regarding TechTool Pro, regrettably that isn't much for finding hardware faults. In my 5+ years of providing direct hardware support in multiple environments has brought me to the conclusion that the best hardware failure detection software out there is the stuff that Apple gives their service centers and Genius Bars (not consumer available stuff).

    But I digress... what you probably did was an Archive & Install of Snow Leopard. Unlike in previous versions of OS X, Snow Leopard doesn't give you the choice of Archive & Install vs. Erase & Install, it just performs an Archive & Install. You have to go into Disk Utility and erase the drive first if you want the benefit of the "E&I" approach. That'd be my vote for the next step, backup your data and perform the Erase & Install. At that point if you're still having difficulties... it's most likely a hardware issue.
  • Allen Rubin Level 1 Level 1 (20 points)
    Thanks, Jason... I didn't do an archive/install.... I had backed up to an external drive (SuperDuper) so I erased the partition and did a clean install. Then I used migration assistant to copy files from the backup drive.

    What's puzzling is that once booted, everything runs normally. Last night I shut down, and this morning here's what happened, in sequence:

    1. Pressed start button, no chime, black screen. Waited about a minute.
    2. Pressed start button and held it down to shut down (I have a USB LED that shows when computer is on.) Waited about two minutes.
    3. Pressed start button, immediate chime, gray screen, chime again, chime again, chime again, continuous chiming.
    4. Pressed start button and held it to shut down.
    5. Pressed start button, no chime, black screen.

    That's where I am right now.....
  • KXsig Level 2 Level 2 (305 points)
    Hi A,

    So your computer is not normal, first to do is to find out if is the computer or any other connected device. Here is the next step (this should be the first when you are debugging):

    DISCONNECT EVERYTHING that is plugged in your Mac, wait about a minute, turn your computer on, this way you can find out if your USB mentioned device or any other is causing this or if it is really your Mac.

    Good luck.
  • JasonFear Level 5 Level 5 (4,935 points)
    Hi Allen,

    I don't know how familiar you are with the startup sequence of a Mac. But that "chime" you're describing is what's called a POST chime. POST stands for Power On Self Test, a basic check, by the operating system of critical hardware components that the machine requires to run.

    It sounds like something is causing POST to either false positive or fail. What's interesting is that when the machine finally does start running it's perfectly fine. Definitely a weird one...

    I agree with the above poster, unplug any USB related peripherals. I'd also add unplugging the battery and just trying to run the machine on A/C power (for the purposes of troubleshooting). See if there's any change or improvements. If not, then I think the next course of action is a Genius Bar / Service Provider.
  • tjk Level 7 Level 7 (24,185 points)
    Hi Allen,

    Even though the POST does not specifically indicate a RAM issue, I would be suspicious, especially if the RAM is not the original as supplied by Apple.

    If it is not, install the original.

    If it is, take one module out and try running the MBP. Move it to the other slot and try running the MBP. Repeat with the other module. In this way you check out both RAM modules and the RAM slots.
  • Allen Rubin Level 1 Level 1 (20 points)
    Thank you one and all for the wealth of information, insights, and suggestions. Although I finally got the MBP running (reset SMC then reset PRAM), I decided it was time to get some "expert" help and took it to the Genius Bar. Cursory examination suggested a memory problem (even though TechTool Pro said it was OK). Anyway, they are running a complete diagnostic and will call me in a few hours with the results and what needs to be done to solve the problem.

    Again, please accept my deepest thanks for your kind attention to my posts, and I'll post again when the problem is fixed so we can tie the symptoms to the disease.
  • JasonFear Level 5 Level 5 (4,935 points)
    Allen Rubin wrote:
    (even though TechTool Pro said it was OK).

    Allen, happy to hear we're making progress towards a resolution. No surprise with TechTool Pro. From my experience that software is rarely capable of detecting the problem and in most situations will tell you something's wrong on a component that isn't the problem.
  • Allen Rubin Level 1 Level 1 (20 points)
    Jason (and all),

    Problem solved! Apple's diagnostics found a faulty memory controller on the logic board. Otherwise the remaining hardware passed all tests. Apparently, during POST, the malfunctioning of the controller interrupted startup. That's why the PRAM reset worked... it bypassed the controller. Once operating, the faulty controller only caused sporadic problems (kernel panics).

    Anyway, the memory controller is not replaceable, it's soldered to the logic board, so I'm out about $300 for a new (replacement) logic board.

    Once again, thanks to all for your help. If this had not been a hardware problem, I'm certain your advice would have done the trick!!

  • Allan Jones Level 7 Level 7 (33,500 points)
    The good news, or maybe the "better" news is the the $300 charge indicates a "depot repair." Computers often come back with other little deficits fixed, all covered under the flat-fee system. You should have a nicely refurbed computer when it comes back for far less than the cost of a new unit.