5 Replies Latest reply: Oct 25, 2010 9:54 PM by topgan1
markrich21 Level 1 Level 1 (0 points)
1. I have suddenly lost several icons on my Finder bar; the text label is there but the actual icon of the button is missing. I can click on the place where they should be and the function works.
2. Locations is now missing from the Sidebar and if I try to click in the selection boxes the X in the box disappears as soon as I click it.
I have several Admin profiles. My normal profile is missing the Locations on the Finder sidebar whereas Locations show on the other 2 profiles. However the Finder icons problem is present on every user profile.
I had the Finder window open and tried to use Time Machine to go back to an uncorrupted backup. But each Finder window that opened showed the same problem.

Any suggestions?

 Mac mini 2.26 Intel Core 2 Duo, 4BG DDR3  G5 PowerPC 1.8 DP, Mac OS X (10.6.4)
  • Kappy Level 10 Level 10 (245,295 points)
    Press COMMAND-OPTION-ESC to open the task manager, select Finder, click on the Relaunch button. If that doesn't help then try moving the /Home/Library/Caches/com.apple.finder/ folder to your Desktop then relaunch the Finder. If the problem is fixed trash the folder you moved to the Desktop.
  • markrich21 Level 1 Level 1 (0 points)
    Under my logged in user profile, there is no com.apple.finder file there.... I have tried repeatedly to relaunch the Finder but that hasn't changed anything.
    How can I save my files and other settings in this profile so I could delete the profile, open another that doesn't have a problem and restore the files? They may be on my HD but it seems like I am logging onto a totally different Mac when I change profiles.
  • Kappy Level 10 Level 10 (245,295 points)
    You're saying that in the /Home/Library/Caches/ folder there is no folder name 'com.apple.finder?' This is a folder, not a file.

    You can also move the /Home/Library/Preferences/com.apple.finder.plist file to your Desktop and relaunch the Finder

    Your files are fine. You cannot simply delete a user account nor replace it with another. So for now do not even try.

    You might also do this:

    Repairing the Hard Drive and Permissions

    Boot from your OS X Installer disc. After the installer loads select your language and click on the Continue button. When the menu bar appears select Disk Utility from the Installer menu (Utilities menu for Tiger, Leopard or Snow Leopard.) After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list. In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive. If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return to the installer. Now restart normally.

    If DU reports errors it cannot fix, then you will need Disk Warrior and/or Tech Tool Pro to repair the drive. If you don't have either of them or if neither of them can fix the drive, then you will need to reformat the drive and reinstall OS X.
  • markrich21 Level 1 Level 1 (0 points)
    I ended up using Backup to save my Home folder, Music, Documents and Applications then ran a complete reinstall of Snow Leopard. After I rebooted all my apps and files were in place, the FInder is back to normal and all is well with the world.
    I wish I could isolate the original issue but I am very thankful for the Apple community as a resource!
    Hope everyone has a wonderful weekend!
    MR
  • topgan1 Level 1 Level 1 (5 points)
    I have exactly the same problem with my mac. It happened just after I run Onyx and executed some maintenance/repair permissions scripts from this program. I did that because I couldn't move any files in the system and I thought using Onyx to repair permissions will do the trick.
    Well actually it did as I can now move folders/files at the system but now I can't see and folder icons, my places on the sidebar at the finder window isn't working anymore.

    I tried creating another administrator but I have the same problem there too. I also tried removing finder.plist under my user/library/preferences folder and relaunching (and restarting) afterwards but nothing worked.

    Any help will be appreciated.
    thanks in advance