Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Disk Utility says: "Unable to read FAT (Input/output error)"

I have a Western Digital Passport external hard drive factory formatted as FAT32. It worked as advertised for over half a year before it suddenly stopped working and refuses to mount on the desktop (it is visible in /dev). No odd sounds and the disk or other problems, a different USB cable makes no difference.

The disk shows up as an empty disk in Windows 7 even though it is supposed to contain a small iTunes library. I have tried to repair the disk in Disk Utility in OS X 10.6.4. This is the latest attempt to repair the disk, copied from the log:
2010-08-10 15:58:44 +0200: ** /dev/disk2s1 (NO WRITE)
2010-08-10 15:58:44 +0200: ** Phase 1 - Preparing FAT
2010-08-10 15:58:44 +0200: ** Phase 2 - Checking Directories
2010-08-10 15:58:44 +0200: Unable to read FAT (Input/output error)


Does anyone have any recommendation on repair/recovery applications? I own a copy of DIskWarrior already but DW is a HFS-olny repair app…

iMac intel, Mac OS X (10.6.4)

Posted on

Reply

There’s more to the conversation

Read all replies

Page content loaded

User profile for user: Niklas Brunberg

Question: Disk Utility says: "Unable to read FAT (Input/output error)"