Previous 1 2 3 Next 145 Replies Latest reply: Jun 10, 2014 2:41 PM by norman from santa monica Branched to a new discussion.
dfv12 Level 1 (0 points)
Sometime when I'm using my MacBook the trackpad gets stuck on 'Drag Lock' mode. So that wherever I move my cursor it will drag whatever it comes across. Does anyone else have this problem? If so, how do I fix it?

MacBook 13-inch Aluminum (Late 2008), Mac OS X (10.6.4)
  • StealingVision Level 1 (0 points)
    I have this exact same problem. If someone could help us out that would be great. It's annoying to have to restart the whole OS every time.
  • mandemcole Level 1 (0 points)
    I have the exact same problem but on my MacBook Pro (Early 2009). Seems the only way to resolve once it happens is a restart.

    This is tantamount to a system crash as far as I'm concerned. If it happens, I can't do any work until I have rebooted the whole system.

    It also messes with which elements have focus and how they behave (eg if a text box is clicked in, the cursor selects only the last typed character when I press the back cursor key rather than moving the cursor back through the text).

    This feels like a problem with OS X to me. Unless this starts happening with the new Magic Trackpad however (ie a high profile new product), I wouldn't hold your breath for a fix. We're probably just need to 'touch it different'...
  • Nicholas Walmsley Level 1 (5 points)
    same problem. started after recent trackpad update. multiple posts on these forums about it. maybe playing with trackpad settings could help.
  • Nicholas Walmsley Level 1 (5 points)
    i've turned off dragging with one finger to see if this helps.
  • Lo-fi guy Level 1 (0 points)
    Yes, looking around on the various forums that complain about this issue, it seems like the problem surfaces when one-finger dragging is turned on.

    Unfortunately, that's how I like to drag.
  • dfv12 Level 1 (0 points)
    I forgot to mention that my problems also began after the recent trackpad update. Also, I have turned off the one-finger dragging and it seems that the problem has disappeared for now.

    Message was edited by: dfv12
  • mrako84 Level 1 (0 points)
    *I maybe found a temporary solution to the problem but I first have to state beforehand that I have a MacBook Pro 17" (Unibody). Dragging on my Trackpad gets stuck every now and then at random points. It started a month or so ago probably after a trackpad update (I don't remember).*

    *Anyhow, this is what I did:*

    *I was surfing the web with Firefox and suddenly dragging got stuck. I quit Firefox and pressed the Power On/Off button. I got this dialog box:*


    *I clicked on cancel because I wanted to check one more thing and I realized that the dragging got unstuck. I don't know if it was a coincidence and I'd like to check that again but, as said before, the Trackpad gets stuck at random points.*
    *Try by yourselves and tell me if it does really work. Of course this isn't supposed to be a definitive solution to the problem but I hope it will help in order not to restart your machine.*
  • mrako84 Level 1 (0 points)
    *Forget about my previous message. It got stuck again and I tried what I wrote above. _IT DOES NOT WORK!_ It seems that it was just a coincidence.*
  • Dave Luebbert Level 1 (95 points)
    I am also having this problem. Only relief of symptoms is restarting the computer. I have noticed that my bluetooth mouse is not affected. I'm not sure how to recreate this problem, however it seems that when it has happened, the macbook has woken from sleep.
  • pundit Level 1 (0 points)
    I would like to point out that I see the same problem. It has been happening quite frequently since a recent update (I don't know for sure which one). The way I resolve it currently is to go to Trackpad Settings in System Preferences and then close the preference pane. It seems to reset something in the process.

    I hope this problem is addressed in a future update as it is extremely annoying.
  • dfv12 Level 1 (0 points)
    I think the only way to resolve the issue is by turning off one-finger dragging. I have had it off for around five days and it the Drag Lock problem hasn't occurred once.
  • artdoggy Level 1 (0 points)
    I don't have one-finger dragging on and am still having this happen - a lot. I've had to restart my machine 5x in a couple hours. very frustrating.
  • dfv12 Level 1 (0 points)
    That's really strange that you have to restart so often, for when I experienced this problem it was usually only once or twice per day. Have you noticed anything that could've triggered the problem to appear?
  • SaintG3 Level 1 (0 points)
    I have the same problem. Before the update trackpad worked perfectly, since the update sticks on drag and destroys my desktop, Only a full restart fixes this problem. I have been using macs for fifteen years and they seem to be getting more glitchy.
Previous 1 2 3 Next