Previous 1 6 7 8 9 10 Next 145 Replies Latest reply: Jun 10, 2014 2:41 PM by norman from santa monica Go to original post Branched to a new discussion.
  • J.Raven Level 1 (0 points)

    I too have had this problem for a few days now, I have no clue what is causing this, but it's getting extremely annoying. I hope we can find the cause together, because it doesn't seem to be a bug in the trackpad software (given this topic was started two years ago)

  • IvanLasston Level 1 (0 points)

    I think I have this same problem.  It happens to me on reboot.  When an icon is stuck while dragging - I do a 1 finger click, 2 finger click, 3 finger click - and keep repeating.  Once the ctrl-click menu comes up (a 2 finger click if you have your Mac setup that way) the drag problem goes away for me.


    I do have Better touch tool installed - and 3 finger click is set to middle button - so for me I am doing a left click, middle click, right click and cycling through until the drag lock releases.

  • nlk000 Level 1 (0 points)

    I had the problem with OS 10.5.8, Now I upgraded to Lion 10.7.3   everything seems fine

  • radium226 Level 1 (0 points)

    I had this problem some time ago.  My solution was to remove one of the following (I removed all three and I'm not sure which fixed it): 


    - Move Addict (adds Cut & Paste in finder)

    - Right Zoom (makes the + zoom button make a window full screen like in MS Windows)

    - USB Overdrive (lets you adjust mouse accelleration curve to be more MS Windows-like)


    So if you're running one of those, try disabling them.

  • kript Level 1 (0 points)

    For what its worth, I appear to have fixed this for me by deleting the mouse and trackpad plist files in ~/Library/Preferences;


    MyMac:Documents john$ ls ~/Library/Preferences/ | grep -i mouse

    MyMac:Documents john$ ls ~/Library/Preferences/ | grep -i trackpad


    OSX then recreated the files on reboot, and I seem to be fine.  Had to log in as a seperate admin user to do this, though.


    Running Lion, if that helps.


    Hope that helps



  • zero-out Level 1 (0 points)

    After a complete clean OS install, the problem yet remained. A hardware issue was all that was left. Stuck click pad? Functions as if it is being held down as pointer is moved anywhere.


    Attempted in several ways to unstick: slide paper and card stock around edges to clean any "residues" which may have gummed up the works, removed battery and air blasted from top and bottom, sprayed teflon lubricant into top edges. No luck, even though it did free it up somewhat.


    About 2 years out of warranty, took it up to Apple Genius Desk to see what they would say. They said no problem, they'd take it in and replace top panel N/C. Picked it up a few days later, and am now a happy camper.  Go Apple!


    Now I need to take in my white unibody MacBook for cracks that have developed (and grown critical) to both screen shell, and unibody shell, dropped and lost several screws out the bottom (2 of 3 I was able to replace out of older units), and a  screen issue (fading out if tilted to certain angles). Still in extended warranty (BTW, this is a unit given as a FREE replacement for a previous generation unit that was out of extended warranty! )

  • Yohannon Level 1 (0 points)

    Okay, I've been having this issue with my 15" unibody macbook pro (no battery cover to remove!) for several weeks now. At first it was intermittents, and hard re-boots would help. Now, however, no amount of rebooting, resetting NVRAM, removing trackpad plists, and so forth will help.


    A lof of people seemed to think that it's a hardware issue, so I grapped the trackpad from my desktop and tried that. To my surprise, it suffers from the SAME ISSUE. I already had thought it wasn't hardware as even using gestures without the physical mouse click wouldn't work, but this confirmed it.


    To be clear, the problem is I select a file to drag it, and releasing the mouse does not "release" the dragged file from the cursor, as if no mouseup event was sent. Clicking with escape down releases it, but that's useless as I can't drag and drop files in the doc, drag to trash, etc. I can work around moving files to trash with select | cmd-delete, and opening files using right-click to open in a specific app, but file moves/copies are almost impossible to perform (thank goodness I'm unix saavy and fear not the!).


    I've also tried booting up in "safe" mode, and the problem persists. I've tried new accounts as well to see if there was something else in my user prefs housing things.


    I haven't used any third party tools to tweak USB or touchpad functionality. My next trick is to try a clean system install (on another disk) to see if that resolves things. If THAT doesn't work, I'm goin to have to think about firmware issues, which puts this squarely back on Apple.

  • Yohannon Level 1 (0 points)

    sudo rm -r /System/Library/Extensions/APExtFramebuffer.kext




    AIrParrot apparently just HAPPENS to have issues with my specific model of MacBook Pro. "mmmble mmble nVidia driver conflict mmble..."




    Remove the about extension using the Wnter your password, reboot (logging out and in won't do it.

  • Richard Sterner Level 1 (0 points)

    Related to "Goosing your MacBook", I had a 2006 MacBook Pro 15" with this problem. The battery was severely bloated in the middle. When I replaced the battery with a good one, the problem went away. The bloated battery must have been pressing on that spot that metroploitannyc found.

  • maintwocamels Level 1 (0 points)

    You nailed it!


    I'm working on a client's MacBook Pro 17" with the same problem.


    Exact same symptoms.


    I removed the battery, which indeed was severely bloated, and now the mouse works!


    I saw the trackpad hardware underneath the battery.

  • ZissouPhotographic Level 1 (0 points)

    I have Yohannons' exact same problem, is it still the battery issue? I just noticed that my battery needs to be replace...i have a mid-2009 unibody c'mon apple...


    this is a huge problem for me since my job consists of constantly dragging photos to specific folders..

  • Stain Boy Level 1 (10 points)

    i was also having the "drag-lock" problem on my MacBook Pro too. drove me crazy. it was worse on flights where it made using my Mac almost unusable, even with a mouse hooked up.


    turns out it was a physical, not software problem: the battery had swollen slightly, putting pressure on the underside of the trackpad! so the Mac was stuck registering a click-hold which was in conflict with my button presses from an external mouse.


    since this is an older MBP with a user-replaceable battery, all i had to do is swap it out for a new one and my trackpad/click-lock issues cleared right up.


    if you are able to remove your laptop battery, lie it on a clean, flat surface. it should lie completely flat and not wobble if you press down on one end. if you press on any edge of the battery and it lifts the opposite edge up, replace it immediately. if you can't remove the battery, have the tech look at the battery first when you bring it in for service.


    i also highly recommend bringing your defective battery to an Apple Store, so they can see (& hopefully take record of) the issue and dispose of your old battery properly.

  • MishaOnMac4Ever Level 1 (0 points)

    Had the same issue as the rest of you.


    Had to remove AirParrot completely:



  • AJKY Level 1 (10 points)

    It seems AirParrot was my problem too. Following the advice linked by Misha, I no longer have the sticky cursor.

  • RichieNinja Level 1 (0 points)

    Me too.. Doing my nut.. More and more bugs creeping in every week. Loosing faith with Apple at the moment. Guess they just want everyone to spend more money on a newer model..

Previous 1 6 7 8 9 10 Next