Previous 1 6 7 8 9 10 Next 145 Replies Latest reply: Jun 10, 2014 2:41 PM by norman from santa monica Go to original post Branched to a new discussion.
  • cruiser_yng Level 1 Level 1 (0 points)

    Removing AirParrot and its *kext files instantly solved the 'click, drag and never drop' problem.


    Instruction, please refer to:


    Thanks, guys!!

  • jeremy36 Level 1 Level 1 (5 points)

    I've just had this problem on my 15 month old Air 11". Took it Genius Bar and they wanted $110 to fix. I left and cracked open my Mac. It seems that the two thin metal spring plates that attach the trackpad to the body, and keep the trackpad sprung up off the microswitch, becomes slightly bent and loses its springiness. I removed the trackpad and gently bent the sring plates back, reassembled, and now it works fine.

  • barefootin Level 1 Level 1 (0 points)

    Check to make sure your battery didn't swell.  It's directly under the track pad and if the battery heats up, or as some of them get older, they can put pressure on the pad, which is a very sensitive part of your laptop. 


    Test by plugging in to your AC adapter, pulling the battery, and if that works, you may need a new battery.  Note - the batteries from Apple had a problem.  I'm not sure if they resolved the swelling issue, but if not, you can find batteries on eBay.

  • mazz520 Level 1 Level 1 (0 points)

    My Early 2008 Pro running 10.8.4 was having the same issue.  After all my research and troubleshooting, it seems that the app LogMeIn was causing the problem...I hope.  Since I disabled the app, the trackpad has been acting normally.  Hope this helps!

  • Wufflesthespider Level 1 Level 1 (0 points)

    I've just been through my login items one by one to find out which one was causing the problem, and I'm only putting this here in case someone else has this problem and finds this using a search.


    The rogue app for me was RightZoom. Removed that and Illustrator now operates like it always did (and should). Click and object and move the mouse/trackpad without fear of the object being dragged a few pixels.

  • 512 MAcpro Level 1 Level 1 (0 points)

    I have spent at least 2 HOURS troubleshooting!  I have reset the PRAM, the SMC, cleaned the **** out of each entry hole with alcohol and used an air spray to blow out debris.  I also cleaned and recleaned my trackpad.  after shutting my computer on and off a million times,  and reading COUNTLESS suggestions, I finally stumbled upon a forum with an answer!


    Simply push hard on the trackpad and apply pressure across the whole surface.


    I Freakin cant believe it worked!!!

  • mazz520 Level 1 Level 1 (0 points)

    I'm updating my previous post.  Disabling LogMeIn worked fine until I upgraded to Mavericks.  Currently it's stuck on drag again.  Urgh

  • bigmikestudios Level 1 Level 1 (0 points)

    I found disabling "Right Zoom" Fixed this for me.

  • Brazilfallingdown Level 1 Level 1 (0 points)

    Tried command option PR and worked!

  • LWills2 Level 1 Level 1 (0 points)

    I have had this problem so many times, and the only way I can get out of it is to close down the program I am using  or restart my computer. But since I downloaded this app from the app store called "Memory Clean" (which is free) and I think it basically refreshes the memory that is being used by the device (from programs or things that aren't in use) and makes my mac work a bit faster. And so far this seems to have worked for me, but will see how it goes.

    Hope this might help you too .

  • norman from santa monica Level 1 Level 1 (0 points)

    Thank you for posting this! I've tried a dozen things in the last month and it never occured to me to just clean the trackpad.

Previous 1 6 7 8 9 10 Next