Previous 1 2 Next 15 Replies Latest reply: Aug 24, 2010 8:52 PM by djmakk
djmakk Level 1 Level 1 (0 points)
for some reason any updates I receive for my macbook pro through software update, itunes (for ipad, iphone), and even when I manually download them from the website (like 1.6.4 combo) are corrupt.

itunes + ipad with the new 3.2.2 update gives me error 14 with a link to this page http://support.apple.com/kb/TS1275. Not helpful in this case.

As far as OSX updates 10.6.4 would constantly corrupt. As does successive other updates like the recent camera raw update and xcode update. I would blame the OS install and reformat except for some reason when I tried these updates at a friends house they work... really strange. I have also resorted to torrenting the update in the case of the 10.6.4 combo. I would really like this fixed but I am at a loss for what to do, and google hasnt turned up people in similar situations for me.

Could shaw (my Internet provider), my router, or... anything be screwing this up somehow?

macbook pro 2009, Mac OS X (10.6.4)
  • ~Bee Level 7 Level 7 (31,130 points)
    dj --
    You are a confusing character . . .
    Your early posts all boast a "self built" Mac, and now your telling us
    that your using Torrents for your OS.

    Good luck!
    You're going to need it, I'm afraid.
  • djmakk Level 1 Level 1 (0 points)
    I have no idea why the default model field says self built, I just hit post message without thinking. I only have a macbook pro. The torrents was me going out on a limb, getting rather desperate. I dont exactly like the lengths I have to go to here to get official updates. If anyone has any ideas I would much appreciate it.
  • ~Bee Level 7 Level 7 (31,130 points)
    +I have no idea why the default model field says self built.+
    Because you entered it. There is no default choice that says self-built, OK?

    OK, so you were trying to update your MBP, and you got an error that referred you back to
    the +Update and restore alert messages on iPhone, iPad, and iPod touch+ KB page?

    That is very strange.
    Did you have any of these devices connected to your MBP?
    Had you used Torrents before this episode?
  • dbsneddon Level 4 Level 4 (1,525 points)
    The "corrupt" error message can be very misleading... have you actually
    checked the console logs to see what the real error is?

    Dave
  • djmakk Level 1 Level 1 (0 points)
    heres a relevant log, at least I think it is. Its the one generated by trying to update xcode to 3.2.3.

    first the one for the software download:

    10-08-07 5:33:21 PM Software Update[205] SWU: scan found 1 products:
    zzzz061-8720
    com.apple.message.uuid: 11E54BBF-F7D6-48D5-A93A-B8B6CE3B9903
    com.apple.message.domain: com.apple.SoftwareUpdate.time.scan
    com.apple.message.signature: SUCCESS: http://swscan.apple.com/
    com.apple.message.result: success
    com.apple.message.value: 75.43260
    com.apple.message.value2: 2392.263
    com.apple.message.signature2: Software Update
    com.apple.message.signature3: SUScanResultCode, 0

    then the corresponding error:

    10-08-07 5:26:53 PM Software Update[594] PKG: extracting "com.apple.pkg.Xcode3.2.3Update"
    Error Domain=PKInstallErrorDomain Code=110 UserInfo=0x11425fb60 "An error occurred while extracting files from the package “Xcode3.2.3Update.pkg”." Underlying Error=(Error Domain=NSCocoaErrorDomain Code=259 "The file couldn’t be opened because it isn’t in the correct format.") {
    NSFilePath = "/var/folders/zz/zzzivhrRnAmviuee+++++++++/Cleanup At Startup/PKInstallSandbox-tmp/Root/Developer";
    NSLocalizedDescription = "An error occurred while extracting files from the package \U201cXcode3.2.3Update.pkg\U201d.";
    NSURL = "Xcode3.2.3Update.pkg -- file://localhost/Library/Updates/zzzz061-8720/061-8720.English.dist";
    NSUnderlyingError = "Error Domain=NSCocoaErrorDomain Code=259 \"The file couldn\U2019t be opened because it isn\U2019t in the correct format.\"";
    PKInstallPackageIdentifier = "com.apple.pkg.Xcode3.2.3Update";
    }
    com.apple.message.uuid: 466F8978-BD69-44EE-9229-90048E3FF2BF
    com.apple.message.domain: com.apple.PackageKit.install.package.extract
    com.apple.message.signature: FAILURE: com.apple.pkg.Xcode3.2.3Update
    com.apple.message.result: failure
    com.apple.message.value: 1.38748
    com.apple.message.signature2: 1.0.1.1248867338

    --

    I dont see any entries for the ipad update failure in the console.

    --

    "That is very strange.
    Did you have any of these devices connected to your MBP?
    Had you used Torrents before this episode?"

    currently my ipad, its stuck at the restore screen atm as the corropted 3.2.2 failed to load
  • dbsneddon Level 4 Level 4 (1,525 points)
    At your place, the updates are corrupt. At a friend's place the updates
    install correctly. How are you connecting to the internet in both situations?
    If you are using wireless at your place, have you tried a wired connection?

    Dave
  • djmakk Level 1 Level 1 (0 points)
    Just tried over direct connection to my modem bypassing the router. Sadly no open wifi in my apartment building to compare against.
  • ~Bee Level 7 Level 7 (31,130 points)
    dj --
    When you were at your friend's place, was the iPad connected?
  • djmakk Level 1 Level 1 (0 points)
    I was on my way over to his house as it was but didnt want to give up yet on fixing the ipad update problem so I brought both my macbook and my ipad. I decided to run the ipad update again and it worked.
  • djmakk Level 1 Level 1 (0 points)
    I could provide the corrupted iPad1,13.2.2_7B500Restore.ipsw for anyone that can figure something out with it.
  • ~Bee Level 7 Level 7 (31,130 points)
    The .ipsw update is for the iPad and iPhone.
    Were you trying to load this on your Mac?
  • djmakk Level 1 Level 1 (0 points)
    Yes. I plugged it in and it would tell me there is an update and I clicked download and install. It downloads, begins install and fails leaving my ipad in need of a restore... which it cant do because the update is corrupted. is there a way to reinstall the older OS that isnt corrupted temporarily?
  • djmakk Level 1 Level 1 (0 points)
    I started looking for a direct download of 3.2.2 for my ipad. I found this web address: http://appldnld.apple.com/iPad/061-8801.20100811.CvfR5/iPad1,13.2.2_7B500Restore.ipsw

    is that legit? actually from apple's servers?

    --

    To add a bit more mystery, I tried downloading the 10.6.4 combo on another (windows) desktop I have at home and it was also corrupted when I first encountered this problem.
  • djmakk Level 1 Level 1 (0 points)
    http://appldnld.apple.com/iPad/061-8801.20100811.CvfR5/iPad1,13.2.2_7B500Restore.ipsw

    so that is legit and still hands me a corrupted file. I am going to bed, but I will visit starbucks and see what happens with there wifi tomorrow.
Previous 1 2 Next