Previous 1 2 3 4 Next 84 Replies Latest reply: Mar 3, 2014 10:13 AM by Mahambaig Go to original post
  • hijack7 Level 1 Level 1 (0 points)
    The solution is in most cases very simple

    You have lots of dust in the connection slot and it interferes with the Home Button.
    Take a toothpick or a dry toothbrush - clean it up. Problem solved.
  • Gwdanno Level 1 Level 1 (0 points)
    I have found that my phone is doing the same thing, so I start troubleshooting. As it turns out mine is a software issue that seems to be happening frequently among iPhone 4 users. I also found that with my phone I can hold down the home button for a while and the voice recognition screen comes up. If I press home again while the screen is up it will usualy make the button work again. Hope this helps.
  • xdru1967 Level 1 Level 1 (0 points)
    @Gwdanno
    I have the EXACT same problem, with the VR coming up sometimes.
    What was the software issue (and the solution)?
    Thanks!
  • Sam Kidd Level 1 Level 1 (25 points)
    Oh my god, the toothbrush trick actually works!
  • romyls Level 1 Level 1 (0 points)
    I just had the problem today, then when I stuck it right back hard into the Universal Dock it started working then when I vaccummed it, its freaking working faster now. WWWOOOWW
    thanks for the input
  • mgoldsworthy Level 1 Level 1 (0 points)
    i was having this problem, found another place where it was discussed - the solution offered seemed ridiculous, but i gave it a try...

    +*quit the camera app from running in the background*+

    tried it. worked for me. immediately different
  • Canucks1234 Level 1 Level 1 (0 points)
    HI ALL I JUST HAD THIS PROBLEM I WAS READY TO TAKE INTO THE SHOPE WHEN I REALIZED THAT A COUPLE TIMES WHEN I PRESS IT EVERY LIKE 5 MIN OR SO IT WORKED SO I STARTED WITGLEING IT AND I GOT IT TO WORK MORE. MY TRICK WAS PUT MY THUMB ON IT AND SHIFT THE BOTTON IN A CIRCLE WHILE PRESSING AND IT WORKS LIKE NEW I WAS SO HAPPY. I KNOW IT SOUNDS LIKE OH YAH JUST WIGGLE IT BUT TRY IN A CIRCLE CAUSE UT WORKED FOR ME. CHEERS!
  • Thaweesak Level 1 Level 1 (0 points)
    Wow, as weird as the suggestion sounds, this actually worked for me! I don't have a vacuum near me at the moment, so I was like, what's the worst that can happen? And just like that, it's working fine now.

    Thanks Canucks1234!
  • antcer Level 1 Level 1 (0 points)

    Same issue here after upgrade.

  • Jeff Maxwell Level 1 Level 1 (5 points)

    This is consistent with what I found. The natural inclination for a lot of folks is to carry the iPhone port-end-down in a pocket. That interface port can get a lot of dust and dirt (pocket lint) in it, and I've blown it out successfully a few times to get the Home button working. The other thing you have to really be aware of is keeping FOIL - candy wrappers, gum wrappers, etc. - out of the port. I got a tiny bit of foil in there and the phone malfunctioned all over the place. Boot failures, connection prompts, etc., until a tech at the Apple Store who'd seen this before extracted the foil. Worked perfectly after that. I now carry the phone switch-side-down and have had no further problems.

  • Jeff Maxwell Level 1 Level 1 (5 points)

    See my later reply to Shaytoon.

  • robertofromstowe Level 1 Level 1 (0 points)

    Amazing... did the trick!  THanks Channuk

  • barryfromalbany Level 1 Level 1 (0 points)

    My iPhone 4 Home Button first stopped working after a firmware update. A day later it worked again. In a few days it failed again, then for no reason started working several hours later. It now fails every other day or so and then starts to work within a day. I have read many comments online such as to squeeze the left side frame which works sometimes, or to squeeze the upper glass just left of the home button, which often worked, but not always. I attempted to leave the camera app running in the background which seemed to work for about a day till it failed again. I have tried vacuuming, brushing and every other suggestion I've found so far, yet my home button simply stops working for no reason. There seems to be a large number of people that newly discovered this problem at the 4.3.1 or 4.3.2 updates. Please offer some other possible suggestions. I do not believe the button has failed as when it works, it is snappy.

  • tom doris Level 1 Level 1 (0 points)

    hi guys, i had the very same problem so i did the toothpick thing and got all the dust out and it started to work for an hour or two then it stopped again and its been stopping and starting since any suggestions? Also it randomly starts the voice control application without me doing anything.

    P.S. id rather not have to go to an apple store as the nearest one to me is over an hours drive away!

  • markus171 Level 1 Level 1 (0 points)

    I had exactly the same problem over a couple of days after having updated to iOS 4.3. I had about twenty apps running in the background. After I had closed all the apps the home button works perfect again.

Previous 1 2 3 4 Next