4 Replies Latest reply: Aug 13, 2010 4:25 PM by luvlabs
goyanks135 Level 1 Level 1
I just upgraded my router's (linksys WRT110) firmware and reran the setup utility to recreate the network. So it set up fine and was able to get my laptops working perfectly. It is protected with WPA2 personal and my ipod does not want to connect. Everytime I enter the password it says incorrect. When I take the security off it can still connect but when I change it to WPA it cannot connect anymore. Using a WEP key does allow my ipod to connect. My ipod was able to connect using WPA2 before I reset it. Any ideas why it doesnt like the WPA(2)?

dell, Windows Vista
  • luvlabs Level 4 Level 4
    Your password is case sensitive, so be careful typing. I would try resetting network settings on the touch first and then logging back in. Try these steps:

    1. Reboot the router (pull the power cord)
    2. Reset network settings - tap Settings > General > Reset > Reset Network Settings
    3. When the touch restarts, tap Settings > WiFi > Other and re-entering the network name, security, and network password.

    Normally WPA2-psk is the preferred encryption method. The only things I have seen that have caused problems are typing, super long passwords (8 characters are plenty), and bad router firmware. You might want to check your router firmware and see if there have been any known problems with the version you are using.
  • goyanks135 Level 1 Level 1
    No matter what I made the password it would not work. However when I used my brother's ipod, his worked.

    edit: i just reset my router to create a new network with a different name to get it to work.
  • HalfBit `aH Level 1 Level 1
    Did renaming your network work for you?
  • luvlabs Level 4 Level 4
    Steps 2 and 3 should have reconnected you without having to change your network name. However, you found a good solution none the less. Congrats on getting it fixed.