Previous 1 2 3 4 Next 56 Replies Latest reply: Nov 17, 2013 12:57 PM by Dmitry Mottl
Daghis Level 1 Level 1 (0 points)
My Google skills haven't found any matches for this, but perhaps others have seen it in passing at least.

I've noticed recently that I've been having problems with FaceTime calls to a friend of mine. For the past month since he got his iPhone 4, he'd end up losing the WiFi connection, but now it's happening to me, too.

The symptom is that the FaceTime call will be going fine for a while, and then it will just hang with no motion in the picture from the other phone for about 10 seconds, then the phone will beep and display this error:

FaceTime Failed

WiFi Connection Lost


At this point, I find that my WiFi indicator in the status bar is gone and replaced with "3G". It has indeed lost its connection to the WiFi access point (a Time Capsule).

Going into the iPhone's settings, I see that it shows there that it is still connected to my WiFi network (showing a checkmark next to my WiFi network name, although it still says "3G" at the top). Cycling WiFi off and back on corrects the problem.

My friend is also using his iPhone 4 connected to a Time Capsule, so we have similar setups. I'm beginning to wonder whether there's some problem either in iOS 4 or the Time Capsule that causes the wireless connection between them to disconnect in an aberrant fashion.

So, anyone else seen or heard of this?

iPhone 4, iOS 4
  • dvassallo Level 1 Level 1 (0 points)
    I am having the EXACT same problem. Have you made any progress with resolution? Have you been able to rule out if its the iPhone 4 or the Time Capsule causing the problem? Thanks.
  • Daghis Level 1 Level 1 (0 points)
    No, I haven't figured out much yet. I did recently switch to a second wireless router I'm using (a Netgear) to see whether that produces any different results. I thought I had learned something today when it occurred again, but I saw that my iPhone had switched back to my Time Capsule.

    I "forgot" that wireless network so it won't connect back to the Time Capsule again. We'll see if that makes any difference.
  • dvassallo Level 1 Level 1 (0 points)
    Thanks for the quick reply. I am going to do some messing around myself. I am going to try switching to another channel to see if I get different results. Also, I would like to see if forcing the router onto either G or N does anything. I am pulling the crash logs off my iPhone now to see if I can't see anything there.
  • Michael Hodos Level 1 Level 1 (35 points)
    I have been able to FaceTime for 10-15 minutes before I have the exact same connection loss, 3G in the status bar, checkmark next to the correct airport in settings. I have also noticed that my IP address has changed from my 10. space to a self assigned 169. space. After a short time, the IP gets refreshed and I am once again connected.

    iPhone4 connected to an airport express (acting as a bridge only) wired to an airport extreme to cable modem.

    I am not sure, but this smells more like an iOS/Facetime bug than a routing (port) issue (although it could be a router firmware bug).

    Just adding my name to the list of folks with problems and get this some more attention.


    Message was edited by: Michael Hodos
  • dvassallo Level 1 Level 1 (0 points)
    Hi Michael...thanks for providing details of your situation. I have some more observations from my experience:

    1) I have examined my iPhone 4 crash logs located at
    ~/Library/Logs/CrashReporter/MobileDevice/<DEVICE_NAME>...I did not find anything of interest indication that any particular service or application was crashing or failing.

    2) My environment is as such: Time Capsule wired to cable modem. Airport Express joined to the network to provide's not acting as a WDS or extending the network in any way.
  • Sharon Gordon Level 2 Level 2 (160 points)
    Nothing to add, but I am having this same issue. I only notice it on FaceTime calls, but I can't say it doesn't happen at other times -- since it rolls over to 3G, I could easily just not notice.
  • Daghis Level 1 Level 1 (0 points)
    I recently had the problem occur even when I was connected to my Netgear wireless network, so it's not restricted to just when I use the Time Capsule.

    Since upgrading to 4.1, I've noticed that I've lost my Wifi connection a few times during FaceTime calls, but I didn't get the same "WiFi Connection Lost" pop-up message. I do notice that my WiFi status indicator is replaced by 3G, so I cycle my WiFi off and back on, and that restores it.
  • eloquent Level 1 Level 1 (0 points)
    same Problem... iPhone 4 4.1 ... Got the same Problem over the past few weeks... dont know how to solve it.... Upgrade to Firmware 4.2.1 did not solve the problem
  • EZ Jim Level 7 Level 7 (21,865 points)
    I don't have iPhone, so I cannot confirm your problem, but if you have not already considered these, one of them might help you:

    Mac Pro Quad Core (Early 2009) 2.93Ghz Mac OS X (10.6.5); MacBook Pro (13 inch, Mid 2009) 2.26GHz (10.6.5)
    LED Cinema Display; G4 PowerBook 1.67GHz (10.4.11); iBookSE 366MHz (10.3.9); External iSight; iPod4touch4.2.1
  • bradfromminot Level 1 Level 1 (0 points)

    FaceTime connection problems on my iPad2 was magically solved by changing the DNS number (in the Settings > Wi-Fi menus) to:



    (yes, there is a space after the comma, and a space after the numbers 7)


    I recommend that you write down your present DNS number for safekeeping before you make this change.


    I hope this solves your FaceTime connection problem!


    All the best,


    Brad P.

  • rduenow Level 1 Level 1 (0 points)

    I have the same problem, too, except it also knocks my wi-fi completely offline.  I have to reset my network on the iphone and reboot the router.  It happens everytime I've tried to use FaceTime, so I've quit using i, because it's such a pain to restore my network and iPhone.


    I'm using a Verizon Router and have a verizon iPhone4 with latest OS.

  • D Anderson Level 2 Level 2 (150 points)

    Exactly same problem here with iPhone 4 and Airport Extreme wired to a VDSL modem (FTTC).


    I have the feeling it may be temperature related, the iPhone being on with high speed 2 way video for a few minutes get quite warm and perhaps the iPhone is shutting down the WiFi chip. I know that my Wifi is still working as the Macs stay connected all the time when this problem happens on FaceTime.


    I may try and get the iPhone replaced under AppleCare warranty just in case it is a sign of the wifi chip starting to die in the phone.

  • ASW-19 Level 1 Level 1 (0 points)

    I have exactly the same problem and it happens often.  Apple should a great deal more testing of changes before releasing to the public. Frustrating.

  • aquariusrick Level 1 Level 1 (0 points)

    I have exactly the same problem with iPhone 4 connected to Airport Extreme. My iPad 2 does not have this problem, so I believe it's specific to the iPhone 4. The comment about heat seems to be relevant in my case too. It happens with FaceTime and with Skype. Cycling the WiFi on the iPhone seems to be the only fix, but it's very annoying. Definitely not what I expect from my Apple device.

Previous 1 2 3 4 Next