Previous 1 2 Next 18 Replies Latest reply: Oct 12, 2014 7:33 AM by Bartek_Poland Go to original post
  • Edwardo7 Level 1 (0 points)

    I have the same issue with my MacBook. Wifi works, but my wired ethernet port won't get an IP address from DHCP and self assigns 169.x.x.x. After reading this thread and getting mine to work, here's my guess at what's happening. There is poor communication between my mac and the dhcp server when the address up for renewal is already taken, eventually timing out. Maybe the Mac doesn't deal well with rejection or the dhcp server isn't good about suggesting an alternative. Apparently Windows PCs, as much as I dislike them, are more tolerant about this sort of thing. This can be resolved by configuring the DHCP sever to assign a fixed IP address based on the Mac's MAC address. This is what I did, and it worked like a snap. Manually configuring would have worked too, but this way I don't have to worry about DNS servers changing, etc. If you don't have the ability to change the server's config, other resolutions might include some of the recipes described in this thread, which amount to various ways of erasing the Mac's memory of what address it wanted to renew.

  • paulfromburwood Level 1 (90 points)

    Yet another one having the same issue.

     

    I have one iMac in the office that wont get the DHCP details, I manually configure it and it works.

     

    I have tried booting it from a a clean install, no joy. I have a NetBoot server running, I hold down N on boot and nothing happens.

  • paulfromburwood Level 1 (90 points)

    And like that I have it working, I reset the SMC and it worked

     

    http://support.apple.com/kb/HT3964

  • Bartek_Poland Level 1 (0 points)

    I have the same problem (macbook pro mid 2012).

    I go to Settings>Network>Ethernet>Advanced>Proxy, uncheck everything, and delete everything in the text box.

    Now ethernet is working ok and get DHCP address correct .

Previous 1 2 Next