Previous 1 5 6 7 8 9 Next 200 Replies Latest reply: Jul 12, 2015 9:54 AM by matthewfromdublin Go to original post Branched to a new discussion.
  • juliafromrpv Level 1 Level 1

    Thank you Sylarmatt. So far my new iPhone hasn't had a problem and I am keeping it in the charger. There was definately dust in there not a huge amount but I used compressed air to clean it out. Thanks! I hope my new phone continues to work with out incident. Thanks again.

  • IDG100 Level 1 Level 1

    This is not to fix to any contamination to the headphone socket, but a fix to the Random locking and a lack of sound with a stuck speaker button that stays on:


    The issue seems to only affect the iPhone 4s as my 2nd iPhone 4 is fine and has never had the issue.


    Resolution :


    Update to anyone who has the random issue of no sound on the iPhone 4s when its used as a phone, dialing out or receiving calls with the use of headphones or not . The phone also "sticks" on with the speaker button illuminated when headphones are plugged in and will not switch off .


    I found initially a reboot of the iPhone4s allowed it to work for one call, but then when the headphones were plugged in, the speaker button would sometimes light up and you could never get the sound back onto the headphones or the ear piece , I would also miss calls as the the dialer couldn't hear me ...pretty useless !!


    I tried "Backing" up and "Restoring from a backup". But I still had the issue.


    I reported the issue to Apple and with their help, as they have seen the issues before I understand  you have to 100% Factory "Restore" the phone via itunes.

    Make sure you have the very latest Firmware code loaded ( 9A406). This is the version of F/W that was released on the 2nd release of iOS 5.0.1.  As the first release used F/W 9A405)

    To loaded F/W 9A406 you have to 100% restore the phone via itunes and it will then load iOS 5.0.1 + the latest F/W (9A406) irrespective if you already have iOs 5.0.1 (the late iOS loaded as this came with F/W 9A405. FYI: This  F/W update is only loaded here on a factory restore ..!!!!


    I ask Apple ...great why don't you indicated this and load it automatically as its different bundle of code ...their response was "its there if you have any issues, as not everyone does and to load it on an already running iOS 5.0.1 iphone4s it needs a factory "restore" of the phone" !!! So this is why its manual process !!!


    Before you run the above process make sure you have a "full sync" of the phone via itunes , this is different to a "backup" as you can't pick off the apps with a" backup " you get "full image" copy.


    After you have Factory restored the phone , "do not restore yia an old backup" as it will reload the intermittent speaker/headphone issue back on to the phone. 

    ( I have proved this after fixing the issue, as I then reverse engineered the iphone4s  back to its old state by restoring from an old backup and the speaker issues followed the backup !!!


    You have to treat the phone as "new" and reload all the apps and contacts via itunes manually as a "sync" .


    Since then I have not had a speaker/headphone issue .


    Hope this helps someone as I couldn't find a true resolution on the web .

  • Sehr Level 1 Level 1

    hi there,

    u think u could help me with my ip4s ?

    same problem-till this morning was all ok-then one app no sound through speakers. the other apps are good

    but this one only works with headphones ! i tried EVERYTHING! calling them, cleaning with a tissue pressing the right corners ! nothing doing. tried delelting then installing another app like the one-same problem-works only through the headphones !

    thanks in advance

    btw i got the phone last week. n apple says its the app problem ! yeah right !!! was fine till this morning.

  • m2asia Level 1 Level 1

    This just worked great for me! Thanks for sharing!

  • purpleladybug99 Level 1 Level 1

    I was having the same problem with my iphone 4S... I've only had it for a month and a half and suddenly no sound on apps, alert tones, music etc... but it would work fine with headphones or during phone calls.  I'd tried all of the restore options and the tissue in the headphone jack, none of which worked.  I then turned my attenetion to charging slot.. blowing out the dust has worked!!!  Thanks so much for everyones suggestions!

  • hhiller2059 Level 1 Level 1

    having the same problem. did you find a solution or does the entire phone need to be replaced for it to work again??

  • AirCerberus Level 1 Level 1

    Hello, I desperately need help. I've had this iPhone 4 since August, and I lost it for 3 weeks in a field, then found it, and it worked only due to the fact that i had a heavy-duty case on it. I don't have a warranty on it, by the way. Otherwise, it wouldnt be working at all. But, then I found out that the home button didnt work, and the sound had problems (Which I will go over in a second). The home button now works (whenever it feels like it), but let me explain the problem with the sound.


    So, whenever I have headphones on, the sound works perfectly, but then without them, there is no sound. However, I would get sound for like 5 seconds after turning it on, and then nothing. But, you can hear the lock-opening sound, and the ringer music is also the only thing that works, as well. When i turn the volume up or down, it shows the sound icon, but no squares that indicate its volume. If i press it down enough times, it will show the icon without the lines (Just like if you turned down the volume all the way). But no music, or any other type of sound plays.


    I have looked at the other suggestions of what to do. I'm probably sure it's the water damage from 3 weeks of exposure to sun, rain, etc., so I tried the towel in the headphone jack, squeezing the corner, blow dryer, all didn't work. I believe that the damage has been done so the sound short circuits after it gets turned on, but that doesnt explain how I can hear ringtones. If someone can help me, it will be appreciated, thank you. :)

  • deggie Level 9 Level 9

    Do an out-of-warranty replacement for $149 USD.

  • Sehr Level 1 Level 1 try fiddling with the mute button on the side next to the volume buttons-just flick it up or down then c if that helps. best of luck

  • AirCerberus Level 1 Level 1

    That didnt work, I might have to go with the replacement unless anyone can give any other methods of trying to get it to work. But thank you anyways for trying!

  • rajpoon Level 1 Level 1

    ohh yes!!! hair dyrer works perfectly

  • Foo313 Level 1 Level 1

    I notice I have the same problem in order to get the sound to work I have to go to YouTube or something in the video player turn the video sound up and then the sounds work even if in iTunes/iPod music the sound is up that doesn't seem to matter the video sound has to be up in order for the other sounds


    Once the video sound is not completly off then the sound can be adjusted with the sound buttons on the side of the phone.


    I'm not sure if this is a hardware or software issue.

  • Browndamiersosa Level 1 Level 1

    "Very occasionnally " ? My ip4 has been stuck on headphone mode since the day i plugged  in the earphones (the day I bought it), and since then I cant listen to anything through the speakers , exept for the occasional click sound when unlock it.

  • hawley1987 Level 1 Level 1

    Using a blow drying in the headphone jack fixed the problem

  • leoalmeida Level 1 Level 1

    @cranpipe, thanks a lot buddy! Your tip worked for me.


    The key was the USB connector. There was some moisture there and connecting the power cord made the speaker working immediately! Soon I will try a definitive fix, with a hairdryer.


    Thanks again, pal!



Previous 1 5 6 7 8 9 Next