5 Replies Latest reply: Aug 18, 2010 6:55 AM by allen12
allen12 Level 1 Level 1 (0 points)
I have an .ipsw for iPod Touch 3.1.2 3G firmware. I have a Mac (my primary computer), though I also have a Windows XP if that helps. I used iTunes to restore my corrupt iPod in recovery mode back to 3.1.2 using the .ipsw file. However, every time I try, it says that the firmware is not compatible. How do I get rid of this annoying message?

P.S. I tried Shift + Option + Click on Restore button but it told me that iTunes does not have the firmware (or something like that), and to uninstall and reinstall iTunes. I have tried that and it doesn't work.

iPod 3G, iPhone OS 3.1.2, 8 GB