13 Replies Latest reply: Jun 30, 2012 8:07 AM by czeggermurphy
anonxxx Level 1 Level 1 (0 points)
I am using Safari 5.0.1. I go to: http://www.google.com/ and type in my search. I get a list of hits and my search query (keywords used in the search) shows up in the box - all normal. The problem is that if I hit on one of the links and then hit the back button to return to my search results, my query is no longer in the box at the top. My search results are all still there, but the keywords I originally entered are not (just a blank box). Thank you.

Mac OS X (10.6.4)
  • Carolyn Samit Level 10 Level 10 (95,985 points)
    HI and welcome to Apple Discussions...

    Go to Safari/Preferences or Command , then select the Autofill tab. Click the Edit button next to: Other forms. Delete .google.com Now click the Security tab in the menu. Click: Show Cookies Remove all Google cookies.

    Relaunch Safari.

  • anonxxx Level 1 Level 1 (0 points)
    Thank you for the warm welcome! However, I don't have any of the AutoFill options checked and there are no sites to remove.

    Another problem I've been having is that my Gmail counter of unread messages which appears on the tab has not been updating correctly. Usually quitting Safari and relaunching solves that problem, but it is annoying too. Thanks in advance.
  • Carolyn Samit Level 10 Level 10 (95,985 points)

    Have you tried accessing Gmail via MacMail?

    Launch Mac Mail then from the Menu Bar click Mail / Add Account.

    More instructions here. http://email.about.com/od/macosxmailtips/qt/et_gmailosxmail.htm

  • anonxxx Level 1 Level 1 (0 points)
    Yes, I have, but I still like gmail in the browser That's not the major issue, though...

    The google search is what's bother me; hope I can find a solution!
  • anonxxx Level 1 Level 1 (0 points)
    Any other suggestions on the google search problem? I realized that my keywords are still showing up in the search bar the bottom of the page, but not the top.
  • anonxxx Level 1 Level 1 (0 points)
    As of this morning, this issue seems to be fixed!!!
  • anonxxx Level 1 Level 1 (0 points)
    The problem started again yesterday. Anybody else having this issue?
  • dakebusi Level 1 Level 1 (0 points)

    Having the same problem here, with Lion and Safari 5.1.3.


    I've disabled AutoFill for google and removed all cookies, but my search query is still modified after going back to google. It's quite annoying!


    How can I solve this?

  • Jochen S. Level 1 Level 1 (0 points)



    I have not exactly the same but a very similar problem with Snow Leopard and Safari 5.1.4.  When I use google.com and then enter a search query I come to the list of results. When I click on any item and go back (arrows on the top left) everything is fine here. When I specify then my search query by adding something and repeat the procedure everything works fine as well, but here comes the issue:


    - Starting from any webpage

    - typing into the Safari search bar on the top right my search query

    - specifying my search query by adding something into the html search bar on google's results page

    - clicking on any item and then going back to the results list

    - then the search bar of google just shows the original search query written into Safari's search bar on the top right.


    Sorry, that was complicated to explain ;-).

    I don't have that problem with Google Chrome or Firefox. I have tried what Carolyn suggested but it didn't fix the bug.


    Thanks for any further support!


  • StephenNg Level 1 Level 1 (0 points)

    I have the same problem as well. I enter a search phrase in the box. Move on to the next page, click on various links. Then when I return to previous page the search phrase changes to a previous search phrase even though I know I have not gone back so far. This is really odd and annoying because I don't know which search I am currently seeing. If I go further back to previous pages and then forward again, the search criteria I wanted reappears. So its not lost from the stack, but as I said its quite annoying because I don't know which search is being returned to me.


    I noticed this problem some time ago and I thought I did something wrong. Now I know its not my fault.

  • czeggermurphy Level 1 Level 1 (0 points)

    I have been having this problem as well.  It is really starting to bug me (much harsher words spoken aloud).  i am not sure why this problem is not noticed by more people, it hapens to me all the time.  Is this an apple ploy to get us off of google?

  • TW300 Level 1 Level 1 (0 points)

    Having same problem as well - happens if I swipe to go back or hit the back button. It is VERY annoying as I quite often just want to amend my last search. Not sure when it started but have now had the problem for a few weeks (maybe months).


    Safari 5.1.7

    Mac OSX 10.7.4


    Is there a Log that tells me when and which versions of Safari I have installed previously?





  • czeggermurphy Level 1 Level 1 (0 points)

    Ok, From another thread on which I posted the same question I got a response from a fellow in Japan.  He suggested... go to your google search preferences.  in the "Google Instant predictions" section select "Never show Instant results"


    I did this and the problem is corrected.