13 Replies Latest reply: Apr 27, 2013 2:15 PM by teree03
Rich-Seven Level 1 Level 1 (0 points)
I have a NetGear WNDR3700 router and I simply can't connect my new iPhone 4. It finds the right SSID, but after I enter the password (yes, I'm sure that the password is correct), I got 'Unable to join the network'.

No issue with other iPod Touch 2G and my wife's iPhone 3G.

Anyone run into the same issue ?


iPhone 4, iOS 4
  • Iskor12 Level 1 Level 1 (55 points)
    This could be a couple of different problems.

    1.) Move your phone closer to the router. I can often times pick up a signal, but my phone wont connect unless I am closer to the router.

    2.) Don't cover the top left side of your phone with your hand. You hand can block some of the signals and degrade your connection quality.

    3.) If one and two don't work, then unplug your router and wait for a minute. Then plug it back in. After it gets done booting back up, try to connect to it again.

    4.) How many wireless devices are connected to the router? There is a limit. : )

    5.) If everything else didn't work, contact apple.

    Message was edited by: Iskor12
  • Mustang7708 Level 1 Level 1 (45 points)
    I have the same router and it works just fine with my iPhone 4, iPhone 3G, and iPad. Have you updated the firmware to the latest version? I just got my Netgear router and out of the box there was a firmware update available. I installed it immediately so I don't know if I would have had problems prior to the update. Also, try resetting your router by unplugging the power and then plugging it back in. Have you been able to connect to other wifi networks? Try rebooting your phone by holding the home button and the power button on the top right corner until you see the Apple logo. Just ignore the message to slide to power off and keep holding until the Apple logo comes up.

    I know this is not much help, but hopefully you will get it working.

    Good luck.

    Message was edited by: Mustang7708
  • forumalias Level 1 Level 1 (40 points)
    Something else to try is to disable wireless security on the router and see if the phone associates to the wireless network okay. If it does then you know you need to tweak security settings a bit when you turn it back on.

  • Radeon123 Level 1 Level 1 (30 points)
    I have that router and it's working great with my iPhone 4.

    The security I use on both the 2.4ghz and 5ghz is "WPA-PSK [TKIP] + WPA2-PSK [AES]" mainly for compatibility with older devices.

    You may also want to try and set the 2.4ghz wireless speed to "Up to 130Mbps" instead of "Up to 300Mbps" via the router settings > Wireless Settings on the top left, because I found some devices have connectivity problems or do connect and then run incredibly slowly on the "Up to 300Mbps" for some reason.
  • Rich-Seven Level 1 Level 1 (0 points)
    I tried removing the security options and it won't connect either, so really so sure what is the issue.
  • dahammer1 Level 1 Level 1 (45 points)
    Ok try this:
    A)Shut down router. Remove power cord. Wait 1 to 2 mins.

    B)While waiting
    Ba)go to settings on your iphone
    Bb)select wifi
    Bc)select netgrear and remove netgear from iphone

    C)Shut down iphone and all your connected toys

    D)Plug power back into router and turn on. Wait till it's done booting up.

    E)Turn on Iphone go to settings, wifi and wait for iphone to see your router.
    When it finds it enter your key.

    F)Now go to safari and see if you got internet.
    If you do great.

    G)Turn on 1 at a time all your toys. Do so 1 at a time.

    Hope this helps.
  • doc9090 Level 1 Level 1 (0 points)
    I have had the same issue with an Ipad (had to return it) and now a new 4G Touch?

    any ideas? other laptops and my old 3g touch all connect fine to my network Netgear WNDR3700 router

  • nmiller67 Level 1 Level 1 (0 points)
    I was having a lot of trouble with my WNDR3300 connecting but dropping frequently and when it was connected it might as well been a dial up connection as it was horrible.

    What fixed my issu and made it a great performance was changing the security option. (Not sur why but it was recommended for the BlackBerry on netgear forum so i tried it.)


    This worked for me and I get super performance, range, etc since making the simple change.

    Hope it helps.
  • solario Level 1 Level 1 (0 points)
    I'm having a similar problem, except I just can't seem to find the network at all. I've tried all the mentioned solutions without it helping. I have the same router and the iPhone 4 with the 4.2.1. OS.
  • Rudegar Level 7 Level 7 (22,130 points)
    update the firmware of the router they fix bugs all the time even on many
    older routers and put out new firmware on their website
    (the router manufacture that is)
  • solario Level 1 Level 1 (0 points)
    Sadly, that didn't help. Are there any other things I can try? Besides all the aforementioned.
  • Rudegar Level 7 Level 7 (22,130 points)
    well if you don't see the network at all you can try typing in the ssid manually
    if the router is not set to broadcast it
    and you can also check if the router is set to filter on mac address and if your iphone's mac address is added to allowed devices

    and it seems that ios devices may not like the enterprise / professional encryptions much so if your using that try the normal wpa2 aes
  • teree03 Level 1 Level 1 (0 points)

    Thanks Radeon123 - changing the settings absolutely solved my problem. My iphone was connecting flawlessly until one day it wasn't. Tried all sorts of solutions and yours worked! Still don't know why the settings changed or why it ceased to connect.