10 Replies Latest reply: Dec 16, 2010 1:19 PM by v8media
Mark Dannau Level 1 Level 1 (110 points)
Hello to all,

I can remotely access my osx server's screen from my iPad with iTeleport. I can also remotely access my shared calendars from my iPad (that one was easy).

But I have yet to find a way to access my shared files from my iPad. I do this from my Macbook through the MobileMe "Back to my Mac" feature.

Can someone please give me at least a lead as to which direction I should start looking to find a solution.

Thanks, Mark

 Mac Mini Server  MB 2.2 WH  MB 2.4 BL + 3 x  Mac Mini Core Duo 1,66 combo, Mac OS X (10.6.4)
  • Osamede Level 1 Level 1 (0 points)
    You could install Dropbox on the Mac and on the Ipad.
  • Mark Dannau Level 1 Level 1 (110 points)
    Thank you Osamede, but I really need to be able to access ALL the files on my server and not just a few. I will not dump all my files on an external server either (which is the way Dropbox works it seems).
  • Osamede Level 1 Level 1 (0 points)
    Well, you'll need a real computer then, not an iphone on steroids...

    Anyway seriously, you could do some research on things like Anyclient, Files HD and other similar WebDAV products.

    Or just
    1) Turn on the Remote Desktop/Remote Management service on the OSX server
    2) install a VNC viewer on the ipad to access the remote desktop service.

    I would recommend the VNC client from Mocha: http://www.mochasoft.dk/iphone_vnc.htm), which allows you to create a remote desktop connection to the Server, at which point you have full control of the server from the ipad, allowing you to view and manipulate (ie edit, move, play media etc) everything on it.

    I use the iphone version of this Mocha software which is viable but very awkward on the small screen of the iphone 3GS. I suspect the experience would be better with the larger, higher resolution screen of the Ipad. I also use their Windows-based VNC viewer to access my Mac Mini OS X Snow Leopard server from my laptop and that works fantastically well.

    Message was edited by: Osamede
  • MrHoffman Level 6 Level 6 (12,980 points)
    What do you expect to happen when you access the files?

    Are you looking for file transfers?

    Processing the contents of the files?

    Changing file attributes?

    Transferring the files to the iOS box, and then passing them along to some apps? (Which apps?)

    Something else?

    iOS is not a replacement for a MacBook Pro. There are definite limits with what you can do with the platform, and getting arbitrary files transferred and processed locally under iOS is one of those areas.
  • Kevin Zittle Level 2 Level 2 (155 points)
    Hi Mark,

    Off topic, but how did you get iTeleport to work with your server?

    I cannot seem to get it to work, I keep getting an authentication error that the server does not allow password based authentication. Any ideas?

    Kevin
  • MrHoffman Level 6 Level 6 (12,980 points)
    Not much info there; no info on how you're trying to connect to the VNC server.
    Start here: [iTeleport support|http://www.iteleportmobile.com/iphone/support].
    If the information posted over there doesn't solve this, there's a support email address posted there.
    (And please don't thread-jack; it leads to confusion. New threads also let you close the thread, etc.)
  • Warwick Teale Level 3 Level 3 (580 points)
    HI Kevin, fwiw, I have a new headless macmini with osx server 10.6.4 (headless) on it and also get authentication errors trying to use Mocha VNC from my iphone 4 to this host.

    FWIW, access using this to the plain vanilla OSX 10.6.4 on this macpro 2009 works fine form the iphone.

    looks like some issue with settings in osx servers' "remote management".

    I also cannot get it to connect as above on the osx server 10.6.4 work from exSHARE's desktop on the phone 4 . Also tried using exSHARe's desktop sharing sing SSH... smae issue.

    back to osx server issues I think

    will post if I resolve and will watch this thread.

    w
  • daveblair Level 1 Level 1 (5 points)
    Did you come up with a solution for this? When I had a similar goal with my iPhone, the solution that worked was to turn on SMB sharing and then install NetPortal App and use it to make the connection.

    Dave
  • Pixelthing Level 1 Level 1 (0 points)
    The app "ezShare Pro" looks like what you might need - it looks like the dropbox browser but accesses SFTP, webdav, SMB and most importantly AFP as well. I'll download it and try it out - I'm expecting a bit of a kludgey interface, but functional.

    http://itunes.apple.com/gb/app/ezshare-pro/id301589535?mt=8

    Ignore the "get a macbook" crowd - sure the MacBook for heavier lifting, but if I have keynote/pages/numbers on my iPad, I expect to be able to access files to use the tools on too. The iPad is not just for downloading **** apps and watching youtube on.
  • v8media Level 1 Level 1 (15 points)
    If you try that, definitely report back. It looks like it has a lot of poor reviews because they broke their old versions, but it sounds like if you delete the app and set things back up it works again. The ratings before the break seem promising. Hard to believe that this is the only iOS app that can do AFP.

    Ian