Previous 1 7 8 9 10 11 Next 162 Replies Latest reply: Aug 22, 2015 8:43 AM by Bstreet Go to original post
  • Samuel White Level 1 Level 1 (0 points)

    DOCSILO has got the answer! Twisting the cards cut out corner slightly against the roof of the slot whilst pressing in works a charm.

  • coolsacha Level 1 Level 1 (0 points)

    Bizarre! I have to insert the card while applying an anti-clockwise force and it pops straight up. The iphoto thing makes no difference.

  • catfisher52 Level 1 Level 1 (0 points)

    We got tired of trying to reinsert the SD card and came up with the bright idea of using the Bloddy fire wire cord that came with our camera and walla we downloaded our Bloddy sacred pictures, now I can sleep tonight, that bloddy SD card

  • rlalani Level 1 Level 1 (0 points)

    DOCSILOhas the answer, it worked for me

  • FOHA Level 1 Level 1 (0 points)





    I also had this problem with my MacBook. I tried compressed air and twisting the card, but nothing work. I finaly gave it a good soak of some good contact cleaner, and BINGO! it finaly brought my sd-card reader back to life. I noticed that if i press the card fully in, it not work.

  • morph85 Level 1 Level 1 (0 points)

    I had successfully repaired my SD card reading problem.

    There are a few possibilities:


    1. Card contact point or dust issue.

    - This is unlikely to happen with your new MBP and the contact point for newer MBP is pretty tight.


    2. Broken SD card adapter

    - Make sure you use a descent adapter.


    3. Still connected with your VM

    - For example: VirtualBox VM, make sure you:

    -  disconnect any USB device in VM and shut down properly.

    -  unmount any virtual disk in virtual machine.

    -  in Setting > Ports > USB > Enable USB 2.0 (EHCI) Controller, uncheck it.


    4. Nothing happened with the step you tried?

    - quit VM entirely and open Utility >

    - see the log file and troubleshoot any irregularities.


    5. Repeat step 1 - 4.

  • smunter Level 1 Level 1 (0 points)

    I have only had this problem for 2 days, thought it might be a software issue but tried all the solutions suggested on here, the only one that worked for me was cleaning out the SD card reader as best I could with compressed air, and then putting the card in gently (not forced in all the way)


    Hopefully this solves it for someone else too!

  • smunter Level 1 Level 1 (0 points)

    Ok dissregard that, the SD card magically ejected itself and now i cant get it back again...FAIL!

  • Link2999 Level 1 Level 1 (0 points)

    Found a solution that worked for me. Turns out a little, tiny piece of lint got stuck in the back left corner of the slot. Got a flashlight and a toothpick and fished it out. Now it works fine! Guess it has to be pristine in order for it to accept cards.

  • PenelG Level 1 Level 1 (0 points)

    Similar to other suggestions on here, the mechanical solution worked for me. I hadn't been able to get my Mac to read any SD cards in months, and all the terminal and safe boot suggestions hadn't worked. So finally I folded up a piece of card and pushed that in there a few times, combined with lots of blowing air into the slot, and finally pushing on the little switches with the end of a paper clip. Success!

  • jaiman003 Level 1 Level 1 (0 points)

    Wow this actually worked, thanks

  • GLYNPH Level 1 Level 1 (0 points)

    Open i-photo..

    Simple but effective..

  • AK9876 Level 1 Level 1 (0 points)

    I just brought a new MacBook Air and have experienced the same problem, SD card reader does not read the card. I needed to tilt the card upward when inserting. I guess it must be a contact issue. Hope it works for you guys too

  • InquisitorKaoz Level 1 Level 1 (0 points)

    Incredible! it works!, it didn‘t work the first time, but then from the secnd try it started working.


    In the past it used to work normally, it doesn't anymore.


    Even after having success with this trick, if I put it normally it still doesn't work.


    The moral of the storyis that raw force does solve issues some times!


    Thank you Docsilo for sharing your solution!

  • tomahony Level 1 Level 1 (0 points)

    Make sure you get a flashlight and have a good look into the slot! I thought this was a software issue but when I looked down the slot it turned out there was a small piece of plastic stuck down the back. It had become jammed behind the small raised pieces of metal that read the SD card and needed a toothpick to be prised out.