Previous 1 2 3 4 Next 162 Replies Latest reply: Aug 22, 2015 8:43 AM by Bstreet Go to original post
  • Nalfeindo Level 1 (0 points)
    I've managed to find a solution! After months of fighting with my SD card reader, that one day just turned irresponsive... I've found a solution!

    I am using VMware Fusion to run virtual windows machine on my mac. I suspected that my sd card could be "stuck in windows". So today I started up virtual windows, connected Internal Card Reader (through settings for USB in vmware) and after a couple of tries - managed to mount SD card in windows. Then I "Removed Safely SD Card" in windows and just in case disconnected internal card reader from windows (settings in vmware again).

    And voila - after turning windows off - SD card appeared miraculously in Mac again!

    Hope that helps!
  • eww Level 9 (52,975 points)
    Ah, yes. The simplicity and convenience of Windoze at work again.
  • adamab123 Level 1 (0 points)
    Hi guys !

    _*I have just fixed the whole problem with the SD card*_, the only thing you need to do is to start iPhoto and the card will appear on the desktop and in iPhoto.

    I had the same problem with my iphone when i wanted to use theathering and my computer didn't find my iPhone so the only thing i needed to do to solve the problem was to open itunes and teathering started.

    It's almost like you need to wake the SD reader up with iPhoto, really weird but true.
  • dorusdevries Level 1 (0 points)
    I've got the same problem and starting iPhoto doesn't work, and i'm not using some virtual machine for windows or something..

    But I won't doubt it hasn't got something to do with iPhoto, because it used to work fine and somehow for many of us it stopped working at a particular moment (that we probably have in common).

    Hope somebody got the answer soon!
  • DOCSILO Level 1 (0 points)
    I was having same problem with my Imac not finding SD cards. Seem to have found this out by accident.
    I inserted the card at a slight angle, holding the cut off corner against the top of the SD slot and then pushing card in. It has loaded every time.
    Hope this works for everyone.
  • Ali Kerim Level 1 (0 points)
    Yes, it works!!

    You should open iPhoto first then insert your SD card. This way your SD card will appear in iPhoto and desktop. The root cause for this issue may be about OS considering our SD cards as photo devices.

    There must be better fix letting us see the card without iPhoto. Hey Apple! Can you hear me?
  • Richard Cartledge Level 2 (435 points)
    Bizarre! Mine does this too. I have to insert the card while applying an anti-clockwise force and it pops straight up. The iphoto thing makes no difference.
  • Highspin Level 1 (0 points)
    I have the same issues with my SD card reader. Sometimes my Mac finds the card at the first time, sometimes after 10 or 15 times trying.

    The above described trick with iPhoto is not working on my Mac.

    The System Profiler recognizes the card reader. If a card is recognized, the Disk Utility shows that 42MB are used, but 0 files on the disk. The photos on the card using approx. 31MB.

    Message was edited by: Highspin
  • JLF SC Level 1 (0 points)
    Same problem (which is new in last month) with SanDisk CompactFlash. Only after removing card reader completely for a good while do I sometimes (still intermittently) get the Card Reader to appear in Finder.
    I do a lot of photo editing in Photoshop, Lightroom and Photmatrix so this is a real pain. I wish someone could offer a real fix other than things like rebooting, plug it in again, etc. I personally think its a recent bug in OS X 10.6.7. Never had this issue before. I don't use iPhoto, though did try that idea to no avail.
  • JLF SC Level 1 (0 points)
    I'm pretty sure this is a Snow Leopard OS X 10.6.7 problem. I tested my card reader on my wife's iMac, which is still using OS X 10.5.8. Thankfully have not upgraded her's to Snow Leopard yet. The card reader with a SanDisk CompactFlash is immediately recognized on the earlier 10.5.8 op system. I ejected and re-inserted the card numerous times.
  • pauldowns Level 1 (0 points)

    Apple:  fix this!  None of the above ideas have worked for me, this is a real pain.  I also think it's a problem with 10.6.7

  • elainefromtoronto Level 1 (0 points)

    The compressed air worked like a charm! Thanks!

  • KCM_SAT Level 1 (0 points)

    Compressed air + opening iPhoto and then inserting the SD card worked for me.

  • DWFaust Level 1 (25 points)

    This is incredibly maddening. I spend over $2000 on my new Macbook Pro and I can't read a $60 Sandisk SD card?


    Sorry to all of you who claim to have "fixes"... nothing works...


    One thing that I have noticed is that it seems to be related to the size of the card.  It seems to reliable recognize 2GB cards... but not consistently recognizing anything larger. The specs say the card reader is compatible with SD ( => 2GB), SDHC (2GB > 32GB) and SDXC (32GB > 2TB)... but that would indicate that it's only functional at the SD spec.  Huge Apple fail.


    Now, what is our recourse?

  • ShaunyH Level 1 (0 points)

    This is a massive fail. I just spent $600 on a new panasonic ft3 with gps tracking and $90 on 2 x class 10 SDHC cards and I can't even get my photo's into Iphoto because my cards won't read.


    I am using an 8gb Sandisk extreme class 10 SDHC card and trying to load it onto my 2011 13' macbook pro.


    The card will be detected in finder straight after being formatted in my camera, however once it has been taken out and had a couple more photos taken on it finder won't detect it anymore.

    I have spent hours searching forums and the apple website for some indication of the problem but have found nothing. Like DWFaust all the fixes I have seen don't actually work and with the specs of the mac pro you shouldn't have to jump through these hoops for something so simple anyway.


    Has anyone had any luck with using a usb SD adapter? I have heard mixed results depending on adapter types, etc. Would love to know if a certain brand/spec is required before i go out and waste more money. I really need a solution to within the next day or two.


    Really hoping Apple can fix this soon or at least give an indication of how we can get around this.

Previous 1 2 3 4 Next