Previous 1 5 6 7 8 9 Next 160 Replies Latest reply: May 2, 2015 7:06 PM by rubli Go to original post
  • Luis Flores Level 1 Level 1 (0 points)

    OK, I had the same problem and I found a solution. What I do is to insert the card slightly slanted, pushing it from the right corner only (viewing the card from the top).

    I hope it helps.

  • Gavin4077 Level 1 Level 1 (0 points)

    Having looked in the slot on my 2011 Macbook Pro with a torch, I noticed quite a lot of dust in there. Used an aerosol air duster, inserted a card and it works perfectly!

     

    I think a lot of you might find the same. The slot is going to pick up dust and debris and it's causing a bad contact with the SD card.

     

    If you've cleaned the dust away and it still doesn't work, try gently wiggling it around too.

  • ScooterD68 Level 1 Level 1 (0 points)

    Had this same experience - using a Macbook Air 1.7 GHz i5, 4Gb RAM, 256 Flash.  SD mysteriously stopped working several weeks ago.  Didn't correlate it with install of Windows 7 and VMWare Fusion to access the Bootcamp partition.  Did bascially the same thing as this post - boot Windows 7 on VMWare, enable and capture the SD slot for Windows, insert card (it will be recognized), gracefully eject card in Windows, tell VMWare not to map the SD slot and set it to give control of SD to OS X when things are inserted, disable the future capture of SD by Windows.  Now, when I insert SD cards in OS X, it recognizes them consistently.  Clearly a deep config setting that is slightly confused or not released/re-written when you install Bootcamp and port it to a VMWare Fusion session.

  • Jorge Dem Level 1 Level 1 (0 points)

    I actually have a simpler solution, at least this worked for me.

     

    I was having the intermitent reading problem and took it to a Mac Store, the guy fixed this in a snap, he didn't even open the case.

     

    This was his solution:

     

    http://support.apple.com/kb/HT1379

     

    Worked for me, hope this works for you all too.

  • Blue_eyes Level 1 Level 1 (0 points)

    Since my solution (blowing out the slot) now does not work for me, and I have tried everything else, I tried zapping the PRAM. No go. Absolutely nothing. So many solutions offered and yet I have not tried one that works (and keeps working). C'mon Apple, step up to the plate and find us a solution--one that works for everyone all the time!

  • uillis Level 1 Level 1 (0 points)

    I finally got it to work by sticking a tiny screwdriver tip into both side top indentations of the adaptor.

  • alex_odessa Level 1 Level 1 (0 points)

    thank you! it worked!

  • 2re1979 Level 1 Level 1 (0 points)

    Ok, had the same problem as everyone is talking about, browsed the forums, tried updating, blowing etc.

    No use.

     

    By coinsidence my Parallels VM (Win xp) crashed, and I had to delete and reinstall the virtual .

    Now the SD slot works!

  • Speedy308 Level 1 Level 1 (0 points)

    I had the same problem after owning my MBP for 1.5yrs. I had ran Parallels for about 1yr of that. Come to find out that is what made my card reader not work yesterday, i uninstalled Parallels and went into the device settings, selected card reader, then unchecked it and it made my card reader work again. Thanks for the advice 2re1979!!! I am now removing Parallels for good and going to do boot camp.

     

     

    Update: I am unable to remove Parallels as it makes my SD card reader not work again....looks like I have to keep it installed.

  • DD445 Level 1 Level 1 (5 points)

    I had the same problem on my black MacBook running 10.6.8. My Kingston 8GB SDHC card, inserted into a SanDisk MobileMate SD+ reader, would be detected in the Finder, but not in iPhoto.  I simply deleted the cache in the com.apple.iPhoto folder by going to Macintosh HD>Users>(me)>Library>Caches>com.apple.iPhoto, then dragging the tiny file within that folder to the trash.  Empty the trash, restart, and now my 8GB card, when inserted into the reader, automatically opens iPhoto and gives the normal option to Import - just the way it's supposed to.

  • DD445 Level 1 Level 1 (5 points)

    Thanks for taking the time to post your solution, Mark.  I had the same frustrating issue on my black MacBook. Since deleting the Cache.db file in my com.apple.iPhoto file, my issue has been fully resolved.  Suddently, life is good again.

  • Blue_eyes Level 1 Level 1 (0 points)

    The other problem still remains--not showing up in the Finder at all. This has fustrated me to no end. I can't use my MacBook Pro the way I had hoped to when it comes to downloading from my camera's cards. It has been literally months and months that this discuss has been running and the silence from Apple is deafening!! Where is the renowned customer service and care?

  • heyknotty Level 1 Level 1 (0 points)

    Not sure if this helps but I am having the same issue on my iMac since installing Lion.  Not an ideal fix but I put the Disk Utility as an icon on the desktop.  (You can find it under Applications/Utilities/ Disk Utility).  Each time I put a card in the slot I open Disk utility and select the card then click on the "Mount" icon.  It now appears in iPhoto or imovie as it used to do automatically.  A pain but a fix until Apple resolves the bug.

  • kevmille Level 1 Level 1 (0 points)

    I had dust in mine as well, I blew in it and it worked.  Simple solution.

  • rravinoff Level 1 Level 1 (0 points)

    "I have to insert the card while applying an anti-clockwise force and it pops straight up." Great tip. This works for me too!

Previous 1 5 6 7 8 9 Next