11 Replies Latest reply: Oct 26, 2012 10:23 AM by SquidlyMan
Hemiolia Level 1 Level 1 (0 points)
I can't put into words how frustrated I am with this. I've been working on this for a few weeks now.

I have gone through the painful process of performing a clean reinstall of iTunes on a cleanly reinstalled OS (Windows7).

Everything appeared to have gone well until the time came to sync my apps/music/movies. At 99% of the entire sync progress, I get a message "Attempting to copy to the disk "xxx's iPhone" failed. An internal device error has occurred".

This is my second iPhone that I've had to exchange. I've set this phone up as a new device, never restoring from a backup so as to eliminate the possibility of "bringing in" some previous problem.

Any help would be greatly appreciated.

PC, Windows 7, 64-bit
  • Hemiolia Level 1 Level 1 (0 points)
    Just to add more information, my iPhone has been returned and exchanged because after syncing for the first time after taking the device home, my apps won't launch. In other words, tapping on an icon only "appears" to launch it for a brief moment and then it takes me back to the home screen.

    I have made sure I made good faith efforts to fix this on my own by reading up on these forums, which I found to be useful, and helpful in answering other questions. However, this problem persists. Inevitably, during syncing, I'll get various messages like "Internal device error has occurred", etc.

    Is it possible that I got two bad iPhones in a row? I have a hard time believing the problem is on my side being that I have been able to replicate this problem even AFTER wiping out my hard drive, reinstalling my operating system and iTunes afresh.
  • Hemiolia Level 1 Level 1 (0 points)
    Not answered, but I might return this and go with the evo.
  • BeejNet Level 1 Level 1 (25 points)
    Hi,

    May I suggest that you try syncing with a different computer/laptop to see if the problems persist? Just that there's a possibility that the USB ports on your current computer have some sort of fault.
  • iZian Level 1 Level 1 (70 points)
    /Agree

    Could be a USB root hub failure
  • jarhead.0627 Level 1 Level 1 (0 points)
    Just purchased iphone 4 (very first iphone). Long story short, was having the PRECISE problems you described - same error messages - after installing several new apps. Error messages were: "the iphone "xxx" cannot be synced" followed by "An internal device error occurred" and "A folder was specified instead of a file". Additionally, all of the older apps functioned as expected, but the newer freshly installed apps would appear to open, then close immediately (as was your case, I believe.)

    After uninstalling the apps from my iphone, removing the apps from itunes, restoring my phone, etc..., the errors continued. The solution was at the bottom of this thread - I tried one of the other USB ports on my computer and it worked like a champ. No more sync/internal errors; iphone syncs without errors and apps run without a problem.

    I hope this is also the solution to your problem. Best of luck to you.

    jarhead.0627
  • PolarBear2k Level 1 Level 1 (0 points)
    I had the same issues and using a different USB port allowed me to sync with no problems.

    Thanks
  • SpyglassSally Level 3 Level 3 (680 points)
    Turn off any antivirus, spyware, firewall etc on your pc. Reset your ipod and try connecting using a different USB hub.
  • Bilbo_85 Level 1 Level 1 (0 points)
    Well i tried the different usb port and it worked like a charm. Thanks for the info i was getting worried!
  • Ktoens Level 1 Level 1 (0 points)

    PERFECT!!  Solved my problem!!

  • rlowe123 Level 1 Level 1 (0 points)

    Just had the same issue syncing iphone 5 for the first time.   It worked at first, then got the error.   I moved it from USB3 to USB2 port, and problem solved!

    Thanks everyone.

  • SquidlyMan Level 1 Level 1 (0 points)

    I had the same issue with my iPad 2 and I just had to reset the power on the hub (in this case, my 27" cinematic display).  You don't need to unplug the monitor (at least, I didn't). Just unplug the USB cable and reattach.  Seemed to do the trick as now it's syncing fine.