12 Replies Latest reply: Apr 9, 2011 6:01 AM by Thumbmaster
Dave DeLong Level 1 Level 1 (15 points)
I recently had to reinstall the OS on my MacBook Pro. I used MobileMe to sync a bunch of my settings back to my computer (including Keychains), and now I can't see any of my Keychain passwords. If I try to view an item and check the "Show password" or "Show note" checkbox, I get a little alert that says "Access to this item is restricted". However, the Access Control tab for that same item has the "Allow all apps access" option selected, with the description saying "Access to this item is not restricted".

Things I've found/tried:

- Keychain First Aid reports no errors with my keychain.
- There is nothing in my ~/Library/Keychains/.syncinfo folder.
- Creating a new default keychain a re-syncing from MobileMe does not fix the issue.

What do I need to do to fix my keychain? I have a bunch of stuff in there (mostly application license keys) that I'd rather not lose.

MacBook Pro 2.8GHz (Mid 2009), Mac OS X (10.6.4)
  • Thumbmaster Level 1 Level 1 (25 points)
    I'm having a very similar issue on my MacBook. It started out as Keychain refusing to store new items via Safari. Then it evolved into MobileMe password not being saved and thus refusing to sync. I can go into MobileMe prefs and manually force the password in so I can sync for that session, but the password is not saved the next time I opened the prefs. The other Macs that sync to the same set of data are not affected. Like Dave, I've tried deleting the keychain and let MobileMe replace it from the cloud. I've also tried to replace the cloud copy with a good copy from another Mac, then sync that copy to the MacBook. I've also tried it on a fresh user account on the MacBook. None of it worked. Trying to access a keychain item results in "Access to this item is restricted". Can anyone shed some light into this? My last resort would be to wipe the drive and reinstall everything from scratch. I'm trying not to have to do that if there's another solution.
  • Jamie Jordan Level 1 Level 1 (25 points)
    I have the same problem on a brand new MacBook Pro. I've been in discussion with Apple Support. They say it is a Mobile Me issue. So I've been in several discussions with people there about this and it has been escalated but they are very slow in getting back to me about this. My first contact with them about it was November 10th, 2010 and still no resolution.

    I've reset my keychain, rebooted, deleted the MobileMe name and password. Reentered it which does write to the keychain and then things will work for a day or 2. But in the end I get the "Can't write to keychain" error from System Preferences, "Problem contacting the server" and "Access to that item is restricted" when I try to see the password in the keychain.

    If I get a solution I'll come back and post it here.
  • f.hintsch Level 1 Level 1 (10 points)
    Any advance on this issue?
    This prob is spreading out on my several mac accounts that are sync'ed via MobileMe. It is certainly a MM issue. Sometimes I have "item restricted" on my Macbook, now it has been moved to my iMac. I become nervous...
  • Thumbmaster Level 1 Level 1 (25 points)
    Still no fix. I've spoken to 2 Geniuses and they can't offer a solution either. In fact, one of them swore he's never seen this problem before. Does anyone else have any luck with this?
  • mhmcfee Level 1 Level 1 (5 points)
    I'd forgotten about this infuriating bug (no way to just do an 'export', no way to fix sync **** other than a lot of deleting). I got a new laptop and made the mistake of sync'ing the keychain from my desktop.
    I just spent 20 minutes hitting the return key 800 times... sigh

    Thank god 1Password works right.
  • baltwo Level 9 Level 9 (62,205 points)
    For all (note I don't have a MobileMe account or sync stuff):

    If you want to report this issue to Apple's engineering, send a bug report or an enhancement request via its Bug Reporter system. To do this, join the Mac Developer Program—it's free and available for all Mac users and gets you a look at some development software. Since you already have an Apple username/ID, use that. Once a member, go to Apple BugReporter and file your bug report or enhancement request. The nice thing with this procedure is that you get a response and a follow-up number; thus, starting a dialog with engineering.
  • Bob Jacobson Level 1 Level 1 (115 points)
    It's sad how many of these vital questions are piling up. It's as if Apple is assigning all of its talent to further developing the iPhone and iTunes, because that's where the money is, and leaving basic operational questions for users to solve on their own. On this issue, I also consulted Express and the answer I got after a lot of futzing was "reinstall the OS." I just reinstalled the OS on my Air using the thumb drive, and it didn't fix this problem. I'm surmising it has something to do (in our household, at least) with the upgrade to 10.6.7, because suddenly all four Macs in our household developed the same bug. Pretty sad.
  • random47 Level 1 Level 1 (5 points)
    I have found over the last few years that syncing can cause more problems than it solves. I have ruined off syncing off all my macs.

    I have found that using a USB flash drive is the best way to keep my macs in sync. Just copy your keychains from one computer to another. If you have a MobileMe account, copy your keychain to your documents folder on the account and have all your macs access the file.

    I also, have noticed that once syncing problems start, they are almost impossible to fix. My calendars have been messed up for over a year now. Even when I delete a repeating entry, they come back. Even deleting a calendar comes back, and I have syncing turned off. I deleted all preferences for iCal on my MacBookPro and the next day I find all the calendars from my PowerMacG4 on my MBP. How are they getting there?

    Syncing with MobileMe can cause another problem. That is duplicating items. At one time, every time I restarted my MBP, I had another copy of my login keychain. The list came to 16 before I stopped syncing.

    The problem I would like to solve now is, why is the Export items... menu item always grayed out? Is this a bug or has Apple not implemented it? I find no reference to the menu item in the help system.
  • takeitup7 Level 1 Level 1 (0 points)
    I turned on keychain sync and now all **** has broken loose on my desktop Mac.

    I cannot retrieve e-mail with any of my primary accounts, no matter how I try to reset them.

    It's almost as if the keychain file on my mac pro is both corrupted/incomplete and locked.
  • Thumbmaster Level 1 Level 1 (25 points)
    After months of battling this issue, I think I've finally got it licked. I wish I'd documented the steps better. But here's from the best of my recollection:

    I knew for a fact that the sync data (calendars, address books, etc) on my iMac was good. Therefore, I went into every other Mac and turned sync off. Then I had the iMac replace all sync data on MobileMe with the local copy. I then turned sync back on one Mac at a time and let MobileMe replace everything on the Macs. All through this time I left the iPhone alone (it syncs with the iMac and MobileMe). It's been about 2 months now and so far (touch wood) everything's been working as it should. I still have little nagging issues with notes not syncing correctly but everything else is working as it should.

    I hope this helps.
  • Bob Jacobson Level 1 Level 1 (115 points)
    I took it to Express Lane, where a second- or third-level guy didn't have an answer. His solutions simply didn't work. He bumped it sideways to Engineering but I've heard nothing yet.

    My solution was to erase the exiting Keychains -- literally, going into ~Library/Keychains -- on the two machines where I had transferred them from my main machine, rebooting the machine, then reentering the new keys as I encountered requests for IDs and PWs. It's working.

    It's a shame Apple won't simplify the whole process and make it ironclad.

    As for synching my machines, I use Synk Pro and its working great -- but support there warned me, don't try to synch Keychains or Applications: these categories are simply too idiosyncratic.
  • Thumbmaster Level 1 Level 1 (25 points)
    Thanks, Bob! I forgot to mention that I'd also deleted the login keychain file on affected Macs before the other procedure. It seems letting MobileMe (iSync) take care of "replacing" the keychain isn't doing what it's supposed to do. Physically removing the file then letting iSync replace it from MobileMe does the trick. At least for now.